libtirpc/libtirpc-0.1.7-libtirpc-pc....

52 lines
1.3 KiB
Diff

commit 4d77b479511a27fb52b54811020176bb32099444
Author: Steve Dickson <steved@redhat.com>
Date: Mon Feb 18 17:30:46 2008 -0500
Added that libtirpc.pc.in that will create
the /usr/lib/pkgconfig/libtirpc.pc file that is
used by the pkg-config(1) command
Signed-off-by: Steve Dickson <steved@redhat.com>
diff --git a/Makefile.am b/Makefile.am
index 1a212e8..4e1503c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,6 +43,9 @@ nobase_include_HEADERS = tirpc/un-namespace.h \
tirpc/rpc/auth_gss.h \
tirpc/rpc/auth_des.h
+pkgconfigdir=$(libdir)/pkgconfig
+pkgconfig_DATA = libtirpc.pc
+
install-exec-local:
cp -p ./doc/etc_netconfig /etc/netconfig
chmod 0644 /etc/netconfig
diff --git a/configure.in b/configure.in
index dc597dd..e907c31 100644
--- a/configure.in
+++ b/configure.in
@@ -27,4 +27,4 @@ AC_CHECK_LIB([pthread], [pthread_create])
AC_CONFIG_FILES([Makefile src/Makefile])
-AC_OUTPUT()
+AC_OUTPUT(libtirpc.pc)
diff --git a/libtirpc.pc.in b/libtirpc.pc.in
new file mode 100644
index 0000000..df9e7ed
--- /dev/null
+++ b/libtirpc.pc.in
@@ -0,0 +1,11 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+
+Name: libtirpc
+Description: Transport Independent RPC Library
+Requires:
+Version: @PACKAGE_VERSION@
+Libs: -L@libdir@ -ltirpc
+Cflags: -I@includedir@/tirpc