- Added patch that creates a libtirpc.pc used by the pkg-config command.

This commit is contained in:
Steve Dickson 2008-02-18 22:54:33 +00:00
parent 2b23012f5d
commit deb8f75e55
2 changed files with 62 additions and 1 deletions

View File

@ -0,0 +1,51 @@
commit 4d77b479511a27fb52b54811020176bb32099444
Author: Steve Dickson <steved@redhat.com>
Date: Mon Feb 18 17:30:46 2008 -0500
Added that libtirpc.pc.in that will create
the /usr/lib/pkgconfig/libtirpc.pc file that is
used by the pkg-config(1) command
Signed-off-by: Steve Dickson <steved@redhat.com>
diff --git a/Makefile.am b/Makefile.am
index 1a212e8..4e1503c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,6 +43,9 @@ nobase_include_HEADERS = tirpc/un-namespace.h \
tirpc/rpc/auth_gss.h \
tirpc/rpc/auth_des.h
+pkgconfigdir=$(libdir)/pkgconfig
+pkgconfig_DATA = libtirpc.pc
+
install-exec-local:
cp -p ./doc/etc_netconfig /etc/netconfig
chmod 0644 /etc/netconfig
diff --git a/configure.in b/configure.in
index dc597dd..e907c31 100644
--- a/configure.in
+++ b/configure.in
@@ -27,4 +27,4 @@ AC_CHECK_LIB([pthread], [pthread_create])
AC_CONFIG_FILES([Makefile src/Makefile])
-AC_OUTPUT()
+AC_OUTPUT(libtirpc.pc)
diff --git a/libtirpc.pc.in b/libtirpc.pc.in
new file mode 100644
index 0000000..df9e7ed
--- /dev/null
+++ b/libtirpc.pc.in
@@ -0,0 +1,11 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+
+Name: libtirpc
+Description: Transport Independent RPC Library
+Requires:
+Version: @PACKAGE_VERSION@
+Libs: -L@libdir@ -ltirpc
+Cflags: -I@includedir@/tirpc

View File

@ -1,6 +1,6 @@
Name: libtirpc
Version: 0.1.7
Release: 15%{?dist}
Release: 16%{?dist}
Summary: Transport Independent RPC Library
Group: System Environment/Libraries
License: GPL
@ -45,6 +45,7 @@ Patch12: libtirpc-0.1.7-dgcall-iprecverr.patch
Patch13: libtirpc-0.1.7-svc-rtaddr.patch
Patch14: libtirpc-0.1.7-arm.patch
Patch15: libtirpc-0.1.7-bufoverflow.patch
Patch16: libtirpc-0.1.7-libtirpc-pc.patch
Patch100: libtirpc-0.1.7-compile.patch
@ -70,9 +71,13 @@ developing programs which use the tirpc library.
%patch13 -p1
%patch14 -p1
%patch15 -p1
%patch16 -p1
%patch100 -p1
# Remove .orig files
find . -name "*.orig" | xargs rm -f
%build
autoreconf -fisv
%configure --enable-gss
@ -105,6 +110,7 @@ rm -rf %{buildroot}
%dir %{_includedir}/tirpc/rpc
%dir %{_includedir}/tirpc/rpcsvc
%{_libdir}/libtirpc.so
%{_libdir}/pkgconfig/libtirpc.pc
%{_includedir}/tirpc/fpmath.h
%{_includedir}/tirpc/getpeereid.h
%{_includedir}/tirpc/libc_private.h
@ -149,6 +155,10 @@ rm -rf %{buildroot}
%{_includedir}/tirpc/un-namespace.h
%changelog
* Mon Feb 18 2008 Steve Dickson <steved@redhat.com> 0.1.7-16
- Added patch that creates a libtirpc.pc used by the
pkg-config command.
* Thu Jan 24 2008 Steve Dickson <steved@redhat.com> 0.1.7-15
- Protect from buffer overflow in the GSS code. (bz 362121)