New upstream release libtimezonemap-0.4.2

This commit is contained in:
David Shea 2014-05-02 11:18:12 -04:00
parent 3392e41b22
commit ac5525d0fc
18 changed files with 1268 additions and 3537 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/libtimezonemap_0.4.1.tar.gz
/libtimezonemap_0.4.2.tar.gz

View File

@ -1,7 +1,7 @@
From fc196f9d0c8ea0531183608dd7bcccc36fffd056 Mon Sep 17 00:00:00 2001
From 9148e44277d558b6f0ca2882e8b511bc31c27f04 Mon Sep 17 00:00:00 2001
From: David Shea <dshea@redhat.com>
Date: Wed, 27 Nov 2013 11:22:42 -0500
Subject: [PATCH 11/11] Added a glade catalog file.
Subject: [PATCH 1/2] Added a glade catalog file.
This allows CcTimezoneMap and CcTimezoneCompletion to be used in glade.
---
@ -99,5 +99,5 @@ index 0000000..a43e925
+ </glade-widget-group>
+</glade-catalog>
--
1.8.4.2
1.9.0

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

View File

@ -1,85 +0,0 @@
From 817161c4596df2fba45e5d801ed26ddc0bb4f4e2 Mon Sep 17 00:00:00 2001
From: David Shea <dshea@redhat.com>
Date: Thu, 14 Nov 2013 10:50:49 -0500
Subject: [PATCH 04/18] Update the GPL comments with the new FSF address.
The Free Software Foundation's address is now at 51 Franklin St. The
rest of the GPL v2 boilerplate comment is unchanged.
---
src/cc-timezone-map.c | 6 +++---
src/cc-timezone-map.h | 6 +++---
src/tz.c | 6 +++---
src/tz.h | 6 +++---
4 files changed, 12 insertions(+), 12 deletions(-)
diff --git a/src/cc-timezone-map.c b/src/cc-timezone-map.c
index 4d7fa40..60297e4 100644
--- a/src/cc-timezone-map.c
+++ b/src/cc-timezone-map.c
@@ -15,9 +15,9 @@
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
* GNU General Public License for more details.
*
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ * You should have received a copy of the GNU General Public License along
+ * with this program; if not, write to the Free Software Foundation, Inc.,
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
*
* Author: Thomas Wood <thomas.wood@intel.com>
*
diff --git a/src/cc-timezone-map.h b/src/cc-timezone-map.h
index 8a6bf9c..ddb6961 100644
--- a/src/cc-timezone-map.h
+++ b/src/cc-timezone-map.h
@@ -11,9 +11,9 @@
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
* GNU General Public License for more details.
*
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ * You should have received a copy of the GNU General Public License along
+ * with this program; if not, write to the Free Software Foundation, Inc.,
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
*
* Author: Thomas Wood <thomas.wood@intel.com>
*
diff --git a/src/tz.c b/src/tz.c
index 969119a..c294b44 100644
--- a/src/tz.c
+++ b/src/tz.c
@@ -17,9 +17,9 @@
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
* GNU General Public License for more details.
*
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
+ * You should have received a copy of the GNU General Public License along
+ * with this program; if not, write to the Free Software Foundation, Inc.,
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
*/
diff --git a/src/tz.h b/src/tz.h
index 3ade1f8..005d72f 100644
--- a/src/tz.h
+++ b/src/tz.h
@@ -17,9 +17,9 @@
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
* GNU General Public License for more details.
*
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
+ * You should have received a copy of the GNU General Public License along
+ * with this program; if not, write to the Free Software Foundation, Inc.,
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
*/
--
1.8.4.2

View File

@ -1,75 +0,0 @@
From 94fb062ff98ba6eab156493b3ad7ef210d175a79 Mon Sep 17 00:00:00 2001
From: David Shea <dshea@redhat.com>
Date: Thu, 14 Nov 2013 10:50:49 -0500
Subject: [PATCH 05/18] Create local copies of string properties.
The string values passed to set_property are owned by the caller, so we
need to create new copies of the strings to store in the private data
structure.
The dispose method already had code to free the private strings, but was
missing a check for the en_name property: added one.
---
src/tz.c | 24 ++++++++++++++++++------
1 file changed, 18 insertions(+), 6 deletions(-)
diff --git a/src/tz.c b/src/tz.c
index c294b44..8d83d0a 100644
--- a/src/tz.c
+++ b/src/tz.c
@@ -124,16 +124,20 @@ cc_timezone_location_set_property (GObject *object,
CcTimezoneLocationPrivate *priv = CC_TIMEZONE_LOCATION (object)->priv;
switch (property_id) {
case PROP_COUNTRY:
- priv->country = g_value_get_string(value);
+ g_free(priv->country);
+ priv->country = g_strdup(g_value_get_string(value));
break;
case PROP_FULL_COUNTRY:
- priv->full_country = g_value_get_string(value);
+ g_free(priv->full_country);
+ priv->full_country = g_strdup(g_value_get_string(value));
break;
case PROP_EN_NAME:
- priv->en_name = g_value_get_string(value);
+ g_free(priv->en_name);
+ priv->en_name = g_strdup(g_value_get_string(value));
break;
case PROP_STATE:
- priv->state = g_value_get_string(value);
+ g_free(priv->state);
+ priv->state = g_strdup(g_value_get_string(value));
break;
case PROP_LATITUDE:
priv->latitude = g_value_get_double(value);
@@ -142,10 +146,12 @@ cc_timezone_location_set_property (GObject *object,
priv->longitude = g_value_get_double(value);
break;
case PROP_ZONE:
- priv->zone = g_value_get_string(value);
+ g_strdup(priv->zone);
+ priv->zone = g_strdup(g_value_get_string(value));
break;
case PROP_COMMENT:
- priv->comment = g_value_get_string(value);
+ g_free(priv->comment);
+ priv->comment = g_strdup(g_value_get_string(value));
break;
case PROP_DIST:
priv->dist = g_value_get_double(value);
@@ -172,6 +178,12 @@ cc_timezone_location_dispose (GObject *object)
priv->full_country = NULL;
}
+ if (priv->en_name)
+ {
+ g_free (priv->en_name);
+ priv->en_name = NULL;
+ }
+
if (priv->state)
{
g_free (priv->state);
--
1.8.4.2

File diff suppressed because it is too large Load Diff

View File

@ -1,75 +0,0 @@
From 8ab1e71acd1ca7efbca2d8a4085c2547abe17e26 Mon Sep 17 00:00:00 2001
From: David Shea <dshea@redhat.com>
Date: Tue, 26 Nov 2013 16:22:01 -0500
Subject: [PATCH 09/10] Added a function to clear the location set for a
CcTimezoneMap
---
src/cc-timezone-map.c | 31 ++++++++++++++++++++++++++-----
src/cc-timezone-map.h | 1 +
2 files changed, 27 insertions(+), 5 deletions(-)
diff --git a/src/cc-timezone-map.c b/src/cc-timezone-map.c
index 7fd7b08..1eab640 100644
--- a/src/cc-timezone-map.c
+++ b/src/cc-timezone-map.c
@@ -897,14 +897,20 @@ set_location (CcTimezoneMap *map,
priv->location = location;
- info = tz_info_from_location (priv->location);
-
- priv->selected_offset = tz_location_get_utc_offset (priv->location)
- / (60.0*60.0) + ((info->daylight) ? -1.0 : 0.0);
+ if (priv->location)
+ {
+ info = tz_info_from_location (priv->location);
+ priv->selected_offset = tz_location_get_utc_offset (priv->location)
+ / (60.0*60.0) + ((info->daylight) ? -1.0 : 0.0);
+ tz_info_free (info);
+ }
+ else
+ {
+ priv->selected_offset = 0.0;
+ }
g_signal_emit (map, signals[LOCATION_CHANGED], 0, priv->location);
- tz_info_free (info);
}
static CcTimezoneLocation *
@@ -1208,3 +1214,18 @@ cc_timezone_map_get_location (CcTimezoneMap *map)
{
return map->priv->location;
}
+
+/**
+ * cc_timezone_map_clear_location:
+ * @map: A #CcTimezoneMap
+ *
+ * Clear the location currently set for the #CcTimezoneMap. This will remove
+ * the highlight and reset the map to its original state.
+ *
+ */
+void
+cc_timezone_map_clear_location (CcTimezoneMap *map)
+{
+ set_location(map, NULL);
+ gtk_widget_queue_draw (GTK_WIDGET (map));
+}
diff --git a/src/cc-timezone-map.h b/src/cc-timezone-map.h
index 15f2e0b..4737c0e 100644
--- a/src/cc-timezone-map.h
+++ b/src/cc-timezone-map.h
@@ -82,6 +82,7 @@ void cc_timezone_map_set_coords (CcTimezoneMap *map,
const gchar * cc_timezone_map_get_timezone_at_coords (CcTimezoneMap *map,
gdouble lon, gdouble lat);
CcTimezoneLocation * cc_timezone_map_get_location (CcTimezoneMap *map);
+void cc_timezone_map_clear_location(CcTimezoneMap *map);
G_END_DECLS
--
1.8.4.2

View File

@ -1,171 +0,0 @@
From 7150253ea59ef6e3688057abc98abe9f9f1daf80 Mon Sep 17 00:00:00 2001
From: David Shea <dshea@redhat.com>
Date: Tue, 26 Nov 2013 16:44:20 -0500
Subject: [PATCH 10/10] Allow the timezone highlight to be manually set
separately from the location.
Added selected-offset as a property and added get and set functions. Reworked
the widget draw handler to allow drawing a highlight with no location.
---
src/cc-timezone-map.c | 63 ++++++++++++++++++++++++++++++++++++++++++++++++++-
src/cc-timezone-map.h | 2 ++
2 files changed, 64 insertions(+), 1 deletion(-)
diff --git a/src/cc-timezone-map.c b/src/cc-timezone-map.c
index 1eab640..9d773ec 100644
--- a/src/cc-timezone-map.c
+++ b/src/cc-timezone-map.c
@@ -60,6 +60,7 @@ struct _CcTimezoneMapPrivate
gint olsen_map_rowstride;
gdouble selected_offset;
+ gboolean show_offset;
gchar *watermark;
@@ -78,6 +79,11 @@ enum
LAST_SIGNAL
};
+enum {
+ PROP_0,
+ PROP_SELECTED_OFFSET,
+};
+
static guint signals[LAST_SIGNAL];
@@ -513,8 +519,12 @@ cc_timezone_map_get_property (GObject *object,
GValue *value,
GParamSpec *pspec)
{
+ CcTimezoneMap *map = CC_TIMEZONE_MAP(object);
switch (property_id)
{
+ case PROP_SELECTED_OFFSET:
+ g_value_set_double(value, map->priv->selected_offset);
+ break;
default:
G_OBJECT_WARN_INVALID_PROPERTY_ID (object, property_id, pspec);
}
@@ -526,8 +536,12 @@ cc_timezone_map_set_property (GObject *object,
const GValue *value,
GParamSpec *pspec)
{
+ CcTimezoneMap *map = CC_TIMEZONE_MAP(object);
switch (property_id)
{
+ case PROP_SELECTED_OFFSET:
+ cc_timezone_map_set_selected_offset(map, g_value_get_double(value));
+ break;
default:
G_OBJECT_WARN_INVALID_PROPERTY_ID (object, property_id, pspec);
}
@@ -783,7 +797,7 @@ cc_timezone_map_draw (GtkWidget *widget,
cairo_stroke(cr);
}
- if (!priv->location) {
+ if (!priv->show_offset) {
return TRUE;
}
@@ -814,6 +828,10 @@ cc_timezone_map_draw (GtkWidget *widget,
g_object_unref (orig_hilight);
}
+ if (!priv->location) {
+ return TRUE;
+ }
+
/* load pin icon */
pin = gdk_pixbuf_new_from_file (DATADIR "/pin.png", &err);
@@ -860,6 +878,14 @@ cc_timezone_map_class_init (CcTimezoneMapClass *klass)
widget_class->realize = cc_timezone_map_realize;
widget_class->draw = cc_timezone_map_draw;
+ g_object_class_install_property(G_OBJECT_CLASS(klass),
+ PROP_SELECTED_OFFSET,
+ g_param_spec_string ("selected-offset",
+ "Selected offset",
+ "The selecect offset from GMT in hours",
+ "",
+ G_PARAM_READWRITE));
+
signals[LOCATION_CHANGED] = g_signal_new ("location-changed",
CC_TYPE_TIMEZONE_MAP,
G_SIGNAL_RUN_FIRST,
@@ -902,10 +928,12 @@ set_location (CcTimezoneMap *map,
info = tz_info_from_location (priv->location);
priv->selected_offset = tz_location_get_utc_offset (priv->location)
/ (60.0*60.0) + ((info->daylight) ? -1.0 : 0.0);
+ priv->show_offset = TRUE;
tz_info_free (info);
}
else
{
+ priv->show_offset = FALSE;
priv->selected_offset = 0.0;
}
@@ -1099,6 +1127,9 @@ cc_timezone_map_init (CcTimezoneMap *self)
priv->olsen_map_pixels = gdk_pixbuf_get_pixels (priv->olsen_map);
priv->olsen_map_rowstride = gdk_pixbuf_get_rowstride (priv->olsen_map);
+ priv->selected_offset = 0.0;
+ priv->show_offset = FALSE;
+
priv->tzdb = tz_load_db ();
g_signal_connect (self, "button-press-event", G_CALLBACK (button_press_event),
@@ -1229,3 +1260,33 @@ cc_timezone_map_clear_location (CcTimezoneMap *map)
set_location(map, NULL);
gtk_widget_queue_draw (GTK_WIDGET (map));
}
+
+/**
+ * cc_timezone_map_get_selected_offset:
+ * @map: A #CcTimezoneMap
+ *
+ * Returns the currently selected offset in hours from GMT.
+ *
+ * Returns: The selected offset.
+ *
+ */
+gdouble cc_timezone_map_get_selected_offset(CcTimezoneMap *map)
+{
+ return map->priv->selected_offset;
+}
+
+/**
+ * cc_timezone_map_set_selected_offset:
+ * @map: A #CcTimezoneMap
+ * @offset: The offset from GMT in hours
+ *
+ * Set the currently selected offset for the map and redraw the highlighted
+ * time zone.
+ */
+void cc_timezone_map_set_selected_offset (CcTimezoneMap *map, gdouble offset)
+{
+ map->priv->selected_offset = offset;
+ map->priv->show_offset = TRUE;
+ g_object_notify(G_OBJECT(map), "selected-offset");
+ gtk_widget_queue_draw (GTK_WIDGET (map));
+}
diff --git a/src/cc-timezone-map.h b/src/cc-timezone-map.h
index 4737c0e..ba6bd37 100644
--- a/src/cc-timezone-map.h
+++ b/src/cc-timezone-map.h
@@ -83,6 +83,8 @@ const gchar * cc_timezone_map_get_timezone_at_coords (CcTimezoneMap *map,
gdouble lon, gdouble lat);
CcTimezoneLocation * cc_timezone_map_get_location (CcTimezoneMap *map);
void cc_timezone_map_clear_location(CcTimezoneMap *map);
+gdouble cc_timezone_map_get_selected_offset(CcTimezoneMap *map);
+void cc_timezone_map_set_selected_offset (CcTimezoneMap *map, gdouble offset);
G_END_DECLS
--
1.8.4.2

View File

@ -1,25 +0,0 @@
From e2d3309d6ae6adb7f7041766e29333ea2cbc2a31 Mon Sep 17 00:00:00 2001
From: Iain Lane <iain.lane@canonical.com>
Date: Fri, 29 Nov 2013 10:22:22 +0000
Subject: [PATCH 12/18] Merge r36 from lp:~dshea/timezonemap/trunk
Don't try to close a NULL file pointer.
---
src/tz.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/tz.c b/src/tz.c
index c294b44..50ce7a3 100644
--- a/src/tz.c
+++ b/src/tz.c
@@ -305,7 +305,6 @@ void parse_file (const char * filename,
if (!fh)
{
g_warning ("Could not open *%s*\n", filename);
- fclose (fh);
return;
}
--
1.8.4.2

View File

@ -1,419 +0,0 @@
From 68dc8c1f23e0d2eec70baf83f6dc6f0ccc8ab0a5 Mon Sep 17 00:00:00 2001
From: Iain Lane <iain.lane@canonical.com>
Date: Fri, 29 Nov 2013 10:28:28 +0000
Subject: [PATCH 13/18] Merge r38 from lp:~dshea/timezonemap/trunk
bzrignore some generated files and remove generated INSTALL from the repository
---
.bzrignore | 21 ++++
INSTALL | 370 -------------------------------------------------------------
2 files changed, 21 insertions(+), 370 deletions(-)
create mode 100644 .bzrignore
delete mode 100644 INSTALL
diff --git a/.bzrignore b/.bzrignore
new file mode 100644
index 0000000..e488bbc
--- /dev/null
+++ b/.bzrignore
@@ -0,0 +1,21 @@
+Makefile
+Makefile.in
+aclocal.m4
+autom4te.cache
+build-aux
+config.h
+config.h.in
+config.log
+config.status
+configure
+libtool
+stamp-h1
+m4/*.m4
+.deps
+.libs
+*.gir
+*.typelib
+*.lo
+*.la
+src/test-timezone
+src/timezonemap.pc
diff --git a/INSTALL b/INSTALL
deleted file mode 100644
index a1e89e1..0000000
--- a/INSTALL
+++ /dev/null
@@ -1,370 +0,0 @@
-Installation Instructions
-*************************
-
-Copyright (C) 1994-1996, 1999-2002, 2004-2011 Free Software Foundation,
-Inc.
-
- Copying and distribution of this file, with or without modification,
-are permitted in any medium without royalty provided the copyright
-notice and this notice are preserved. This file is offered as-is,
-without warranty of any kind.
-
-Basic Installation
-==================
-
- Briefly, the shell commands `./configure; make; make install' should
-configure, build, and install this package. The following
-more-detailed instructions are generic; see the `README' file for
-instructions specific to this package. Some packages provide this
-`INSTALL' file but do not implement all of the features documented
-below. The lack of an optional feature in a given package is not
-necessarily a bug. More recommendations for GNU packages can be found
-in *note Makefile Conventions: (standards)Makefile Conventions.
-
- The `configure' shell script attempts to guess correct values for
-various system-dependent variables used during compilation. It uses
-those values to create a `Makefile' in each directory of the package.
-It may also create one or more `.h' files containing system-dependent
-definitions. Finally, it creates a shell script `config.status' that
-you can run in the future to recreate the current configuration, and a
-file `config.log' containing compiler output (useful mainly for
-debugging `configure').
-
- It can also use an optional file (typically called `config.cache'
-and enabled with `--cache-file=config.cache' or simply `-C') that saves
-the results of its tests to speed up reconfiguring. Caching is
-disabled by default to prevent problems with accidental use of stale
-cache files.
-
- If you need to do unusual things to compile the package, please try
-to figure out how `configure' could check whether to do them, and mail
-diffs or instructions to the address given in the `README' so they can
-be considered for the next release. If you are using the cache, and at
-some point `config.cache' contains results you don't want to keep, you
-may remove or edit it.
-
- The file `configure.ac' (or `configure.in') is used to create
-`configure' by a program called `autoconf'. You need `configure.ac' if
-you want to change it or regenerate `configure' using a newer version
-of `autoconf'.
-
- The simplest way to compile this package is:
-
- 1. `cd' to the directory containing the package's source code and type
- `./configure' to configure the package for your system.
-
- Running `configure' might take a while. While running, it prints
- some messages telling which features it is checking for.
-
- 2. Type `make' to compile the package.
-
- 3. Optionally, type `make check' to run any self-tests that come with
- the package, generally using the just-built uninstalled binaries.
-
- 4. Type `make install' to install the programs and any data files and
- documentation. When installing into a prefix owned by root, it is
- recommended that the package be configured and built as a regular
- user, and only the `make install' phase executed with root
- privileges.
-
- 5. Optionally, type `make installcheck' to repeat any self-tests, but
- this time using the binaries in their final installed location.
- This target does not install anything. Running this target as a
- regular user, particularly if the prior `make install' required
- root privileges, verifies that the installation completed
- correctly.
-
- 6. You can remove the program binaries and object files from the
- source code directory by typing `make clean'. To also remove the
- files that `configure' created (so you can compile the package for
- a different kind of computer), type `make distclean'. There is
- also a `make maintainer-clean' target, but that is intended mainly
- for the package's developers. If you use it, you may have to get
- all sorts of other programs in order to regenerate files that came
- with the distribution.
-
- 7. Often, you can also type `make uninstall' to remove the installed
- files again. In practice, not all packages have tested that
- uninstallation works correctly, even though it is required by the
- GNU Coding Standards.
-
- 8. Some packages, particularly those that use Automake, provide `make
- distcheck', which can by used by developers to test that all other
- targets like `make install' and `make uninstall' work correctly.
- This target is generally not run by end users.
-
-Compilers and Options
-=====================
-
- Some systems require unusual options for compilation or linking that
-the `configure' script does not know about. Run `./configure --help'
-for details on some of the pertinent environment variables.
-
- You can give `configure' initial values for configuration parameters
-by setting variables in the command line or in the environment. Here
-is an example:
-
- ./configure CC=c99 CFLAGS=-g LIBS=-lposix
-
- *Note Defining Variables::, for more details.
-
-Compiling For Multiple Architectures
-====================================
-
- You can compile the package for more than one kind of computer at the
-same time, by placing the object files for each architecture in their
-own directory. To do this, you can use GNU `make'. `cd' to the
-directory where you want the object files and executables to go and run
-the `configure' script. `configure' automatically checks for the
-source code in the directory that `configure' is in and in `..'. This
-is known as a "VPATH" build.
-
- With a non-GNU `make', it is safer to compile the package for one
-architecture at a time in the source code directory. After you have
-installed the package for one architecture, use `make distclean' before
-reconfiguring for another architecture.
-
- On MacOS X 10.5 and later systems, you can create libraries and
-executables that work on multiple system types--known as "fat" or
-"universal" binaries--by specifying multiple `-arch' options to the
-compiler but only a single `-arch' option to the preprocessor. Like
-this:
-
- ./configure CC="gcc -arch i386 -arch x86_64 -arch ppc -arch ppc64" \
- CXX="g++ -arch i386 -arch x86_64 -arch ppc -arch ppc64" \
- CPP="gcc -E" CXXCPP="g++ -E"
-
- This is not guaranteed to produce working output in all cases, you
-may have to build one architecture at a time and combine the results
-using the `lipo' tool if you have problems.
-
-Installation Names
-==================
-
- By default, `make install' installs the package's commands under
-`/usr/local/bin', include files under `/usr/local/include', etc. You
-can specify an installation prefix other than `/usr/local' by giving
-`configure' the option `--prefix=PREFIX', where PREFIX must be an
-absolute file name.
-
- You can specify separate installation prefixes for
-architecture-specific files and architecture-independent files. If you
-pass the option `--exec-prefix=PREFIX' to `configure', the package uses
-PREFIX as the prefix for installing programs and libraries.
-Documentation and other data files still use the regular prefix.
-
- In addition, if you use an unusual directory layout you can give
-options like `--bindir=DIR' to specify different values for particular
-kinds of files. Run `configure --help' for a list of the directories
-you can set and what kinds of files go in them. In general, the
-default for these options is expressed in terms of `${prefix}', so that
-specifying just `--prefix' will affect all of the other directory
-specifications that were not explicitly provided.
-
- The most portable way to affect installation locations is to pass the
-correct locations to `configure'; however, many packages provide one or
-both of the following shortcuts of passing variable assignments to the
-`make install' command line to change installation locations without
-having to reconfigure or recompile.
-
- The first method involves providing an override variable for each
-affected directory. For example, `make install
-prefix=/alternate/directory' will choose an alternate location for all
-directory configuration variables that were expressed in terms of
-`${prefix}'. Any directories that were specified during `configure',
-but not in terms of `${prefix}', must each be overridden at install
-time for the entire installation to be relocated. The approach of
-makefile variable overrides for each directory variable is required by
-the GNU Coding Standards, and ideally causes no recompilation.
-However, some platforms have known limitations with the semantics of
-shared libraries that end up requiring recompilation when using this
-method, particularly noticeable in packages that use GNU Libtool.
-
- The second method involves providing the `DESTDIR' variable. For
-example, `make install DESTDIR=/alternate/directory' will prepend
-`/alternate/directory' before all installation names. The approach of
-`DESTDIR' overrides is not required by the GNU Coding Standards, and
-does not work on platforms that have drive letters. On the other hand,
-it does better at avoiding recompilation issues, and works well even
-when some directory options were not specified in terms of `${prefix}'
-at `configure' time.
-
-Optional Features
-=================
-
- If the package supports it, you can cause programs to be installed
-with an extra prefix or suffix on their names by giving `configure' the
-option `--program-prefix=PREFIX' or `--program-suffix=SUFFIX'.
-
- Some packages pay attention to `--enable-FEATURE' options to
-`configure', where FEATURE indicates an optional part of the package.
-They may also pay attention to `--with-PACKAGE' options, where PACKAGE
-is something like `gnu-as' or `x' (for the X Window System). The
-`README' should mention any `--enable-' and `--with-' options that the
-package recognizes.
-
- For packages that use the X Window System, `configure' can usually
-find the X include and library files automatically, but if it doesn't,
-you can use the `configure' options `--x-includes=DIR' and
-`--x-libraries=DIR' to specify their locations.
-
- Some packages offer the ability to configure how verbose the
-execution of `make' will be. For these packages, running `./configure
---enable-silent-rules' sets the default to minimal output, which can be
-overridden with `make V=1'; while running `./configure
---disable-silent-rules' sets the default to verbose, which can be
-overridden with `make V=0'.
-
-Particular systems
-==================
-
- On HP-UX, the default C compiler is not ANSI C compatible. If GNU
-CC is not installed, it is recommended to use the following options in
-order to use an ANSI C compiler:
-
- ./configure CC="cc -Ae -D_XOPEN_SOURCE=500"
-
-and if that doesn't work, install pre-built binaries of GCC for HP-UX.
-
- HP-UX `make' updates targets which have the same time stamps as
-their prerequisites, which makes it generally unusable when shipped
-generated files such as `configure' are involved. Use GNU `make'
-instead.
-
- On OSF/1 a.k.a. Tru64, some versions of the default C compiler cannot
-parse its `<wchar.h>' header file. The option `-nodtk' can be used as
-a workaround. If GNU CC is not installed, it is therefore recommended
-to try
-
- ./configure CC="cc"
-
-and if that doesn't work, try
-
- ./configure CC="cc -nodtk"
-
- On Solaris, don't put `/usr/ucb' early in your `PATH'. This
-directory contains several dysfunctional programs; working variants of
-these programs are available in `/usr/bin'. So, if you need `/usr/ucb'
-in your `PATH', put it _after_ `/usr/bin'.
-
- On Haiku, software installed for all users goes in `/boot/common',
-not `/usr/local'. It is recommended to use the following options:
-
- ./configure --prefix=/boot/common
-
-Specifying the System Type
-==========================
-
- There may be some features `configure' cannot figure out
-automatically, but needs to determine by the type of machine the package
-will run on. Usually, assuming the package is built to be run on the
-_same_ architectures, `configure' can figure that out, but if it prints
-a message saying it cannot guess the machine type, give it the
-`--build=TYPE' option. TYPE can either be a short name for the system
-type, such as `sun4', or a canonical name which has the form:
-
- CPU-COMPANY-SYSTEM
-
-where SYSTEM can have one of these forms:
-
- OS
- KERNEL-OS
-
- See the file `config.sub' for the possible values of each field. If
-`config.sub' isn't included in this package, then this package doesn't
-need to know the machine type.
-
- If you are _building_ compiler tools for cross-compiling, you should
-use the option `--target=TYPE' to select the type of system they will
-produce code for.
-
- If you want to _use_ a cross compiler, that generates code for a
-platform different from the build platform, you should specify the
-"host" platform (i.e., that on which the generated programs will
-eventually be run) with `--host=TYPE'.
-
-Sharing Defaults
-================
-
- If you want to set default values for `configure' scripts to share,
-you can create a site shell script called `config.site' that gives
-default values for variables like `CC', `cache_file', and `prefix'.
-`configure' looks for `PREFIX/share/config.site' if it exists, then
-`PREFIX/etc/config.site' if it exists. Or, you can set the
-`CONFIG_SITE' environment variable to the location of the site script.
-A warning: not all `configure' scripts look for a site script.
-
-Defining Variables
-==================
-
- Variables not defined in a site shell script can be set in the
-environment passed to `configure'. However, some packages may run
-configure again during the build, and the customized values of these
-variables may be lost. In order to avoid this problem, you should set
-them in the `configure' command line, using `VAR=value'. For example:
-
- ./configure CC=/usr/local2/bin/gcc
-
-causes the specified `gcc' to be used as the C compiler (unless it is
-overridden in the site shell script).
-
-Unfortunately, this technique does not work for `CONFIG_SHELL' due to
-an Autoconf bug. Until the bug is fixed you can use this workaround:
-
- CONFIG_SHELL=/bin/bash /bin/bash ./configure CONFIG_SHELL=/bin/bash
-
-`configure' Invocation
-======================
-
- `configure' recognizes the following options to control how it
-operates.
-
-`--help'
-`-h'
- Print a summary of all of the options to `configure', and exit.
-
-`--help=short'
-`--help=recursive'
- Print a summary of the options unique to this package's
- `configure', and exit. The `short' variant lists options used
- only in the top level, while the `recursive' variant lists options
- also present in any nested packages.
-
-`--version'
-`-V'
- Print the version of Autoconf used to generate the `configure'
- script, and exit.
-
-`--cache-file=FILE'
- Enable the cache: use and save the results of the tests in FILE,
- traditionally `config.cache'. FILE defaults to `/dev/null' to
- disable caching.
-
-`--config-cache'
-`-C'
- Alias for `--cache-file=config.cache'.
-
-`--quiet'
-`--silent'
-`-q'
- Do not print messages saying which checks are being made. To
- suppress all normal output, redirect it to `/dev/null' (any error
- messages will still be shown).
-
-`--srcdir=DIR'
- Look for the package's source code in directory DIR. Usually
- `configure' can determine that directory automatically.
-
-`--prefix=DIR'
- Use DIR as the installation prefix. *note Installation Names::
- for more details, including other options available for fine-tuning
- the installation locations.
-
-`--no-create'
-`-n'
- Run the configure checks, but stop before creating any output
- files.
-
-`configure' also accepts some other, not widely useful, options. Run
-`configure --help' for more details.
-
--
1.8.4.2

View File

@ -1,22 +0,0 @@
From b81b960a9f5ba1fed1ae47fb852c7ccb67c7c5cf Mon Sep 17 00:00:00 2001
From: Iain Lane <iain.lane@canonical.com>
Date: Fri, 29 Nov 2013 10:28:43 +0000
Subject: [PATCH 14/18] Merge r39 from lp:~dshea/timezonemap/trunk
Ignore INSTALL too; generated file
---
.bzrignore | 1 +
1 file changed, 1 insertion(+)
diff --git a/.bzrignore b/.bzrignore
index e488bbc..abe0491 100644
--- a/.bzrignore
+++ b/.bzrignore
@@ -19,3 +19,4 @@ m4/*.m4
*.la
src/test-timezone
src/timezonemap.pc
+INSTALL
--
1.8.4.2

View File

@ -1,60 +0,0 @@
From 67fb6770f8e4cde41c47e15b9660d7d7d5def243 Mon Sep 17 00:00:00 2001
From: Iain Lane <iain.lane@canonical.com>
Date: Fri, 29 Nov 2013 11:25:40 +0000
Subject: [PATCH 15/18] Merge r37 from lp:~dshea/timezonemap/trunk
Turn on g-ir-scanner warnings & fix an errant comment
---
src/Makefile.am | 2 +-
src/cc-timezone-map.c | 8 ++++++++
src/timezone-completion.c | 2 +-
3 files changed, 10 insertions(+), 2 deletions(-)
diff --git a/src/Makefile.am b/src/Makefile.am
index 05dfb1a..3f2d176 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -110,7 +110,7 @@ introspection_sources = $(libtimezonemap_la_SOURCES)
TimezoneMap-1.0.gir: libtimezonemap.la
TimezoneMap_1_0_gir_INCLUDES = GObject-2.0 Gtk-3.0 Json-1.0
TimezoneMap_1_0_gir_CFLAGS = $(INCLUDES)
-TimezoneMap_1_0_gir_SCANNERFLAGS = --identifier-prefix=Cc
+TimezoneMap_1_0_gir_SCANNERFLAGS = --identifier-prefix=Cc --warn-all
TimezoneMap_1_0_gir_LIBS = libtimezonemap.la
TimezoneMap_1_0_gir_FILES = $(introspection_sources)
diff --git a/src/cc-timezone-map.c b/src/cc-timezone-map.c
index 60297e4..d4d86f3 100644
--- a/src/cc-timezone-map.c
+++ b/src/cc-timezone-map.c
@@ -1226,6 +1226,14 @@ cc_timezone_map_set_watermark (CcTimezoneMap *map, const gchar * watermark)
gtk_widget_queue_draw (GTK_WIDGET (map));
}
+/**
+ * cc_timezone_map_get_location:
+ * @map: A #CcTimezoneMap
+ *
+ * Returns the current location set for the map.
+ *
+ * Returns: (transfer none): the map location.
+ */
CcTimezoneLocation *
cc_timezone_map_get_location (CcTimezoneMap *map)
{
diff --git a/src/timezone-completion.c b/src/timezone-completion.c
index f6ca8c8..e7f88db 100644
--- a/src/timezone-completion.c
+++ b/src/timezone-completion.c
@@ -442,7 +442,7 @@ get_descendent (GtkWidget * parent, GType type)
return NULL;
}
-/**
+/*
* The popup window and its GtkTreeView are private to our parent completion
* object. We can't get access to discover if there is a highlighted item or
* even if the window is showing right now. So this is a super hack to find
--
1.8.4.2

View File

@ -1,25 +0,0 @@
From 1726b4dc558d12d353fd86306a6c075c787d24a9 Mon Sep 17 00:00:00 2001
From: Iain Lane <iain.lane@canonical.com>
Date: Fri, 29 Nov 2013 12:02:00 +0000
Subject: [PATCH 16/18] Add cc-timezone-location.h to
timezonemapincludes_HEADERS so it gets installed
---
src/Makefile.am | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/Makefile.am b/src/Makefile.am
index 8b00c16..2eec6d7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -87,6 +87,7 @@ libtimezonemap_la_SOURCES = $(libtimezonemap_GISOURCES) $(libtimezonemap_NONGISO
# that users do "#include <timezonemap/tz.h>" instead of "#include <tz.h>"
timezonemapincludesdir = $(includedir)/timezonemap/timezonemap
timezonemapincludes_HEADERS = \
+ cc-timezone-location.h \
cc-timezone-map.h \
timezone-completion.h \
tz.h
--
1.8.4.2

View File

@ -1,25 +0,0 @@
From 6dced294369ce9b47d793b959d1cc3acfd1e86d1 Mon Sep 17 00:00:00 2001
From: Iain Lane <iain.lane@canonical.com>
Date: Fri, 29 Nov 2013 12:23:12 +0000
Subject: [PATCH 17/18] Set en_name correctly
---
src/cc-timezone-location.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/cc-timezone-location.c b/src/cc-timezone-location.c
index 3bf4cad..31ceb56 100644
--- a/src/cc-timezone-location.c
+++ b/src/cc-timezone-location.c
@@ -315,7 +315,7 @@ const gchar *cc_timezone_location_get_en_name(CcTimezoneLocation *loc)
void cc_timezone_location_set_en_name(CcTimezoneLocation *loc, const gchar *en_name)
{
g_free(loc->priv->en_name);
- loc->priv->full_country = g_strdup(en_name);
+ loc->priv->en_name = g_strdup(en_name);
g_object_notify(G_OBJECT(loc), "en_name");
}
--
1.8.4.2

View File

@ -1,27 +0,0 @@
From d57780d32f9ec7d7d091a07c173a88928c17bd09 Mon Sep 17 00:00:00 2001
From: Iain Lane <iain.lane@canonical.com>
Date: Fri, 29 Nov 2013 12:26:52 +0000
Subject: [PATCH 18/18] Don't call g_type_init() on glib >= 2.35; it's
deprecated
---
src/test-timezone.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/test-timezone.c b/src/test-timezone.c
index a2271c4..5658227 100644
--- a/src/test-timezone.c
+++ b/src/test-timezone.c
@@ -23,7 +23,9 @@ int main (int argc, char **argv)
return 1;
}
+#if !GLIB_CHECK_VERSION(2, 35, 0)
g_type_init();
+#endif
GValue zone = {0};
g_value_init(&zone, G_TYPE_STRING);
--
1.8.4.2

View File

@ -1,26 +1,14 @@
Name: libtimezonemap
Version: 0.4.1
Release: 4%{?dist}
Version: 0.4.2
Release: 1%{?dist}
Summary: Time zone map widget for Gtk+
Group: System Environment/Libraries
License: GPLv3
URL: https://launchpad.net/timezonemap
Source0: http://archive.ubuntu.com/ubuntu/pool/main/libt/libtimezonemap/%{name}_%{version}.tar.gz
Patch0: 0001-Make-whitespace-and-indentation-consistent.patch
Patch1: 0004-Update-the-GPL-comments-with-the-new-FSF-address.patch
Patch2: 0005-Create-local-copies-of-string-properties.patch
Patch3: 0006-Moved-CcTimezoneLocation-into-its-own-file.patch
Patch8: 0009-Added-a-function-to-clear-the-location-set-for-a-CcT.patch
Patch9: 0010-Allow-the-timezone-highlight-to-be-manually-set-sepa.patch
Patch10: 0011-Added-a-glade-catalog-file.patch
Patch11: 0012-Merge-r36-from-lp-dshea-timezonemap-trunk.patch
Patch12: 0013-Merge-r38-from-lp-dshea-timezonemap-trunk.patch
Patch13: 0014-Merge-r39-from-lp-dshea-timezonemap-trunk.patch
Patch14: 0015-Merge-r37-from-lp-dshea-timezonemap-trunk.patch
Patch15: 0016-Add-cc-timezone-location.h-to-timezonemapincludes_HE.patch
Patch16: 0017-Set-en_name-correctly.patch
Patch17: 0018-Don-t-call-g_type_init-on-glib-2.35-it-s-deprecated.patch
Patch1: 0001-Added-a-glade-catalog-file.patch
Patch2: 0002-Remove-the-color-codes-map.patch
BuildRequires: glib2-devel >= 2.26
BuildRequires: gtk3-devel >= 3.1.4
@ -47,20 +35,8 @@ files used for building applications that use %{name}.
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%patch13 -p1
%patch14 -p1
%patch15 -p1
%patch16 -p1
%patch17 -p1
%build
./autogen.sh
@ -89,6 +65,9 @@ rm -f %{buildroot}%{_libdir}/*.la
%{_datadir}/glade/catalogs/TimezoneMap.xml
%changelog
* Fri May 2 2014 David Shea <dshea@redhat.com> - 0.4.2-1
- New upstream release libtimezonemap-0.4.2
* Mon Dec 2 2013 David Shea <dshea@redhat.com> - 0.4.1-4
- Merge fixes from lp:timezonemap
- Add cc-timezone-location.h to timezonemapincludes_HEADERS so it gets installed (iain.lane)

View File

@ -1 +1 @@
79da327a7473b24c32d588db33831848 libtimezonemap_0.4.1.tar.gz
daaf4d2761e90bbc22d424dfff1f83c1 libtimezonemap_0.4.2.tar.gz