- Merge fixes from lp:timezonemap - Add cc-timezone-location.h to timezonemapincludes_HEADERS so it gets installed (iain.lane) - Set en_name correctly (iain.lane) - Don't call g_type_init() on glib >= 2.35; it's deprecated (iain.lane)
61 lines
2.0 KiB
Diff
61 lines
2.0 KiB
Diff
From 67fb6770f8e4cde41c47e15b9660d7d7d5def243 Mon Sep 17 00:00:00 2001
|
|
From: Iain Lane <iain.lane@canonical.com>
|
|
Date: Fri, 29 Nov 2013 11:25:40 +0000
|
|
Subject: [PATCH 15/18] Merge r37 from lp:~dshea/timezonemap/trunk
|
|
|
|
Turn on g-ir-scanner warnings & fix an errant comment
|
|
---
|
|
src/Makefile.am | 2 +-
|
|
src/cc-timezone-map.c | 8 ++++++++
|
|
src/timezone-completion.c | 2 +-
|
|
3 files changed, 10 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
index 05dfb1a..3f2d176 100644
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -110,7 +110,7 @@ introspection_sources = $(libtimezonemap_la_SOURCES)
|
|
TimezoneMap-1.0.gir: libtimezonemap.la
|
|
TimezoneMap_1_0_gir_INCLUDES = GObject-2.0 Gtk-3.0 Json-1.0
|
|
TimezoneMap_1_0_gir_CFLAGS = $(INCLUDES)
|
|
-TimezoneMap_1_0_gir_SCANNERFLAGS = --identifier-prefix=Cc
|
|
+TimezoneMap_1_0_gir_SCANNERFLAGS = --identifier-prefix=Cc --warn-all
|
|
TimezoneMap_1_0_gir_LIBS = libtimezonemap.la
|
|
TimezoneMap_1_0_gir_FILES = $(introspection_sources)
|
|
|
|
diff --git a/src/cc-timezone-map.c b/src/cc-timezone-map.c
|
|
index 60297e4..d4d86f3 100644
|
|
--- a/src/cc-timezone-map.c
|
|
+++ b/src/cc-timezone-map.c
|
|
@@ -1226,6 +1226,14 @@ cc_timezone_map_set_watermark (CcTimezoneMap *map, const gchar * watermark)
|
|
gtk_widget_queue_draw (GTK_WIDGET (map));
|
|
}
|
|
|
|
+/**
|
|
+ * cc_timezone_map_get_location:
|
|
+ * @map: A #CcTimezoneMap
|
|
+ *
|
|
+ * Returns the current location set for the map.
|
|
+ *
|
|
+ * Returns: (transfer none): the map location.
|
|
+ */
|
|
CcTimezoneLocation *
|
|
cc_timezone_map_get_location (CcTimezoneMap *map)
|
|
{
|
|
diff --git a/src/timezone-completion.c b/src/timezone-completion.c
|
|
index f6ca8c8..e7f88db 100644
|
|
--- a/src/timezone-completion.c
|
|
+++ b/src/timezone-completion.c
|
|
@@ -442,7 +442,7 @@ get_descendent (GtkWidget * parent, GType type)
|
|
return NULL;
|
|
}
|
|
|
|
-/**
|
|
+/*
|
|
* The popup window and its GtkTreeView are private to our parent completion
|
|
* object. We can't get access to discover if there is a highlighted item or
|
|
* even if the window is showing right now. So this is a super hack to find
|
|
--
|
|
1.8.4.2
|
|
|