Added patches from upstream bzr.
- Merge fixes from lp:timezonemap - Add cc-timezone-location.h to timezonemapincludes_HEADERS so it gets installed (iain.lane) - Set en_name correctly (iain.lane) - Don't call g_type_init() on glib >= 2.35; it's deprecated (iain.lane)
This commit is contained in:
parent
299e29647a
commit
3392e41b22
@ -1,7 +1,7 @@
|
|||||||
From 817161c4596df2fba45e5d801ed26ddc0bb4f4e2 Mon Sep 17 00:00:00 2001
|
From 817161c4596df2fba45e5d801ed26ddc0bb4f4e2 Mon Sep 17 00:00:00 2001
|
||||||
From: David Shea <dshea@redhat.com>
|
From: David Shea <dshea@redhat.com>
|
||||||
Date: Thu, 14 Nov 2013 10:50:49 -0500
|
Date: Thu, 14 Nov 2013 10:50:49 -0500
|
||||||
Subject: [PATCH 02/10] Update the GPL comments with the new FSF address.
|
Subject: [PATCH 04/18] Update the GPL comments with the new FSF address.
|
||||||
|
|
||||||
The Free Software Foundation's address is now at 51 Franklin St. The
|
The Free Software Foundation's address is now at 51 Franklin St. The
|
||||||
rest of the GPL v2 boilerplate comment is unchanged.
|
rest of the GPL v2 boilerplate comment is unchanged.
|
@ -1,7 +1,7 @@
|
|||||||
From 94fb062ff98ba6eab156493b3ad7ef210d175a79 Mon Sep 17 00:00:00 2001
|
From 94fb062ff98ba6eab156493b3ad7ef210d175a79 Mon Sep 17 00:00:00 2001
|
||||||
From: David Shea <dshea@redhat.com>
|
From: David Shea <dshea@redhat.com>
|
||||||
Date: Thu, 14 Nov 2013 10:50:49 -0500
|
Date: Thu, 14 Nov 2013 10:50:49 -0500
|
||||||
Subject: [PATCH 03/10] Create local copies of string properties.
|
Subject: [PATCH 05/18] Create local copies of string properties.
|
||||||
|
|
||||||
The string values passed to set_property are owned by the caller, so we
|
The string values passed to set_property are owned by the caller, so we
|
||||||
need to create new copies of the strings to store in the private data
|
need to create new copies of the strings to store in the private data
|
@ -1,26 +0,0 @@
|
|||||||
From eddbdda3d7aecce37fb889ea1b9754659aae872c Mon Sep 17 00:00:00 2001
|
|
||||||
From: David Shea <dshea@redhat.com>
|
|
||||||
Date: Thu, 14 Nov 2013 10:50:49 -0500
|
|
||||||
Subject: [PATCH 05/10] Don't close a NULL file pointer.
|
|
||||||
|
|
||||||
parse_file attempted to close a NULL pointer if it was unable to open
|
|
||||||
the given file, causing a crash.
|
|
||||||
---
|
|
||||||
src/tz.c | 1 -
|
|
||||||
1 file changed, 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/tz.c b/src/tz.c
|
|
||||||
index 9393ba2..95bfca0 100644
|
|
||||||
--- a/src/tz.c
|
|
||||||
+++ b/src/tz.c
|
|
||||||
@@ -54,7 +54,6 @@ void parse_file (const char * filename,
|
|
||||||
if (!fh)
|
|
||||||
{
|
|
||||||
g_warning ("Could not open *%s*\n", filename);
|
|
||||||
- fclose (fh);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
--
|
|
||||||
1.8.4.2
|
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
From f2f3c519595467d34c4f2c5c199cee62439c7e77 Mon Sep 17 00:00:00 2001
|
From f2f3c519595467d34c4f2c5c199cee62439c7e77 Mon Sep 17 00:00:00 2001
|
||||||
From: David Shea <dshea@redhat.com>
|
From: David Shea <dshea@redhat.com>
|
||||||
Date: Thu, 14 Nov 2013 10:50:49 -0500
|
Date: Thu, 14 Nov 2013 10:50:49 -0500
|
||||||
Subject: [PATCH 04/10] Moved CcTimezoneLocation into its own file.
|
Subject: [PATCH 06/18] Moved CcTimezoneLocation into its own file.
|
||||||
|
|
||||||
Mixing GObject and non-GObject code in tz.c confuses g-ir-scanner and
|
Mixing GObject and non-GObject code in tz.c confuses g-ir-scanner and
|
||||||
adds a lot non-introspectable identifiers to the .gir file.
|
adds a lot non-introspectable identifiers to the .gir file.
|
25
0012-Merge-r36-from-lp-dshea-timezonemap-trunk.patch
Normal file
25
0012-Merge-r36-from-lp-dshea-timezonemap-trunk.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From e2d3309d6ae6adb7f7041766e29333ea2cbc2a31 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Iain Lane <iain.lane@canonical.com>
|
||||||
|
Date: Fri, 29 Nov 2013 10:22:22 +0000
|
||||||
|
Subject: [PATCH 12/18] Merge r36 from lp:~dshea/timezonemap/trunk
|
||||||
|
|
||||||
|
Don't try to close a NULL file pointer.
|
||||||
|
---
|
||||||
|
src/tz.c | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/tz.c b/src/tz.c
|
||||||
|
index c294b44..50ce7a3 100644
|
||||||
|
--- a/src/tz.c
|
||||||
|
+++ b/src/tz.c
|
||||||
|
@@ -305,7 +305,6 @@ void parse_file (const char * filename,
|
||||||
|
if (!fh)
|
||||||
|
{
|
||||||
|
g_warning ("Could not open *%s*\n", filename);
|
||||||
|
- fclose (fh);
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
|
||||||
|
--
|
||||||
|
1.8.4.2
|
||||||
|
|
@ -1,10 +1,9 @@
|
|||||||
From c009e7cb89c0d45afc4e4c94e589d0154591fb89 Mon Sep 17 00:00:00 2001
|
From 68dc8c1f23e0d2eec70baf83f6dc6f0ccc8ab0a5 Mon Sep 17 00:00:00 2001
|
||||||
From: David Shea <dshea@redhat.com>
|
From: Iain Lane <iain.lane@canonical.com>
|
||||||
Date: Tue, 26 Nov 2013 10:43:14 -0500
|
Date: Fri, 29 Nov 2013 10:28:28 +0000
|
||||||
Subject: [PATCH 07/10] Added a .bzrignore file to ignore all the files
|
Subject: [PATCH 13/18] Merge r38 from lp:~dshea/timezonemap/trunk
|
||||||
generated by the build.
|
|
||||||
|
|
||||||
Removed INSTALL from the repo since this file is copied in by automake.
|
bzrignore some generated files and remove generated INSTALL from the repository
|
||||||
---
|
---
|
||||||
.bzrignore | 21 ++++
|
.bzrignore | 21 ++++
|
||||||
INSTALL | 370 -------------------------------------------------------------
|
INSTALL | 370 -------------------------------------------------------------
|
@ -1,8 +1,9 @@
|
|||||||
From ff6a3c64c83326d53fb86c25b0f60f852f6257b5 Mon Sep 17 00:00:00 2001
|
From b81b960a9f5ba1fed1ae47fb852c7ccb67c7c5cf Mon Sep 17 00:00:00 2001
|
||||||
From: David Shea <dshea@redhat.com>
|
From: Iain Lane <iain.lane@canonical.com>
|
||||||
Date: Tue, 26 Nov 2013 16:12:56 -0500
|
Date: Fri, 29 Nov 2013 10:28:43 +0000
|
||||||
Subject: [PATCH 08/10] Ignore the INSTALL file
|
Subject: [PATCH 14/18] Merge r39 from lp:~dshea/timezonemap/trunk
|
||||||
|
|
||||||
|
Ignore INSTALL too; generated file
|
||||||
---
|
---
|
||||||
.bzrignore | 1 +
|
.bzrignore | 1 +
|
||||||
1 file changed, 1 insertion(+)
|
1 file changed, 1 insertion(+)
|
@ -1,13 +1,9 @@
|
|||||||
From 7e33322d16f78ab613ffdd284274be580034023a Mon Sep 17 00:00:00 2001
|
From 67fb6770f8e4cde41c47e15b9660d7d7d5def243 Mon Sep 17 00:00:00 2001
|
||||||
From: David Shea <dshea@redhat.com>
|
From: Iain Lane <iain.lane@canonical.com>
|
||||||
Date: Thu, 14 Nov 2013 10:50:49 -0500
|
Date: Fri, 29 Nov 2013 11:25:40 +0000
|
||||||
Subject: [PATCH 06/10] Turn on and fix g-ir-scanner warnings.
|
Subject: [PATCH 15/18] Merge r37 from lp:~dshea/timezonemap/trunk
|
||||||
|
|
||||||
A comment in timezone-completion opened with /** but did not include
|
Turn on g-ir-scanner warnings & fix an errant comment
|
||||||
gtk-doc data. Removed the extra asterisk.
|
|
||||||
|
|
||||||
cc_timezone_map_get_location needed transfer information since it
|
|
||||||
returns a non-const object. Added a doc comment with transfer none.
|
|
||||||
---
|
---
|
||||||
src/Makefile.am | 2 +-
|
src/Makefile.am | 2 +-
|
||||||
src/cc-timezone-map.c | 8 ++++++++
|
src/cc-timezone-map.c | 8 ++++++++
|
||||||
@ -15,10 +11,10 @@ returns a non-const object. Added a doc comment with transfer none.
|
|||||||
3 files changed, 10 insertions(+), 2 deletions(-)
|
3 files changed, 10 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||||
index b4461cd..8b00c16 100644
|
index 05dfb1a..3f2d176 100644
|
||||||
--- a/src/Makefile.am
|
--- a/src/Makefile.am
|
||||||
+++ b/src/Makefile.am
|
+++ b/src/Makefile.am
|
||||||
@@ -109,7 +109,7 @@ introspection_sources = $(libtimezonemap_GISOURCES)
|
@@ -110,7 +110,7 @@ introspection_sources = $(libtimezonemap_la_SOURCES)
|
||||||
TimezoneMap-1.0.gir: libtimezonemap.la
|
TimezoneMap-1.0.gir: libtimezonemap.la
|
||||||
TimezoneMap_1_0_gir_INCLUDES = GObject-2.0 Gtk-3.0 Json-1.0
|
TimezoneMap_1_0_gir_INCLUDES = GObject-2.0 Gtk-3.0 Json-1.0
|
||||||
TimezoneMap_1_0_gir_CFLAGS = $(INCLUDES)
|
TimezoneMap_1_0_gir_CFLAGS = $(INCLUDES)
|
||||||
@ -28,10 +24,10 @@ index b4461cd..8b00c16 100644
|
|||||||
TimezoneMap_1_0_gir_FILES = $(introspection_sources)
|
TimezoneMap_1_0_gir_FILES = $(introspection_sources)
|
||||||
|
|
||||||
diff --git a/src/cc-timezone-map.c b/src/cc-timezone-map.c
|
diff --git a/src/cc-timezone-map.c b/src/cc-timezone-map.c
|
||||||
index a782089..7fd7b08 100644
|
index 60297e4..d4d86f3 100644
|
||||||
--- a/src/cc-timezone-map.c
|
--- a/src/cc-timezone-map.c
|
||||||
+++ b/src/cc-timezone-map.c
|
+++ b/src/cc-timezone-map.c
|
||||||
@@ -1195,6 +1195,14 @@ cc_timezone_map_set_watermark (CcTimezoneMap *map, const gchar * watermark)
|
@@ -1226,6 +1226,14 @@ cc_timezone_map_set_watermark (CcTimezoneMap *map, const gchar * watermark)
|
||||||
gtk_widget_queue_draw (GTK_WIDGET (map));
|
gtk_widget_queue_draw (GTK_WIDGET (map));
|
||||||
}
|
}
|
||||||
|
|
@ -0,0 +1,25 @@
|
|||||||
|
From 1726b4dc558d12d353fd86306a6c075c787d24a9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Iain Lane <iain.lane@canonical.com>
|
||||||
|
Date: Fri, 29 Nov 2013 12:02:00 +0000
|
||||||
|
Subject: [PATCH 16/18] Add cc-timezone-location.h to
|
||||||
|
timezonemapincludes_HEADERS so it gets installed
|
||||||
|
|
||||||
|
---
|
||||||
|
src/Makefile.am | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||||
|
index 8b00c16..2eec6d7 100644
|
||||||
|
--- a/src/Makefile.am
|
||||||
|
+++ b/src/Makefile.am
|
||||||
|
@@ -87,6 +87,7 @@ libtimezonemap_la_SOURCES = $(libtimezonemap_GISOURCES) $(libtimezonemap_NONGISO
|
||||||
|
# that users do "#include <timezonemap/tz.h>" instead of "#include <tz.h>"
|
||||||
|
timezonemapincludesdir = $(includedir)/timezonemap/timezonemap
|
||||||
|
timezonemapincludes_HEADERS = \
|
||||||
|
+ cc-timezone-location.h \
|
||||||
|
cc-timezone-map.h \
|
||||||
|
timezone-completion.h \
|
||||||
|
tz.h
|
||||||
|
--
|
||||||
|
1.8.4.2
|
||||||
|
|
25
0017-Set-en_name-correctly.patch
Normal file
25
0017-Set-en_name-correctly.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 6dced294369ce9b47d793b959d1cc3acfd1e86d1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Iain Lane <iain.lane@canonical.com>
|
||||||
|
Date: Fri, 29 Nov 2013 12:23:12 +0000
|
||||||
|
Subject: [PATCH 17/18] Set en_name correctly
|
||||||
|
|
||||||
|
---
|
||||||
|
src/cc-timezone-location.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/cc-timezone-location.c b/src/cc-timezone-location.c
|
||||||
|
index 3bf4cad..31ceb56 100644
|
||||||
|
--- a/src/cc-timezone-location.c
|
||||||
|
+++ b/src/cc-timezone-location.c
|
||||||
|
@@ -315,7 +315,7 @@ const gchar *cc_timezone_location_get_en_name(CcTimezoneLocation *loc)
|
||||||
|
void cc_timezone_location_set_en_name(CcTimezoneLocation *loc, const gchar *en_name)
|
||||||
|
{
|
||||||
|
g_free(loc->priv->en_name);
|
||||||
|
- loc->priv->full_country = g_strdup(en_name);
|
||||||
|
+ loc->priv->en_name = g_strdup(en_name);
|
||||||
|
|
||||||
|
g_object_notify(G_OBJECT(loc), "en_name");
|
||||||
|
}
|
||||||
|
--
|
||||||
|
1.8.4.2
|
||||||
|
|
@ -0,0 +1,27 @@
|
|||||||
|
From d57780d32f9ec7d7d091a07c173a88928c17bd09 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Iain Lane <iain.lane@canonical.com>
|
||||||
|
Date: Fri, 29 Nov 2013 12:26:52 +0000
|
||||||
|
Subject: [PATCH 18/18] Don't call g_type_init() on glib >= 2.35; it's
|
||||||
|
deprecated
|
||||||
|
|
||||||
|
---
|
||||||
|
src/test-timezone.c | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/test-timezone.c b/src/test-timezone.c
|
||||||
|
index a2271c4..5658227 100644
|
||||||
|
--- a/src/test-timezone.c
|
||||||
|
+++ b/src/test-timezone.c
|
||||||
|
@@ -23,7 +23,9 @@ int main (int argc, char **argv)
|
||||||
|
return 1;
|
||||||
|
}
|
||||||
|
|
||||||
|
+#if !GLIB_CHECK_VERSION(2, 35, 0)
|
||||||
|
g_type_init();
|
||||||
|
+#endif
|
||||||
|
GValue zone = {0};
|
||||||
|
g_value_init(&zone, G_TYPE_STRING);
|
||||||
|
|
||||||
|
--
|
||||||
|
1.8.4.2
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
Name: libtimezonemap
|
Name: libtimezonemap
|
||||||
Version: 0.4.1
|
Version: 0.4.1
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: Time zone map widget for Gtk+
|
Summary: Time zone map widget for Gtk+
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -8,16 +8,19 @@ License: GPLv3
|
|||||||
URL: https://launchpad.net/timezonemap
|
URL: https://launchpad.net/timezonemap
|
||||||
Source0: http://archive.ubuntu.com/ubuntu/pool/main/libt/libtimezonemap/%{name}_%{version}.tar.gz
|
Source0: http://archive.ubuntu.com/ubuntu/pool/main/libt/libtimezonemap/%{name}_%{version}.tar.gz
|
||||||
Patch0: 0001-Make-whitespace-and-indentation-consistent.patch
|
Patch0: 0001-Make-whitespace-and-indentation-consistent.patch
|
||||||
Patch1: 0002-Update-the-GPL-comments-with-the-new-FSF-address.patch
|
Patch1: 0004-Update-the-GPL-comments-with-the-new-FSF-address.patch
|
||||||
Patch2: 0003-Create-local-copies-of-string-properties.patch
|
Patch2: 0005-Create-local-copies-of-string-properties.patch
|
||||||
Patch3: 0004-Moved-CcTimezoneLocation-into-its-own-file.patch
|
Patch3: 0006-Moved-CcTimezoneLocation-into-its-own-file.patch
|
||||||
Patch4: 0005-Don-t-close-a-NULL-file-pointer.patch
|
|
||||||
Patch5: 0006-Turn-on-and-fix-g-ir-scanner-warnings.patch
|
|
||||||
Patch6: 0007-Added-a-.bzrignore-file-to-ignore-all-the-files-gene.patch
|
|
||||||
Patch7: 0008-Ignore-the-INSTALL-file.patch
|
|
||||||
Patch8: 0009-Added-a-function-to-clear-the-location-set-for-a-CcT.patch
|
Patch8: 0009-Added-a-function-to-clear-the-location-set-for-a-CcT.patch
|
||||||
Patch9: 0010-Allow-the-timezone-highlight-to-be-manually-set-sepa.patch
|
Patch9: 0010-Allow-the-timezone-highlight-to-be-manually-set-sepa.patch
|
||||||
Patch10: 0011-Added-a-glade-catalog-file.patch
|
Patch10: 0011-Added-a-glade-catalog-file.patch
|
||||||
|
Patch11: 0012-Merge-r36-from-lp-dshea-timezonemap-trunk.patch
|
||||||
|
Patch12: 0013-Merge-r38-from-lp-dshea-timezonemap-trunk.patch
|
||||||
|
Patch13: 0014-Merge-r39-from-lp-dshea-timezonemap-trunk.patch
|
||||||
|
Patch14: 0015-Merge-r37-from-lp-dshea-timezonemap-trunk.patch
|
||||||
|
Patch15: 0016-Add-cc-timezone-location.h-to-timezonemapincludes_HE.patch
|
||||||
|
Patch16: 0017-Set-en_name-correctly.patch
|
||||||
|
Patch17: 0018-Don-t-call-g_type_init-on-glib-2.35-it-s-deprecated.patch
|
||||||
|
|
||||||
BuildRequires: glib2-devel >= 2.26
|
BuildRequires: glib2-devel >= 2.26
|
||||||
BuildRequires: gtk3-devel >= 3.1.4
|
BuildRequires: gtk3-devel >= 3.1.4
|
||||||
@ -48,13 +51,16 @@ files used for building applications that use %{name}.
|
|||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
|
||||||
%patch5 -p1
|
|
||||||
%patch6 -p1
|
|
||||||
%patch7 -p1
|
|
||||||
%patch8 -p1
|
%patch8 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
%patch10 -p1
|
%patch10 -p1
|
||||||
|
%patch11 -p1
|
||||||
|
%patch12 -p1
|
||||||
|
%patch13 -p1
|
||||||
|
%patch14 -p1
|
||||||
|
%patch15 -p1
|
||||||
|
%patch16 -p1
|
||||||
|
%patch17 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
@ -83,6 +89,12 @@ rm -f %{buildroot}%{_libdir}/*.la
|
|||||||
%{_datadir}/glade/catalogs/TimezoneMap.xml
|
%{_datadir}/glade/catalogs/TimezoneMap.xml
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 2 2013 David Shea <dshea@redhat.com> - 0.4.1-4
|
||||||
|
- Merge fixes from lp:timezonemap
|
||||||
|
- Add cc-timezone-location.h to timezonemapincludes_HEADERS so it gets installed (iain.lane)
|
||||||
|
- Set en_name correctly (iain.lane)
|
||||||
|
- Don't call g_type_init() on glib >= 2.35; it's deprecated (iain.lane)
|
||||||
|
|
||||||
* Wed Nov 27 2013 David Shea <dshea@redhat.com> - 0.4.1-3
|
* Wed Nov 27 2013 David Shea <dshea@redhat.com> - 0.4.1-3
|
||||||
- Added a glade catalog file (dshea)
|
- Added a glade catalog file (dshea)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user