Update to version 0.8.0
This commit is contained in:
parent
20e5de6a12
commit
f6f5e2b76e
2
.gitignore
vendored
2
.gitignore
vendored
@ -25,3 +25,5 @@ libssh-0.4.4.tar.gz.asc
|
||||
/libssh-0.7.3.tar.xz
|
||||
/libssh-0.7.4.tar.xz
|
||||
/libssh-0.7.5.tar.xz
|
||||
/libssh-0.8.0.tar.xz
|
||||
/libssh-0.8.0.tar.xz.asc
|
||||
|
@ -1,32 +0,0 @@
|
||||
From 5333be5988c3789e7011598995f4df90d50d84d0 Mon Sep 17 00:00:00 2001
|
||||
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
|
||||
Date: Sun, 4 Jun 2017 11:54:55 +0300
|
||||
Subject: config: Bugfix: Don't skip unseen opcodes
|
||||
|
||||
libssh fails to read the configuration from a config file due to a
|
||||
wrong check in 'ssh_config_parse_line' procedure in 'config.c'; it's
|
||||
effectively skipping every opcode (and therefore every option) from
|
||||
the file. The change fixes that behaviour.
|
||||
|
||||
Signed-off-by: Artyom V. Poptsov <poptsov.artyom@gmail.com>
|
||||
Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
|
||||
---
|
||||
src/config.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/config.c b/src/config.c
|
||||
index 6478fc5f..519926e7 100644
|
||||
--- a/src/config.c
|
||||
+++ b/src/config.c
|
||||
@@ -219,7 +219,7 @@ static int ssh_config_parse_line(ssh_session session, const char *line,
|
||||
|
||||
opcode = ssh_config_get_opcode(keyword);
|
||||
if (*parsing == 1 && opcode != SOC_HOST) {
|
||||
- if (seen[opcode] == 0) {
|
||||
+ if (seen[opcode] != 0) {
|
||||
return 0;
|
||||
}
|
||||
seen[opcode] = 1;
|
||||
--
|
||||
cgit v1.1
|
||||
|
File diff suppressed because it is too large
Load Diff
BIN
libssh.keyring
Normal file
BIN
libssh.keyring
Normal file
Binary file not shown.
27
libssh.spec
27
libssh.spec
@ -1,14 +1,13 @@
|
||||
Name: libssh
|
||||
Version: 0.7.5
|
||||
Release: 9%{?dist}
|
||||
Version: 0.8.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A library implementing the SSH protocol
|
||||
License: LGPLv2+
|
||||
URL: http://www.libssh.org
|
||||
|
||||
Source0: https://red.libssh.org/attachments/download/218/libssh-0.7.5.tar.xz
|
||||
|
||||
Patch0: libssh-0.7.5-fix-config-parsing.patch
|
||||
Patch1: libssh-0.7.5-openssl-1.1.patch
|
||||
Source0: https://www.libssh.org/files/0.8/%{name}-%{version}.tar.xz
|
||||
Source1: https://www.libssh.org/files/0.8/%{name}-%{version}.tar.xz.asc
|
||||
Source2: https://cryptomilk.org/gpgkey-8DFF53E18F2ABC8D8F3C92237EE0FC4DCC014E3D.gpg#/%{name}.keyring
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: doxygen
|
||||
@ -36,6 +35,7 @@ The %{name}-devel package contains libraries and header files for developing
|
||||
applications that use %{name}.
|
||||
|
||||
%prep
|
||||
gpgv2 --quiet --keyring %{SOURCE2} %{SOURCE1} %{SOURCE0}
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
@ -45,7 +45,7 @@ fi
|
||||
pushd obj
|
||||
|
||||
%cmake .. \
|
||||
-DWITH_TESTING=ON
|
||||
-DUNIT_TESTING=ON
|
||||
|
||||
%make_build VERBOSE=1
|
||||
make doc
|
||||
@ -58,23 +58,18 @@ make DESTDIR=%{buildroot} install/fast -C obj
|
||||
## unpackaged files
|
||||
# static libs forced on using WITH_TESTING
|
||||
rm -fv %{buildroot}%{_libdir}/libssh.a
|
||||
rm -fv %{buildroot}%{_libdir}/libssh_threads.a
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%check
|
||||
pushd obj
|
||||
make test || {
|
||||
cat Testing/Temporary/LastTest.log;
|
||||
exit 1;
|
||||
}
|
||||
ctest --output-on-failure
|
||||
popd
|
||||
|
||||
%files
|
||||
%doc AUTHORS BSD ChangeLog README
|
||||
%license COPYING
|
||||
%{_libdir}/libssh.so.4*
|
||||
%{_libdir}/libssh_threads.so.4*
|
||||
|
||||
%files devel
|
||||
%doc obj/doc/html
|
||||
@ -83,11 +78,13 @@ popd
|
||||
%dir %{_libdir}/cmake/
|
||||
%{_libdir}/cmake/libssh/
|
||||
%{_libdir}/pkgconfig/libssh.pc
|
||||
%{_libdir}/pkgconfig/libssh_threads.pc
|
||||
%{_libdir}/libssh.so
|
||||
%{_libdir}/libssh_threads.so
|
||||
|
||||
%changelog
|
||||
* Fri Aug 10 2018 Andreas Schneider <asn@redhat.com> - 0.8.0-1
|
||||
- Update to version 0.8.0
|
||||
https://www.libssh.org/2018/08/10/libssh-0-8-0/
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.5-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
3
sources
3
sources
@ -1 +1,2 @@
|
||||
SHA512 (libssh-0.7.5.tar.xz) = 6c7f539899caaedf13d66fa2e0fac1a475ecdfe389131abcbdf908bdebc50a0b9e6b0d43e67e52aea85c32f6aa68e46ca2f50695992f82ded83489f445a8e775
|
||||
SHA512 (libssh-0.8.0.tar.xz) = 63512871f77a3dee52ace4434844647d5715c08f7803e2ffee3b0aa1effe287452e7601df56f7628608d3d58b6cb48d5c909501457e7a3ead5414b7b260070f4
|
||||
SHA512 (libssh-0.8.0.tar.xz.asc) = e52fc20c5423f79ce120f743a831891e410f20d9ebdf2703a8643df69a643411e76e81d4c4d3cdb39930165ef6586d01233a30cf77db7b22b16cce6e5d8ef64e
|
||||
|
Loading…
Reference in New Issue
Block a user