Update to version 0.5.5.
This commit is contained in:
parent
5bb14cc944
commit
aa5810c342
2
.gitignore
vendored
2
.gitignore
vendored
@ -12,3 +12,5 @@ libssh-0.4.4.tar.gz.asc
|
||||
/libssh-0.5.3.tar.asc
|
||||
/libssh-0.5.4.tar.gz
|
||||
/libssh-0.5.4.tar.asc
|
||||
/libssh-0.5.5.tar.gz
|
||||
/libssh-0.5.5.tar.asc
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 068ab9f61196b01235173623c1cca3143cf1d43a Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Sat, 13 Jul 2013 14:13:52 +0400
|
||||
Subject: [PATCH] Check for NULL pointers in ssh_channel_close
|
||||
|
||||
---
|
||||
src/channels.c | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/channels.c b/src/channels.c
|
||||
index 214485c..3fac10e 100644
|
||||
--- a/src/channels.c
|
||||
+++ b/src/channels.c
|
||||
@@ -1080,9 +1080,15 @@ error:
|
||||
* @see channel_eof()
|
||||
*/
|
||||
int ssh_channel_close(ssh_channel channel){
|
||||
- ssh_session session = channel->session;
|
||||
+ ssh_session session;
|
||||
int rc = 0;
|
||||
|
||||
+ if (channel == NULL) {
|
||||
+ return SSH_ERROR;
|
||||
+ }
|
||||
+
|
||||
+ session = channel->session;
|
||||
+
|
||||
enter_function();
|
||||
|
||||
if (channel->local_eof == 0) {
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -2,9 +2,11 @@ Description: Be sure we never build LaTeX documentation
|
||||
Author: Laurent Bigonville <bigon@debian.org>
|
||||
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622108
|
||||
|
||||
--- a/doc/doxy.config.in
|
||||
+++ b/doc/doxy.config.in
|
||||
@@ -1014,7 +1014,7 @@
|
||||
Index: libssh-0.5.5/doc/doxy.config.in
|
||||
===================================================================
|
||||
--- libssh-0.5.5.orig/doc/doxy.config.in
|
||||
+++ libssh-0.5.5/doc/doxy.config.in
|
||||
@@ -1015,7 +1015,7 @@ SEARCHENGINE = NO
|
||||
# If the GENERATE_LATEX tag is set to YES (the default) Doxygen will
|
||||
# generate Latex output.
|
||||
|
||||
@ -13,3 +15,53 @@ Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622108
|
||||
|
||||
# The LATEX_OUTPUT tag is used to specify where the LaTeX docs will be put.
|
||||
# If a relative path is entered the value of OUTPUT_DIRECTORY will be
|
||||
Index: libssh-0.5.5/cmake/Modules/UseDoxygen.cmake
|
||||
===================================================================
|
||||
--- libssh-0.5.5.orig/cmake/Modules/UseDoxygen.cmake
|
||||
+++ libssh-0.5.5/cmake/Modules/UseDoxygen.cmake
|
||||
@@ -63,27 +63,27 @@ if(DOXYGEN_FOUND AND DOXYFILE_IN_FOUND)
|
||||
set(DOXYFILE_PDFLATEX FALSE)
|
||||
set(DOXYFILE_DOT FALSE)
|
||||
|
||||
- find_package(LATEX)
|
||||
- if(LATEX_COMPILER AND MAKEINDEX_COMPILER)
|
||||
- set(DOXYFILE_LATEX TRUE)
|
||||
- usedoxygen_set_default(DOXYFILE_LATEX_DIR "latex")
|
||||
+ #find_package(LATEX)
|
||||
+ #if(LATEX_COMPILER AND MAKEINDEX_COMPILER)
|
||||
+ # set(DOXYFILE_LATEX TRUE)
|
||||
+ # usedoxygen_set_default(DOXYFILE_LATEX_DIR "latex")
|
||||
|
||||
- set_property(DIRECTORY APPEND PROPERTY
|
||||
- ADDITIONAL_MAKE_CLEAN_FILES
|
||||
- "${DOXYFILE_OUTPUT_DIR}/${DOXYFILE_LATEX_DIR}")
|
||||
+ # set_property(DIRECTORY APPEND PROPERTY
|
||||
+ # ADDITIONAL_MAKE_CLEAN_FILES
|
||||
+ # "${DOXYFILE_OUTPUT_DIR}/${DOXYFILE_LATEX_DIR}")
|
||||
|
||||
- if(PDFLATEX_COMPILER)
|
||||
- set(DOXYFILE_PDFLATEX TRUE)
|
||||
- endif()
|
||||
- if(DOXYGEN_DOT_EXECUTABLE)
|
||||
- set(DOXYFILE_DOT TRUE)
|
||||
- endif()
|
||||
+ # if(PDFLATEX_COMPILER)
|
||||
+ # set(DOXYFILE_PDFLATEX TRUE)
|
||||
+ # endif()
|
||||
+ # if(DOXYGEN_DOT_EXECUTABLE)
|
||||
+ # set(DOXYFILE_DOT TRUE)
|
||||
+ # endif()
|
||||
|
||||
- add_custom_command(TARGET doxygen
|
||||
- POST_BUILD
|
||||
- COMMAND ${CMAKE_MAKE_PROGRAM}
|
||||
- WORKING_DIRECTORY "${DOXYFILE_OUTPUT_DIR}/${DOXYFILE_LATEX_DIR}")
|
||||
- endif()
|
||||
+ # add_custom_command(TARGET doxygen
|
||||
+ # POST_BUILD
|
||||
+ # COMMAND ${CMAKE_MAKE_PROGRAM}
|
||||
+ # WORKING_DIRECTORY "${DOXYFILE_OUTPUT_DIR}/${DOXYFILE_LATEX_DIR}")
|
||||
+ #endif()
|
||||
|
||||
configure_file(${DOXYFILE_IN} ${CMAKE_CURRENT_BINARY_DIR}/doxy.config ESCAPE_QUOTES IMMEDIATE @ONLY)
|
||||
if (EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/doxy.trac.in)
|
||||
|
@ -1,14 +0,0 @@
|
||||
Subject: Fix typo
|
||||
From: Laurent Bigonville <bigon@debian.org>
|
||||
|
||||
--- a/src/server.c
|
||||
+++ b/src/server.c
|
||||
@@ -186,7 +186,7 @@ static int dh_handshake_server(ssh_sessi
|
||||
default:
|
||||
ssh_set_error(session,
|
||||
SSH_FATAL,
|
||||
- "Could determine the specified hostkey");
|
||||
+ "Could not determine the specified hostkey");
|
||||
ssh_string_free(f);
|
||||
return -1;
|
||||
}
|
65
libssh.spec
65
libssh.spec
@ -1,23 +1,21 @@
|
||||
Name: libssh
|
||||
Version: 0.5.4
|
||||
Release: 5%{?dist}
|
||||
Version: 0.5.5
|
||||
Release: 1%{?dist}
|
||||
Summary: A library implementing the SSH2 protocol (0xbadc0de version)
|
||||
License: LGPLv2+
|
||||
URL: http://www.libssh.org/
|
||||
Group: System Environment/Libraries
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Source0: https://red.libssh.org/attachments/download/41/libssh-0.5.4.tar.gz
|
||||
Source1: https://red.libssh.org/attachments/download/42/libssh-0.5.4.tar.asc
|
||||
Patch0: libssh-0.5.4-channel-close.patch
|
||||
Patch1: libssh-0.5.4-disable-latex-documentation.patch
|
||||
Patch2: libssh-0.5.4-fix-html-doc-generation.patch
|
||||
Patch3: libssh-0.5.4-fix-typo.patch
|
||||
Source0: https://red.libssh.org/attachments/download/51/libssh-0.5.5.tar.gz
|
||||
Source1: https://red.libssh.org/attachments/download/50/libssh-0.5.5.tar.asc
|
||||
Patch0: libssh-0.5.4-disable-latex-documentation.patch
|
||||
Patch1: libssh-0.5.4-fix-html-doc-generation.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: zlib-devel
|
||||
|
||||
%description
|
||||
The ssh library was designed to be used by programmers needing a working SSH
|
||||
@ -38,28 +36,29 @@ applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .channel-close
|
||||
%patch1 -p1 -b .disable-latex-documentation
|
||||
%patch2 -p1 -b .fix-html-doc-generation
|
||||
%patch3 -p1 -b .fix-typo
|
||||
%patch0 -p1 -b .disable-latex-documentation
|
||||
%patch1 -p1 -b .fix-html-doc-generation
|
||||
# Remove examples, they are not packaged and do not build on EPEL 5
|
||||
sed -i -e 's|add_subdirectory(examples)||g' CMakeLists.txt
|
||||
rm -fr examples
|
||||
|
||||
%build
|
||||
mkdir obj
|
||||
cd obj
|
||||
%cmake ..
|
||||
make
|
||||
if test ! -e "obj"; then
|
||||
mkdir obj
|
||||
fi
|
||||
pushd obj
|
||||
|
||||
%cmake \
|
||||
%{_builddir}/%{name}-%{version}
|
||||
make %{?_smp_mflags} VERBOSE=1
|
||||
make doc
|
||||
|
||||
popd
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
cd obj
|
||||
make install DESTDIR=%{buildroot}
|
||||
find %{buildroot} -name '*.la' -delete
|
||||
install -d %{buildroot}%{_datadir}
|
||||
mv %{buildroot}/%{_libdir}/pkgconfig %{buildroot}/usr/share
|
||||
pushd obj
|
||||
make DESTDIR=%{buildroot} install
|
||||
popd
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
@ -70,15 +69,27 @@ rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%doc AUTHORS BSD ChangeLog COPYING README
|
||||
%{_libdir}/*.so.*
|
||||
%{_libdir}/libssh.so.*
|
||||
%{_libdir}/libssh_threads.so.*
|
||||
|
||||
%files devel
|
||||
%doc obj/doc/html
|
||||
%{_datadir}/pkgconfig/*.pc
|
||||
%{_includedir}/*
|
||||
%{_libdir}/*.so
|
||||
%{_includedir}/libssh/callbacks.h
|
||||
%{_includedir}/libssh/legacy.h
|
||||
%{_includedir}/libssh/libssh.h
|
||||
%{_includedir}/libssh/server.h
|
||||
%{_includedir}/libssh/sftp.h
|
||||
%{_includedir}/libssh/ssh2.h
|
||||
%{_libdir}/pkgconfig/libssh.pc
|
||||
%{_libdir}/pkgconfig/libssh_threads.pc
|
||||
%{_libdir}/libssh.so
|
||||
%{_libdir}/libssh_threads.so
|
||||
|
||||
%changelog
|
||||
* Fri Jul 26 2013 - Andreas Schneider <asn@redhat.com> - 0.5.5-1
|
||||
- Update to 0.5.5.
|
||||
- Clenup the spec file.
|
||||
|
||||
* Thu Jul 18 2013 Simone Caronni <negativo17@gmail.com> - 0.5.4-5
|
||||
- Add EPEL 5 support.
|
||||
- Add Debian patches to enable Doxygen documentation.
|
||||
|
Loading…
Reference in New Issue
Block a user