Update to version 0.10.3
This commit is contained in:
parent
66a9be7750
commit
4b6782cd1b
8
.gitignore
vendored
8
.gitignore
vendored
@ -56,3 +56,11 @@ libssh-0.4.4.tar.gz.asc
|
||||
/libssh-0.9.5.tar.xz.asc
|
||||
/libssh-0.9.6.tar.xz
|
||||
/libssh-0.9.6.tar.xz.asc
|
||||
/libssh-0.10.0.tar.xz
|
||||
/libssh-0.10.0.tar.xz.asc
|
||||
/libssh-0.10.1.tar.xz
|
||||
/libssh-0.10.1.tar.xz.asc
|
||||
/libssh-0.10.2.tar.xz
|
||||
/libssh-0.10.2.tar.xz.asc
|
||||
/libssh-0.10.3.tar.xz
|
||||
/libssh-0.10.3.tar.xz.asc
|
||||
|
@ -1,61 +0,0 @@
|
||||
From 86ee3f5a00c2f5237dcbb09f80283af703ced3f5 Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Jelen <jjelen@redhat.com>
|
||||
Date: Thu, 27 Jan 2022 21:04:03 +0100
|
||||
Subject: [PATCH] tests: Skip the workaround forcing SHA1 signatures
|
||||
|
||||
In certificate authentication with OpenSSH 8.0, the SHA2 signatures were
|
||||
not accepted correctly [1]. This was not an issue up until the OpenSSH
|
||||
8.8p1, which does no longer allow SHA1 signatures by default so this
|
||||
broke the CI and tests against the new OpenSSH [2].
|
||||
|
||||
Fixes !107
|
||||
|
||||
[1] https://bugzilla.mindrot.org/show_bug.cgi?id=3016
|
||||
[2] https://gitlab.com/libssh/libssh-mirror/-/issues/107
|
||||
|
||||
Signed-off-by: Jakub Jelen <jjelen@redhat.com>
|
||||
Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
|
||||
---
|
||||
tests/client/torture_auth.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/tests/client/torture_auth.c b/tests/client/torture_auth.c
|
||||
index 29f6f5a5..d02fd6e2 100644
|
||||
--- a/tests/client/torture_auth.c
|
||||
+++ b/tests/client/torture_auth.c
|
||||
@@ -642,6 +642,7 @@ static void torture_auth_cert(void **state) {
|
||||
|
||||
static void torture_auth_agent_cert(void **state)
|
||||
{
|
||||
+#if OPENSSH_VERSION_MAJOR < 8
|
||||
struct torture_state *s = *state;
|
||||
ssh_session session = s->ssh.session;
|
||||
int rc;
|
||||
@@ -661,6 +662,7 @@ static void torture_auth_agent_cert(void **state)
|
||||
"ssh-rsa-cert-v01@openssh.com");
|
||||
assert_int_equal(rc, SSH_OK);
|
||||
}
|
||||
+#endif /* OPENSSH_VERSION_MAJOR < 8 */
|
||||
|
||||
/* Setup loads a different key, tests are exactly the same. */
|
||||
torture_auth_agent(state);
|
||||
@@ -668,6 +670,7 @@ static void torture_auth_agent_cert(void **state)
|
||||
|
||||
static void torture_auth_agent_cert_nonblocking(void **state)
|
||||
{
|
||||
+#if OPENSSH_VERSION_MAJOR < 8
|
||||
struct torture_state *s = *state;
|
||||
ssh_session session = s->ssh.session;
|
||||
int rc;
|
||||
@@ -687,6 +690,7 @@ static void torture_auth_agent_cert_nonblocking(void **state)
|
||||
"ssh-rsa-cert-v01@openssh.com");
|
||||
assert_int_equal(rc, SSH_OK);
|
||||
}
|
||||
+#endif /* OPENSSH_VERSION_MAJOR < 8 */
|
||||
|
||||
torture_auth_agent_nonblocking(state);
|
||||
}
|
||||
--
|
||||
GitLab
|
||||
|
||||
|
19
libssh.spec
19
libssh.spec
@ -1,16 +1,15 @@
|
||||
Name: libssh
|
||||
Version: 0.9.6
|
||||
Release: 5%{?dist}
|
||||
Version: 0.10.3
|
||||
Release: 1%{?dist}
|
||||
Summary: A library implementing the SSH protocol
|
||||
License: LGPLv2+
|
||||
URL: http://www.libssh.org
|
||||
|
||||
Source0: https://www.libssh.org/files/0.9/%{name}-%{version}.tar.xz
|
||||
Source1: https://www.libssh.org/files/0.9/%{name}-%{version}.tar.xz.asc
|
||||
Source0: https://www.libssh.org/files/0.10/%{name}-%{version}.tar.xz
|
||||
Source1: https://www.libssh.org/files/0.10/%{name}-%{version}.tar.xz.asc
|
||||
Source2: https://cryptomilk.org/gpgkey-8DFF53E18F2ABC8D8F3C92237EE0FC4DCC014E3D.gpg#/%{name}.keyring
|
||||
Source3: libssh_client.config
|
||||
Source4: libssh_server.config
|
||||
Patch1: libssh-0.9.6-openssh-8.8p1-compat.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc-c++
|
||||
@ -108,7 +107,7 @@ popd
|
||||
%ctest
|
||||
|
||||
%files
|
||||
%doc AUTHORS BSD ChangeLog README
|
||||
%doc AUTHORS BSD CHANGELOG README
|
||||
%license COPYING
|
||||
%{_libdir}/libssh.so.4*
|
||||
%{_libdir}/libssh_threads.so.4*
|
||||
@ -128,6 +127,14 @@ popd
|
||||
%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/libssh/libssh_server.config
|
||||
|
||||
%changelog
|
||||
* Fri Sep 02 2022 Andreas Schneider <asn@redhat.com> - 0.10.3-1
|
||||
- Update to version 0.10.3
|
||||
https://git.libssh.org/projects/libssh.git/tag/?h=libssh-0.10.3
|
||||
https://git.libssh.org/projects/libssh.git/tag/?h=libssh-0.10.2
|
||||
https://git.libssh.org/projects/libssh.git/tag/?h=libssh-0.10.1
|
||||
https://git.libssh.org/projects/libssh.git/tag/?h=libssh-0.10.0
|
||||
- Removed libssh-0.9.6-openssh-8.8p1-compat.patch
|
||||
|
||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.6-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (libssh-0.9.6.tar.xz) = 4040ec4af937e95be2e41313ef6d4db60b46b8d4dea10c09402398127c1d1ca8843392d207088aeee3c7ef631c6ae7b66861327dcebf78ed3af0723777619fd1
|
||||
SHA512 (libssh-0.9.6.tar.xz.asc) = 1b6223efe9e4ce864cd8d97d517f9f0d38c1cd502b5874fdc6a58731038c2830a72ce753f02fc062d9d4d5922107ec9a2e62fe24a704bb5dec0dcfecdb569fe6
|
||||
SHA512 (libssh-0.10.3.tar.xz) = dfc992a4d16bf3de6ed01b1d0d73e061f61acf6785b2c81a722154219a286fc2b8952dec0e842bcbc14ce2734078161a820d44091f01851c8538f8f381655253
|
||||
SHA512 (libssh-0.10.3.tar.xz.asc) = e286e0e5cc908afd78e0074bfaae89e4f3413c718f8b520661eb63bf35669ad96300f3e81e00f0468f060b7c05b7f8a72f654bbac561c8b93b69e2241b6ca82e
|
||||
|
Loading…
Reference in New Issue
Block a user