Auto sync2gitlab import of libssh-0.9.6-6.el8.src.rpm
This commit is contained in:
parent
6704d301cd
commit
3ac920abbe
10
libssh.spec
10
libssh.spec
@ -1,6 +1,6 @@
|
|||||||
Name: libssh
|
Name: libssh
|
||||||
Version: 0.9.6
|
Version: 0.9.6
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Summary: A library implementing the SSH protocol
|
Summary: A library implementing the SSH protocol
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://www.libssh.org
|
URL: http://www.libssh.org
|
||||||
@ -12,6 +12,7 @@ Source3: libssh_client.config
|
|||||||
Source4: libssh_server.config
|
Source4: libssh_server.config
|
||||||
|
|
||||||
Patch0: loglevel.patch
|
Patch0: loglevel.patch
|
||||||
|
Patch1: s390x_fix.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
@ -77,6 +78,8 @@ pushd obj
|
|||||||
|
|
||||||
%cmake .. \
|
%cmake .. \
|
||||||
-DUNIT_TESTING=ON \
|
-DUNIT_TESTING=ON \
|
||||||
|
-DCLIENT_TESTING=ON \
|
||||||
|
-DSERVER_TESTING=ON \
|
||||||
-DGLOBAL_CLIENT_CONFIG="%{_sysconfdir}/libssh/libssh_client.config" \
|
-DGLOBAL_CLIENT_CONFIG="%{_sysconfdir}/libssh/libssh_client.config" \
|
||||||
-DGLOBAL_BIND_CONFIG="%{_sysconfdir}/libssh/libssh_server.config"
|
-DGLOBAL_BIND_CONFIG="%{_sysconfdir}/libssh/libssh_server.config"
|
||||||
|
|
||||||
@ -138,6 +141,11 @@ popd
|
|||||||
%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/libssh/libssh_server.config
|
%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/libssh/libssh_server.config
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 06 2023 Norbert Pocs <npocs@redhat.com> - 0.9.6-6
|
||||||
|
- Enable client and server testing build time
|
||||||
|
- Fix failing rekey test on arch s390x
|
||||||
|
- Resolves: rhbz#2126342
|
||||||
|
|
||||||
* Mon Dec 05 2022 Stanislav Zidek <szidek@redhat.com> - 0.9.6-5
|
* Mon Dec 05 2022 Stanislav Zidek <szidek@redhat.com> - 0.9.6-5
|
||||||
- Fix CI configuration for new TMT
|
- Fix CI configuration for new TMT
|
||||||
- Resolves: rhbz#2149910
|
- Resolves: rhbz#2149910
|
||||||
|
19
s390x_fix.patch
Normal file
19
s390x_fix.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
diff --git a/src/packet.c b/src/packet.c
|
||||||
|
index ec4a7203..a81eb8e3 100644
|
||||||
|
--- a/src/packet.c
|
||||||
|
+++ b/src/packet.c
|
||||||
|
@@ -1752,10 +1752,12 @@ static bool
|
||||||
|
ssh_packet_in_rekey(ssh_session session)
|
||||||
|
{
|
||||||
|
/* We know we are rekeying if we are authenticated and the DH
|
||||||
|
- * status is not finished
|
||||||
|
+ * status is not finished, but we only queue packets until we've
|
||||||
|
+ * sent our NEWKEYS.
|
||||||
|
*/
|
||||||
|
return (session->flags & SSH_SESSION_FLAG_AUTHENTICATED) &&
|
||||||
|
- (session->dh_handshake_state != DH_STATE_FINISHED);
|
||||||
|
+ (session->dh_handshake_state != DH_STATE_FINISHED) &&
|
||||||
|
+ (session->dh_handshake_state != DH_STATE_NEWKEYS_SENT);
|
||||||
|
}
|
||||||
|
|
||||||
|
int ssh_packet_send(ssh_session session)
|
Loading…
Reference in New Issue
Block a user