73 lines
2.8 KiB
Diff
73 lines
2.8 KiB
Diff
diff -Naur libshout-2.2/include/shout/Makefile.am libshout-2.2.patched/include/shout/Makefile.am
|
|
--- libshout-2.2/include/shout/Makefile.am 2004-03-21 05:03:33.000000000 +0100
|
|
+++ libshout-2.2.patched/include/shout/Makefile.am 2006-03-10 14:09:58.000000000 +0100
|
|
@@ -2,5 +2,5 @@
|
|
|
|
AUTOMAKE_OPTIONS = foreign
|
|
|
|
-includedir = $(prefix)/include/shout
|
|
-nodist_include_HEADERS = shout.h
|
|
+pkgincludedir = $(includedir)/shout
|
|
+nodist_pkginclude_HEADERS = shout.h
|
|
diff -Naur libshout-2.2/include/shout/Makefile.in libshout-2.2.patched/include/shout/Makefile.in
|
|
--- libshout-2.2/include/shout/Makefile.in 2006-01-03 20:19:05.000000000 +0100
|
|
+++ libshout-2.2.patched/include/shout/Makefile.in 2006-03-10 14:14:56.000000000 +0100
|
|
@@ -61,7 +61,7 @@
|
|
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
|
|
am__installdirs = "$(DESTDIR)$(includedir)"
|
|
nodist_includeHEADERS_INSTALL = $(INSTALL_HEADER)
|
|
-HEADERS = $(nodist_include_HEADERS)
|
|
+HEADERS = $(nodist_pkginclude_HEADERS)
|
|
ETAGS = etags
|
|
CTAGS = ctags
|
|
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
|
@@ -197,7 +197,7 @@
|
|
host_cpu = @host_cpu@
|
|
host_os = @host_os@
|
|
host_vendor = @host_vendor@
|
|
-includedir = $(prefix)/include/shout
|
|
+pkgincludedir = $(includedir)//shout
|
|
infodir = @infodir@
|
|
install_sh = @install_sh@
|
|
libdir = @libdir@
|
|
@@ -217,7 +217,7 @@
|
|
target = @target@
|
|
target_alias = @target_alias@
|
|
AUTOMAKE_OPTIONS = foreign
|
|
-nodist_include_HEADERS = shout.h
|
|
+nodist_pkginclude_HEADERS = shout.h
|
|
all: all-am
|
|
|
|
.SUFFIXES:
|
|
@@ -262,22 +262,22 @@
|
|
distclean-libtool:
|
|
-rm -f libtool
|
|
uninstall-info-am:
|
|
-install-nodist_includeHEADERS: $(nodist_include_HEADERS)
|
|
+install-nodist_includeHEADERS: $(nodist_pkginclude_HEADERS)
|
|
@$(NORMAL_INSTALL)
|
|
- test -z "$(includedir)" || $(mkdir_p) "$(DESTDIR)$(includedir)"
|
|
- @list='$(nodist_include_HEADERS)'; for p in $$list; do \
|
|
+ test -z "$(pkgincludedir)" || $(mkdir_p) "$(DESTDIR)$(pkgincludedir)"
|
|
+ @list='$(nodist_pkginclude_HEADERS)'; for p in $$list; do \
|
|
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
f=$(am__strip_dir) \
|
|
- echo " $(nodist_includeHEADERS_INSTALL) '$$d$$p' '$(DESTDIR)$(includedir)/$$f'"; \
|
|
- $(nodist_includeHEADERS_INSTALL) "$$d$$p" "$(DESTDIR)$(includedir)/$$f"; \
|
|
+ echo " $(nodist_includeHEADERS_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgincludedir)/$$f'"; \
|
|
+ $(nodist_includeHEADERS_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgincludedir)/$$f"; \
|
|
done
|
|
|
|
uninstall-nodist_includeHEADERS:
|
|
@$(NORMAL_UNINSTALL)
|
|
- @list='$(nodist_include_HEADERS)'; for p in $$list; do \
|
|
+ @list='$(nodist_pkginclude_HEADERS)'; for p in $$list; do \
|
|
f=$(am__strip_dir) \
|
|
- echo " rm -f '$(DESTDIR)$(includedir)/$$f'"; \
|
|
- rm -f "$(DESTDIR)$(includedir)/$$f"; \
|
|
+ echo " rm -f '$(DESTDIR)$(pkgincludedir)/$$f'"; \
|
|
+ rm -f "$(DESTDIR)$(pkgincludedir)/$$f"; \
|
|
done
|
|
|
|
ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
|