new version

This commit is contained in:
Thomas Vander Stichele 2006-03-10 15:48:41 +00:00
parent bf2b455851
commit dc26c0c178
4 changed files with 100 additions and 12 deletions

View File

@ -1 +1 @@
libshout-1.0.9.tar.gz
libshout-2.2.tar.gz

72
libshout.autotools.patch Normal file
View File

@ -0,0 +1,72 @@
diff -Naur libshout-2.2/include/shout/Makefile.am libshout-2.2.patched/include/shout/Makefile.am
--- libshout-2.2/include/shout/Makefile.am 2004-03-21 05:03:33.000000000 +0100
+++ libshout-2.2.patched/include/shout/Makefile.am 2006-03-10 14:09:58.000000000 +0100
@@ -2,5 +2,5 @@
AUTOMAKE_OPTIONS = foreign
-includedir = $(prefix)/include/shout
-nodist_include_HEADERS = shout.h
+pkgincludedir = $(includedir)/shout
+nodist_pkginclude_HEADERS = shout.h
diff -Naur libshout-2.2/include/shout/Makefile.in libshout-2.2.patched/include/shout/Makefile.in
--- libshout-2.2/include/shout/Makefile.in 2006-01-03 20:19:05.000000000 +0100
+++ libshout-2.2.patched/include/shout/Makefile.in 2006-03-10 14:14:56.000000000 +0100
@@ -61,7 +61,7 @@
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
am__installdirs = "$(DESTDIR)$(includedir)"
nodist_includeHEADERS_INSTALL = $(INSTALL_HEADER)
-HEADERS = $(nodist_include_HEADERS)
+HEADERS = $(nodist_pkginclude_HEADERS)
ETAGS = etags
CTAGS = ctags
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
@@ -197,7 +197,7 @@
host_cpu = @host_cpu@
host_os = @host_os@
host_vendor = @host_vendor@
-includedir = $(prefix)/include/shout
+pkgincludedir = $(includedir)//shout
infodir = @infodir@
install_sh = @install_sh@
libdir = @libdir@
@@ -217,7 +217,7 @@
target = @target@
target_alias = @target_alias@
AUTOMAKE_OPTIONS = foreign
-nodist_include_HEADERS = shout.h
+nodist_pkginclude_HEADERS = shout.h
all: all-am
.SUFFIXES:
@@ -262,22 +262,22 @@
distclean-libtool:
-rm -f libtool
uninstall-info-am:
-install-nodist_includeHEADERS: $(nodist_include_HEADERS)
+install-nodist_includeHEADERS: $(nodist_pkginclude_HEADERS)
@$(NORMAL_INSTALL)
- test -z "$(includedir)" || $(mkdir_p) "$(DESTDIR)$(includedir)"
- @list='$(nodist_include_HEADERS)'; for p in $$list; do \
+ test -z "$(pkgincludedir)" || $(mkdir_p) "$(DESTDIR)$(pkgincludedir)"
+ @list='$(nodist_pkginclude_HEADERS)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
f=$(am__strip_dir) \
- echo " $(nodist_includeHEADERS_INSTALL) '$$d$$p' '$(DESTDIR)$(includedir)/$$f'"; \
- $(nodist_includeHEADERS_INSTALL) "$$d$$p" "$(DESTDIR)$(includedir)/$$f"; \
+ echo " $(nodist_includeHEADERS_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgincludedir)/$$f'"; \
+ $(nodist_includeHEADERS_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgincludedir)/$$f"; \
done
uninstall-nodist_includeHEADERS:
@$(NORMAL_UNINSTALL)
- @list='$(nodist_include_HEADERS)'; for p in $$list; do \
+ @list='$(nodist_pkginclude_HEADERS)'; for p in $$list; do \
f=$(am__strip_dir) \
- echo " rm -f '$(DESTDIR)$(includedir)/$$f'"; \
- rm -f "$(DESTDIR)$(includedir)/$$f"; \
+ echo " rm -f '$(DESTDIR)$(pkgincludedir)/$$f'"; \
+ rm -f "$(DESTDIR)$(pkgincludedir)/$$f"; \
done
ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)

View File

@ -1,18 +1,26 @@
Name: libshout
Version: 1.0.9
Release: 5%{?dist}
Version: 2.2
Release: 1%{?dist}
Summary: icecast source streaming library
Group: Libraries/Multimedia
Group: System Environment/Libraries
License: LGPL
URL: http://www.icecast.org/
Source: http://developer.icecast.org/libshout/releases/%{name}-%{version}.tar.gz
Patch: libshout-makefile.patch
Source: http://downloads.us.xiph.org/releases/libshout/libshout-%{version}.tar.gz
Patch: libshout.autotools.patch
BuildRequires: libogg-devel
BuildRequires: libvorbis-devel
BuildRequires: libtheora-devel
BuildRequires: speex-devel
# so it generates and installs the .pc file
BuildRequires: pkgconfig
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%description
Libshout is a library for communicating with and sending data to an
ibshout is a library for communicating with and sending data to an
icecast server. It handles the socket connection, the timing of the
data, and prevents most bad data from getting to the icecast server.
@ -37,11 +45,12 @@ make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
# docs install in $(prefix)/doc, we don't want that, so don't go into SUBDIRS
%makeinstall SUBDIRS=
%makeinstall
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
rm -rf $RPM_BUILD_ROOT%{_docdir}
%clean
rm -rf $RPM_BUILD_ROOT
@ -51,18 +60,25 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc AUTHORS CHANGES COPYING README
%doc COPYING NEWS README
%{_libdir}/libshout.so.*
%files devel
%defattr(-,root,root,-)
%doc doc/*.html doc/style.css
%doc examples/*.c doc/*.xml doc/*.xsl
%{_libdir}/libshout.a
%{_libdir}/libshout.so
%{_libdir}/pkgconfig/shout.pc
%dir %{_includedir}/shout/
%{_includedir}/shout/shout.h
%{_datadir}/aclocal/shout.m4
%changelog
* Fri Mar 10 2006 Thomas Vander Stichele <thomas at apestaart dot org>
- 2.2-1
- new (incompatible) version, but deps are updated
- various cleanups
* Sun Mar 05 2006 Thomas Vander Stichele <thomas at apestaart dot org>
- 1.0.9-5
- rebuild

View File

@ -1 +1 @@
bbe598e28bbf2989a90d78ff33953ea2 libshout-1.0.9.tar.gz
d5b273a072785ee14a85ff76f66850aa libshout-2.2.tar.gz