Fix test suite to build
This commit is contained in:
parent
518c1aa0ae
commit
db579f949e
@ -0,0 +1,13 @@
|
||||
diff --git a/libsemanage/tests/Makefile b/libsemanage/tests/Makefile
|
||||
index f92455c..ad1869b 100644
|
||||
--- a/libsemanage/tests/Makefile
|
||||
+++ b/libsemanage/tests/Makefile
|
||||
@@ -13,7 +13,7 @@ EXECUTABLE = libsemanage-tests
|
||||
CC = gcc
|
||||
CFLAGS = -c -g -o0 -Wall -W -Wundef -Wmissing-noreturn -Wmissing-format-attribute -Wno-unused-parameter
|
||||
INCLUDE = -I$(TESTSRC) -I$(TESTSRC)/../include
|
||||
-LDFLAGS = -lcunit -lustr -lbz2
|
||||
+LDFLAGS = -lcunit -lustr -lbz2 -lpthread
|
||||
OBJECTS = $(SOURCES:.c=.o)
|
||||
|
||||
all: $(EXECUTABLE)
|
@ -10,7 +10,7 @@
|
||||
Summary: SELinux binary policy manipulation library
|
||||
Name: libsemanage
|
||||
Version: 2.1.10
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
Source: libsemanage-%{version}.tgz
|
||||
@ -181,6 +181,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%endif # if with_python3
|
||||
|
||||
%changelog
|
||||
* Thu Apr 11 2013 Dan Walsh <dwalsh@redhat.com> - 2.1.10-3
|
||||
- Fix test suite to build
|
||||
|
||||
* Thu Feb 14 2013 Dan Walsh <dwalsh@redhat.com> - 2.1.10-2
|
||||
- Revert some changes which are causing the wrong policy version file to be created
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user