- Fix test suite to build
This commit is contained in:
parent
db579f949e
commit
13bc72f76a
@ -1,3 +1,18 @@
|
|||||||
|
diff --git a/libsemanage/src/utilities.c b/libsemanage/src/utilities.c
|
||||||
|
index 349a4be..a340fc8 100644
|
||||||
|
--- a/libsemanage/src/utilities.c
|
||||||
|
+++ b/libsemanage/src/utilities.c
|
||||||
|
@@ -140,6 +140,10 @@ int semanage_list_push(semanage_list_t ** list, char *data)
|
||||||
|
|
||||||
|
if (!data)
|
||||||
|
return EINVAL;
|
||||||
|
+
|
||||||
|
+ if (semanage_list_find(*list, data) != NULL)
|
||||||
|
+ return 0;
|
||||||
|
+
|
||||||
|
if (!(temp = malloc(sizeof(semanage_list_t))))
|
||||||
|
return ENOMEM;
|
||||||
|
|
||||||
diff --git a/libsemanage/tests/Makefile b/libsemanage/tests/Makefile
|
diff --git a/libsemanage/tests/Makefile b/libsemanage/tests/Makefile
|
||||||
index f92455c..ad1869b 100644
|
index f92455c..ad1869b 100644
|
||||||
--- a/libsemanage/tests/Makefile
|
--- a/libsemanage/tests/Makefile
|
||||||
|
@ -10,7 +10,7 @@
|
|||||||
Summary: SELinux binary policy manipulation library
|
Summary: SELinux binary policy manipulation library
|
||||||
Name: libsemanage
|
Name: libsemanage
|
||||||
Version: 2.1.10
|
Version: 2.1.10
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: libsemanage-%{version}.tgz
|
Source: libsemanage-%{version}.tgz
|
||||||
@ -181,6 +181,8 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%endif # if with_python3
|
%endif # if with_python3
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 22 2013 Dan Walsh <dwalsh@redhat.com> - 2.1.10-4
|
||||||
|
-
|
||||||
* Thu Apr 11 2013 Dan Walsh <dwalsh@redhat.com> - 2.1.10-3
|
* Thu Apr 11 2013 Dan Walsh <dwalsh@redhat.com> - 2.1.10-3
|
||||||
- Fix test suite to build
|
- Fix test suite to build
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user