update to latest upstream 1.3.6
This commit is contained in:
parent
cba7b337b0
commit
12fd245d4e
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
librtas-1.3.4.tar.gz
|
librtas-1.3.4.tar.gz
|
||||||
/librtas-1.3.5.tar.gz
|
/librtas-1.3.5.tar.gz
|
||||||
|
/librtas-1.3.6.tar.gz
|
||||||
|
@ -1,36 +0,0 @@
|
|||||||
diff -up librtas-1.3.5/libofdt_src/Makefile.ln librtas-1.3.5/libofdt_src/Makefile
|
|
||||||
--- librtas-1.3.5/libofdt_src/Makefile.ln 2011-08-09 16:02:40.228882952 +0200
|
|
||||||
+++ librtas-1.3.5/libofdt_src/Makefile 2011-08-09 16:02:58.788149712 +0200
|
|
||||||
@@ -26,7 +26,7 @@ all: $(LIBOFDT_OBJS) $(LIBOFDT_HDRS)
|
|
||||||
install:
|
|
||||||
@$(call install_lib,$(LIBOFDT),$(DESTDIR))
|
|
||||||
@$(call install_inc,$(LIBOFDT_SHIP_HDR),$(DESTDIR))
|
|
||||||
- @ln -sf $(LIBOFDT) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBOFDT))/$(LIBOFDT_SONAME)
|
|
||||||
+ @ln -sf $(LIBOFDT) $(DESTDIR)/$(LIB_DIR)/$(LIBOFDT_SONAME)
|
|
||||||
|
|
||||||
uninstall:
|
|
||||||
@$(call uninstall_lib,$(LIBOFDT),$(DESTDIR))
|
|
||||||
diff -up librtas-1.3.5/librtasevent_src/Makefile.ln librtas-1.3.5/librtasevent_src/Makefile
|
|
||||||
--- librtas-1.3.5/librtasevent_src/Makefile.ln 2011-08-09 16:03:18.310430003 +0200
|
|
||||||
+++ librtas-1.3.5/librtasevent_src/Makefile 2011-08-09 16:03:34.484661982 +0200
|
|
||||||
@@ -27,7 +27,7 @@ all: $(LIBRE_OBJS) $(HEADERS)
|
|
||||||
install:
|
|
||||||
@$(call install_lib,$(LIBRE),$(DESTDIR))
|
|
||||||
@$(call install_inc,$(LIBRE_HDRS),$(DESTDIR))
|
|
||||||
- @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME)
|
|
||||||
+ @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME)
|
|
||||||
|
|
||||||
uninstall:
|
|
||||||
@$(call uninstall_lib,$(LIBRE),$(DESTDIR))
|
|
||||||
diff -up librtas-1.3.5/librtas_src/Makefile.ln librtas-1.3.5/librtas_src/Makefile
|
|
||||||
--- librtas-1.3.5/librtas_src/Makefile.ln 2011-08-09 16:01:54.008217333 +0200
|
|
||||||
+++ librtas-1.3.5/librtas_src/Makefile 2011-08-09 16:02:22.242624149 +0200
|
|
||||||
@@ -32,7 +32,7 @@ librtas_static: $(LIBRTAS_OBJS) $(HEADER
|
|
||||||
install:
|
|
||||||
@$(call install_lib,$(LIBRTAS),$(DESTDIR))
|
|
||||||
@$(call install_inc,$(LIBRTAS_HDR),$(DESTDIR))
|
|
||||||
- @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
|
|
||||||
+ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME)
|
|
||||||
|
|
||||||
uninstall:
|
|
||||||
@$(call uninstall_lib,$(LIBRTAS),$(DESTDIR))
|
|
55
librtas-1.3.6-ln.patch
Normal file
55
librtas-1.3.6-ln.patch
Normal file
@ -0,0 +1,55 @@
|
|||||||
|
diff -up librtas-1.3.6/libofdt_src/Makefile.ln librtas-1.3.6/libofdt_src/Makefile
|
||||||
|
--- librtas-1.3.6/libofdt_src/Makefile.ln 2011-02-07 11:53:34.000000000 -0500
|
||||||
|
+++ librtas-1.3.6/libofdt_src/Makefile 2011-08-11 06:45:39.948735397 -0400
|
||||||
|
@@ -26,12 +26,12 @@ all: $(LIBOFDT_OBJS) $(LIBOFDT_HDRS)
|
||||||
|
install:
|
||||||
|
@$(call install_lib,$(LIBOFDT),$(DESTDIR))
|
||||||
|
@$(call install_inc,$(LIBOFDT_SHIP_HDR),$(DESTDIR))
|
||||||
|
- @ln -sf $(LIBOFDT) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBOFDT))/$(LIBOFDT_SONAME)
|
||||||
|
+ @ln -sf $(LIBOFDT) $(DESTDIR)/$(LIB_DIR)/$(LIBOFDT_SONAME)
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
@$(call uninstall_lib,$(LIBOFDT),$(DESTDIR))
|
||||||
|
@$(call uninstall_inc,$(LIBOFDT_SHIP_HDR),$(DESTDIR))
|
||||||
|
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBOFDT))/$(LIBOFDT_SONAME)
|
||||||
|
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBOFDT_SONAME)
|
||||||
|
|
||||||
|
clean:
|
||||||
|
@echo "Cleaning up $(WORK_DIR) files..."
|
||||||
|
diff -up librtas-1.3.6/librtasevent_src/Makefile.ln librtas-1.3.6/librtasevent_src/Makefile
|
||||||
|
--- librtas-1.3.6/librtasevent_src/Makefile.ln 2011-02-07 11:53:34.000000000 -0500
|
||||||
|
+++ librtas-1.3.6/librtasevent_src/Makefile 2011-08-11 06:47:03.377757115 -0400
|
||||||
|
@@ -27,13 +27,12 @@ all: $(LIBRE_OBJS) $(HEADERS)
|
||||||
|
install:
|
||||||
|
@$(call install_lib,$(LIBRE),$(DESTDIR))
|
||||||
|
@$(call install_inc,$(LIBRE_HDRS),$(DESTDIR))
|
||||||
|
- @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME)
|
||||||
|
- @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME).1
|
||||||
|
+ @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME)
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
@$(call uninstall_lib,$(LIBRE),$(DESTDIR))
|
||||||
|
@$(call uninstall_inc,$(LIBRE_HDRS),$(DESTDIR))
|
||||||
|
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME)
|
||||||
|
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME)
|
||||||
|
|
||||||
|
clean:
|
||||||
|
@echo "Cleaning up $(WORK_DIR) files..."
|
||||||
|
diff -up librtas-1.3.6/librtas_src/Makefile.ln librtas-1.3.6/librtas_src/Makefile
|
||||||
|
--- librtas-1.3.6/librtas_src/Makefile.ln 2011-02-07 11:53:34.000000000 -0500
|
||||||
|
+++ librtas-1.3.6/librtas_src/Makefile 2011-08-11 06:45:39.950735397 -0400
|
||||||
|
@@ -32,12 +32,12 @@ librtas_static: $(LIBRTAS_OBJS) $(HEADER
|
||||||
|
install:
|
||||||
|
@$(call install_lib,$(LIBRTAS),$(DESTDIR))
|
||||||
|
@$(call install_inc,$(HEADERS),$(DESTDIR))
|
||||||
|
- @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
|
||||||
|
+ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME)
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
@$(call uninstall_lib,$(LIBRTAS),$(DESTDIR))
|
||||||
|
@$(call uninstall_inc,$(LIBRTAS_HDR),$(DESTDIR))
|
||||||
|
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
|
||||||
|
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME)
|
||||||
|
|
||||||
|
clean:
|
||||||
|
@echo "Cleaning up $(WORK_DIR) files..."
|
@ -1,6 +1,6 @@
|
|||||||
Summary: Libraries to provide access to RTAS calls and RTAS events
|
Summary: Libraries to provide access to RTAS calls and RTAS events
|
||||||
Name: librtas
|
Name: librtas
|
||||||
Version: 1.3.5
|
Version: 1.3.6
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://librtas.ozlabs.org
|
URL: http://librtas.ozlabs.org
|
||||||
License: CPL
|
License: CPL
|
||||||
@ -9,7 +9,7 @@ Group: System Environment/Libraries
|
|||||||
Source: http://librtas.ozlabs.org/releases/%{name}-%{version}.tar.gz
|
Source: http://librtas.ozlabs.org/releases/%{name}-%{version}.tar.gz
|
||||||
#Fedora specific patch
|
#Fedora specific patch
|
||||||
Patch0: %{name}-1.3.4-libdir.patch
|
Patch0: %{name}-1.3.4-libdir.patch
|
||||||
Patch1: %{name}-1.3.5-ln.patch
|
Patch1: %{name}-1.3.6-ln.patch
|
||||||
|
|
||||||
ExclusiveArch: ppc ppc64
|
ExclusiveArch: ppc ppc64
|
||||||
|
|
||||||
@ -67,10 +67,14 @@ mkdir -p %{buildroot}/%{_libdir}
|
|||||||
%{_includedir}/librtasevent.h
|
%{_includedir}/librtasevent.h
|
||||||
%{_includedir}/librtasevent_v4.h
|
%{_includedir}/librtasevent_v4.h
|
||||||
%{_includedir}/librtasevent_v6.h
|
%{_includedir}/librtasevent_v6.h
|
||||||
|
%{_includedir}/common.h
|
||||||
%{_includedir}/libofdt.h
|
%{_includedir}/libofdt.h
|
||||||
%{_libdir}/libofdt.so
|
%{_libdir}/libofdt.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 11 2011 Jiri Skala <jskala@redhat.com> 1.3.6-1
|
||||||
|
- update to latest upstream 1.3.6
|
||||||
|
|
||||||
* Mon Aug 08 2011 Jiri Skala <jskala@redhat.com> 1.3.5-1
|
* Mon Aug 08 2011 Jiri Skala <jskala@redhat.com> 1.3.5-1
|
||||||
- update to latest upstream 1.3.5
|
- update to latest upstream 1.3.5
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user