update to latest upstream 1.3.5
This commit is contained in:
parent
fbf3e5510d
commit
cba7b337b0
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
librtas-1.3.4.tar.gz
|
||||
/librtas-1.3.5.tar.gz
|
||||
|
@ -1,12 +1,21 @@
|
||||
diff -up librtas-1.3.4/rules.mk.libdir librtas-1.3.4/rules.mk
|
||||
--- librtas-1.3.4/rules.mk.libdir 2009-09-21 16:41:57.000000000 +0200
|
||||
+++ librtas-1.3.4/rules.mk 2009-09-21 16:42:01.000000000 +0200
|
||||
@@ -135,7 +135,7 @@ define install_sbin
|
||||
diff -up librtas-1.3.5/rules.mk.libdir librtas-1.3.5/rules.mk
|
||||
--- librtas-1.3.5/rules.mk.libdir 2010-01-28 20:04:30.000000000 +0100
|
||||
+++ librtas-1.3.5/rules.mk 2011-08-09 15:47:16.842521606 +0200
|
||||
@@ -145,7 +145,7 @@ define install_sbin
|
||||
endef
|
||||
|
||||
define install_lib
|
||||
- $(call install_files,$1,755,$2/$(LIB_DIR)$(findstring 64,$(shell file $(firstword $1))))
|
||||
- $(call install_files,$1,755,$2/$(LIB_DIR)$(call is_lib64,$1))
|
||||
+ $(call install_files,$1,755,$2/$(LIB_DIR))
|
||||
endef
|
||||
|
||||
define install_inc
|
||||
@@ -188,7 +188,7 @@ define uninstall_sbin
|
||||
endef
|
||||
|
||||
define uninstall_lib
|
||||
- $(call uninstall_files,$1,$2/$(LIB_DIR)$(call is_lib64,$1))
|
||||
+ $(call uninstall_files,$1,$2/$(LIB_DIR))
|
||||
endef
|
||||
|
||||
define uninstall_inc
|
||||
|
36
librtas-1.3.5-ln.patch
Normal file
36
librtas-1.3.5-ln.patch
Normal file
@ -0,0 +1,36 @@
|
||||
diff -up librtas-1.3.5/libofdt_src/Makefile.ln librtas-1.3.5/libofdt_src/Makefile
|
||||
--- librtas-1.3.5/libofdt_src/Makefile.ln 2011-08-09 16:02:40.228882952 +0200
|
||||
+++ librtas-1.3.5/libofdt_src/Makefile 2011-08-09 16:02:58.788149712 +0200
|
||||
@@ -26,7 +26,7 @@ all: $(LIBOFDT_OBJS) $(LIBOFDT_HDRS)
|
||||
install:
|
||||
@$(call install_lib,$(LIBOFDT),$(DESTDIR))
|
||||
@$(call install_inc,$(LIBOFDT_SHIP_HDR),$(DESTDIR))
|
||||
- @ln -sf $(LIBOFDT) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBOFDT))/$(LIBOFDT_SONAME)
|
||||
+ @ln -sf $(LIBOFDT) $(DESTDIR)/$(LIB_DIR)/$(LIBOFDT_SONAME)
|
||||
|
||||
uninstall:
|
||||
@$(call uninstall_lib,$(LIBOFDT),$(DESTDIR))
|
||||
diff -up librtas-1.3.5/librtasevent_src/Makefile.ln librtas-1.3.5/librtasevent_src/Makefile
|
||||
--- librtas-1.3.5/librtasevent_src/Makefile.ln 2011-08-09 16:03:18.310430003 +0200
|
||||
+++ librtas-1.3.5/librtasevent_src/Makefile 2011-08-09 16:03:34.484661982 +0200
|
||||
@@ -27,7 +27,7 @@ all: $(LIBRE_OBJS) $(HEADERS)
|
||||
install:
|
||||
@$(call install_lib,$(LIBRE),$(DESTDIR))
|
||||
@$(call install_inc,$(LIBRE_HDRS),$(DESTDIR))
|
||||
- @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME)
|
||||
+ @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME)
|
||||
|
||||
uninstall:
|
||||
@$(call uninstall_lib,$(LIBRE),$(DESTDIR))
|
||||
diff -up librtas-1.3.5/librtas_src/Makefile.ln librtas-1.3.5/librtas_src/Makefile
|
||||
--- librtas-1.3.5/librtas_src/Makefile.ln 2011-08-09 16:01:54.008217333 +0200
|
||||
+++ librtas-1.3.5/librtas_src/Makefile 2011-08-09 16:02:22.242624149 +0200
|
||||
@@ -32,7 +32,7 @@ librtas_static: $(LIBRTAS_OBJS) $(HEADER
|
||||
install:
|
||||
@$(call install_lib,$(LIBRTAS),$(DESTDIR))
|
||||
@$(call install_inc,$(LIBRTAS_HDR),$(DESTDIR))
|
||||
- @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
|
||||
+ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME)
|
||||
|
||||
uninstall:
|
||||
@$(call uninstall_lib,$(LIBRTAS),$(DESTDIR))
|
10
librtas.spec
10
librtas.spec
@ -1,7 +1,7 @@
|
||||
Summary: Libraries to provide access to RTAS calls and RTAS events
|
||||
Name: librtas
|
||||
Version: 1.3.4
|
||||
Release: 3%{?dist}
|
||||
Version: 1.3.5
|
||||
Release: 1%{?dist}
|
||||
URL: http://librtas.ozlabs.org
|
||||
License: CPL
|
||||
Group: System Environment/Libraries
|
||||
@ -9,6 +9,7 @@ Group: System Environment/Libraries
|
||||
Source: http://librtas.ozlabs.org/releases/%{name}-%{version}.tar.gz
|
||||
#Fedora specific patch
|
||||
Patch0: %{name}-1.3.4-libdir.patch
|
||||
Patch1: %{name}-1.3.5-ln.patch
|
||||
|
||||
ExclusiveArch: ppc ppc64
|
||||
|
||||
@ -34,6 +35,7 @@ developing programs using librtas.
|
||||
%prep
|
||||
%setup
|
||||
%patch0 -p1 -b .libdir
|
||||
%patch1 -p1 -b .ln
|
||||
|
||||
%build
|
||||
%{__make} CFLAGS="%{optflags} -fPIC -DPIC -I." %{?_smp_mflags}
|
||||
@ -65,11 +67,13 @@ mkdir -p %{buildroot}/%{_libdir}
|
||||
%{_includedir}/librtasevent.h
|
||||
%{_includedir}/librtasevent_v4.h
|
||||
%{_includedir}/librtasevent_v6.h
|
||||
%{_includedir}/common.h
|
||||
%{_includedir}/libofdt.h
|
||||
%{_libdir}/libofdt.so
|
||||
|
||||
%changelog
|
||||
* Mon Aug 08 2011 Jiri Skala <jskala@redhat.com> 1.3.5-1
|
||||
- update to latest upstream 1.3.5
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user