Update to 2.43.1

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2018-06-24 13:35:29 +02:00
parent 8da4f790bb
commit 9a636ae039
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C
5 changed files with 39 additions and 70 deletions

1
.gitignore vendored
View File

@ -36,3 +36,4 @@ librsvg-2.31.0.tar.bz2
/librsvg-2.42.2.tar.xz
/librsvg-2.42.3.tar.xz
/librsvg-2.42.4.tar.xz
/librsvg-2.43.1.tar.xz

View File

@ -0,0 +1,25 @@
From 60f8afdfe6c5b667c015b2124cd46fd1d5bb07ee Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sun, 24 Jun 2018 11:31:13 +0000
Subject: [PATCH] deps: bump regex to 1
---
rsvg_internals/Cargo.toml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/rsvg_internals/Cargo.toml b/rsvg_internals/Cargo.toml
index 1fc5c443..76c25402 100644
--- a/rsvg_internals/Cargo.toml
+++ b/rsvg_internals/Cargo.toml
@@ -22,7 +22,7 @@ phf_codegen = "0.7.21"
[dependencies]
libc = "0.2"
downcast-rs = "^1.0.0"
-regex = "^0.2.1"
+regex = "1"
itertools = "0.7.4"
pango = "0.4"
pangocairo = "0.5"
--
2.18.0.rc2

View File

@ -1,61 +0,0 @@
From 3a1325cc73ee4abb64ce254098fb9a1d8f486ce0 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <ignatenko@src.gnome.org>
Date: Tue, 8 May 2018 16:10:26 +0200
Subject: [PATCH] deps: update gtk-rs stack
Signed-off-by: Igor Gnatenko <ignatenko@src.gnome.org>
---
rsvg_internals/Cargo.toml | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/rsvg_internals/Cargo.toml b/rsvg_internals/Cargo.toml
index 92c7704f..92e16a95 100644
--- a/rsvg_internals/Cargo.toml
+++ b/rsvg_internals/Cargo.toml
@@ -24,16 +24,16 @@ libc = "0.2"
downcast-rs = "^1.0.0"
regex = "^0.2.1"
itertools = "0.7.4"
-pango = "0.3.0"
-pangocairo = "0.4.1"
-pango-sys = "0.5.0"
+pango = "0.4"
+pangocairo = "0.5"
+pango-sys = "0.6"
cssparser = "0.23"
lazy_static = "1.0.0"
phf = "0.7.21"
float-cmp = "0.4.0"
[dependencies.cairo-sys-rs]
-version = "0.5.0"
+version = "0.6"
#git = "https://github.com/gtk-rs/cairo.git"
#branch = "master"
#git = "https://github.com/federicomenaquintero/cairo.git"
@@ -42,19 +42,19 @@ version = "0.5.0"
#features = ["png"]
[dependencies.cairo-rs]
-version = "0.3.0"
+version = "0.4"
#git = "https://github.com/gtk-rs/cairo.git"
#branch = "master"
#git = "file:///home/federico/src/gtk-rs/cairo"
#features = ["png"]
[dependencies.glib]
-version = "0.4.0"
+version = "0.5"
#git = "https://github.com/gtk-rs/glib.git"
#branch = "master"
[dependencies.glib-sys]
-version = "0.5.0"
+version = "0.6"
#git = "https://github.com/gtk-rs/sys"
#branch = "master"
--
2.17.0

View File

@ -6,14 +6,14 @@
Name: librsvg2
Summary: An SVG library based on cairo
Version: 2.42.4
Version: 2.43.1
Release: 1%{?dist}
License: LGPLv2+
URL: https://wiki.gnome.org/Projects/LibRsvg
Source: http://download.gnome.org/sources/librsvg/2.42/librsvg-%{version}.tar.xz
# https://gitlab.gnome.org/GNOME/librsvg/merge_requests/60
Patch0: 0001-deps-update-gtk-rs-stack.patch
Source: http://download.gnome.org/sources/librsvg/2.43/librsvg-%{version}.tar.xz
# https://gitlab.gnome.org/GNOME/librsvg/commit/60f8afdfe6c5b667c015b2124cd46fd1d5bb07ee
Patch0001: 0001-deps-bump-regex-to-1.patch
BuildRequires: gcc
BuildRequires: pkgconfig(gdk-pixbuf-2.0) >= 2.20
@ -47,8 +47,9 @@ BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
BuildRequires: (crate(pango) >= 0.4.0 with crate(pango) < 0.5.0)
BuildRequires: (crate(pango-sys) >= 0.6.0 with crate(pango-sys) < 0.7.0)
BuildRequires: (crate(pangocairo) >= 0.5.0 with crate(pangocairo) < 0.6.0)
BuildRequires: (crate(pangocairo-sys) >= 0.7.0 with crate(pangocairo-sys) < 0.8.0)
BuildRequires: (crate(phf) >= 0.7.21 with crate(phf) < 0.8.0)
BuildRequires: (crate(regex) >= 0.2.1 with crate(regex) < 0.3.0)
BuildRequires: (crate(regex) >= 1.0.0 with crate(regex) < 2.0.0)
# [build-dependencies]
BuildRequires: (crate(phf_codegen) >= 0.7.21 with crate(phf_codegen) < 0.8.0)
@ -81,9 +82,9 @@ rm -vrf vendor
%build
%configure --disable-static \
--disable-gtk-doc \
--enable-introspection \
--enable-vala
--disable-gtk-doc \
--enable-introspection \
--enable-vala
%make_build
%install
@ -129,6 +130,9 @@ rm -vrf %{buildroot}%{_datadir}/doc
%{_mandir}/man1/rsvg-convert.1*
%changelog
* Sun Jun 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.43.1-1
- Update to 2.43.1
* Tue May 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.42.4-1
- Update to 2.42.4

View File

@ -1 +1 @@
SHA512 (librsvg-2.42.4.tar.xz) = d2fe14e7ae4b22774d6bbc4af630e9ae07742e45b5d17e8e6d4f0d3de94086d4108a15cfb8769eead8161bd024617d57c29bf5353cede252d2ed41d7a0f76744
SHA512 (librsvg-2.43.1.tar.xz) = b9f3e49b001903951d8a7600d92432f3c6684426019a11bfb7d93575d6dbbb87ee499d2500d530068ddd55b08fd33ce122ac14eb725378439e16e7ad7499405f