RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/librepository#1241fc1f678b1af3174a0ed48f8fd28362519d1c
This commit is contained in:
parent
b0be3a5931
commit
ee172e30e4
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
||||
/librepository-1.1.3-jarsdeleted.zip
|
40
librepository-1.1.2.build.patch
Normal file
40
librepository-1.1.2.build.patch
Normal file
@ -0,0 +1,40 @@
|
||||
--- librepository-1.1.3/build.properties 2009-11-17 16:41:36.000000000 +0000
|
||||
+++ librepository-1.1.3/build.properties 2009-11-17 16:41:56.000000000 +0000
|
||||
@@ -1,7 +1,9 @@
|
||||
-project.revision=TRUNK-SNAPSHOT
|
||||
+project.revision=1.1.3
|
||||
ivy.artifact.group=pentaho-library
|
||||
ivy.artifact.id=librepository
|
||||
impl.title=LibRepository
|
||||
impl.productID=librepository
|
||||
src.dir=${basedir}/source
|
||||
dependency.libbase.revision=1.1.3
|
||||
+antcontrib.available=true
|
||||
+build.cache.dir=lib
|
||||
--- librepository-1.1.3/common_build.xml 2009-11-17 20:34:29.000000000 +0000
|
||||
+++ librepository-1.1.3/common_build.xml 2009-11-17 20:36:51.000000000 +0000
|
||||
@@ -1071,6 +1071,7 @@
|
||||
<path refid="classpath" />
|
||||
</classpath>
|
||||
<src path="${src.dir}" />
|
||||
+ <exclude name="org/pentaho/reporting/libraries/repository/email/**"/>
|
||||
</javac>
|
||||
</target>
|
||||
|
||||
@@ -1356,6 +1357,9 @@
|
||||
doctitle="${impl.title} documentation">
|
||||
<link href="http://java.sun.com/j2se/${javac.source}.0/docs/api/" />
|
||||
<classpath refid="classpath" />
|
||||
+ <packageset dir="source">
|
||||
+ <exclude name="org/pentaho/reporting/libraries/repository/email/**"/>
|
||||
+ </packageset>
|
||||
</javadoc>
|
||||
</target>
|
||||
|
||||
@@ -1648,4 +1652,4 @@
|
||||
</dot-classpath>
|
||||
</target>
|
||||
|
||||
-</project>
|
||||
\ No hay ningún carácter de nueva línea al final del fichero
|
||||
+</project>
|
79
librepository-1.1.2.java11.patch
Normal file
79
librepository-1.1.2.java11.patch
Normal file
@ -0,0 +1,79 @@
|
||||
--- librepository-1.1.3/common_build.xml 2020-05-05 20:00:37.191243154 +0100
|
||||
+++ librepository-1.1.3/common_build.xml 2020-05-05 20:00:44.344299905 +0100
|
||||
@@ -136,8 +136,8 @@
|
||||
<property name="javac.deprecation"
|
||||
value="true"
|
||||
description="Indicates whether source should be compiled with deprecation information" />
|
||||
- <property name="javac.source" value="1.5" description="Provide source compatibility with specified release" />
|
||||
- <property name="javac.target" value="1.5" description="Generate class files for specific VM version" />
|
||||
+ <property name="javac.source" value="1.6" description="Provide source compatibility with specified release" />
|
||||
+ <property name="javac.target" value="1.6" description="Generate class files for specific VM version" />
|
||||
|
||||
<!-- Build Cache properties -->
|
||||
<property name="build.cache.dir"
|
||||
@@ -1353,13 +1353,11 @@
|
||||
nodeprecatedlist="false"
|
||||
nodeprecated="false"
|
||||
packagenames="${javadoc.packagenames}"
|
||||
+ excludepackagenames="org.pentaho.reporting.libraries.repository.email.*"
|
||||
sourcepath="${src.dir}"
|
||||
doctitle="${impl.title} documentation">
|
||||
<link href="http://java.sun.com/j2se/${javac.source}.0/docs/api/" />
|
||||
<classpath refid="classpath" />
|
||||
- <packageset dir="source">
|
||||
- <exclude name="org/pentaho/reporting/libraries/repository/email/**"/>
|
||||
- </packageset>
|
||||
</javadoc>
|
||||
</target>
|
||||
|
||||
--- librepository-1.1.3/source/org/pentaho/reporting/libraries/repository/ContentItem.java 2020-06-10 14:13:04.904250346 +0100
|
||||
+++ librepository-1.1.3/source/org/pentaho/reporting/libraries/repository/ContentItem.java 2020-06-10 14:12:10.686769515 +0100
|
||||
@@ -43,7 +43,7 @@
|
||||
* Tries to open and return a output stream for writing into the content item. This call will fail if the
|
||||
* item is not writeable. Whether opening multiple output streams at the same time is possible is implementation
|
||||
* dependent, but it is generally not recommended to try this.
|
||||
- * <p/>
|
||||
+ * <p>
|
||||
* Having both an input and output stream open at the same time is not guaranteed to work. Generally if you need
|
||||
* to append data, first open the inputstream and copy the content to a temporary location and then write the
|
||||
* content along with the appended content to the new output stream.
|
||||
@@ -58,7 +58,7 @@
|
||||
* Tries to open and return a input stream for reading from the content item. This call will fail if the
|
||||
* item is not readable. Whether opening multiple input streams at the same time is possible is implementation
|
||||
* dependent.
|
||||
- * <p/>
|
||||
+ * <p>
|
||||
* Having both an input and output stream open at the same time is not guaranteed to work. Generally if you need
|
||||
* to append data, first open the inputstream and copy the content to a temporary location and then write the
|
||||
* content along with the appended content to the new output stream.
|
||||
--- librepository-1.1.3/source/org/pentaho/reporting/libraries/repository/LibRepositoryBoot.java 2020-06-10 14:13:14.599336328 +0100
|
||||
+++ librepository-1.1.3/source/org/pentaho/reporting/libraries/repository/LibRepositoryBoot.java 2020-06-10 14:12:10.690769550 +0100
|
||||
@@ -27,7 +27,7 @@
|
||||
/**
|
||||
* The LibRepositoryBoot class is used to initialize the library before it is
|
||||
* first used. This loads all configurations and initializes all factories.
|
||||
- * <p/>
|
||||
+ * <p>
|
||||
* Without booting, basic services like logging and the global configuration
|
||||
* will not be availble.
|
||||
*
|
||||
--- librepository-1.1.3/source/org/pentaho/reporting/libraries/repository/stream/StreamContentItem.java 2020-06-10 14:13:28.417458875 +0100
|
||||
+++ librepository-1.1.3/source/org/pentaho/reporting/libraries/repository/stream/StreamContentItem.java 2020-06-10 14:12:10.693769577 +0100
|
||||
@@ -114,7 +114,7 @@
|
||||
* Tries to open and return a output stream for writing into the content item. This call will fail if the
|
||||
* item is not writeable. Whether opening multiple output streams at the same time is possible is implementation
|
||||
* dependent, but it is generally not recommended to try this.
|
||||
- * <p/>
|
||||
+ * <p>
|
||||
* Having both an input and output stream open at the same time is not guaranteed to work. Generally if you need
|
||||
* to append data, first open the inputstream and copy the content to a temporary location and then write the
|
||||
* content along with the appended content to the new output stream.
|
||||
@@ -132,7 +132,7 @@
|
||||
* Tries to open and return a input stream for reading from the content item. This call will fail if the
|
||||
* item is not readable. Whether opening multiple input streams at the same time is possible is implementation
|
||||
* dependent.
|
||||
- * <p/>
|
||||
+ * <p>
|
||||
* Having both an input and output stream open at the same time is not guaranteed to work. Generally if you need
|
||||
* to append data, first open the inputstream and copy the content to a temporary location and then write the
|
||||
* content along with the appended content to the new output stream.
|
160
librepository.spec
Normal file
160
librepository.spec
Normal file
@ -0,0 +1,160 @@
|
||||
Name: librepository
|
||||
Version: 1.1.3
|
||||
Release: 27%{?dist}
|
||||
Summary: Hierarchical repository abstraction layer
|
||||
License: LGPLv2
|
||||
#Original source: http://downloads.sourceforge.net/jfreereport/%%name}-%%{version}.zip
|
||||
#unzip, find . -name "*.jar" -exec rm {} \;
|
||||
#to simplify the licensing
|
||||
Source: %{name}-%{version}-jarsdeleted.zip
|
||||
URL: http://reporting.pentaho.org/
|
||||
BuildRequires: ant, ant-contrib, java-devel, jpackage-utils, libbase >= 1.1.3
|
||||
Requires: java-headless, jpackage-utils, libbase >= 1.1.3
|
||||
BuildArch: noarch
|
||||
Patch0: librepository-1.1.2.build.patch
|
||||
Patch1: librepository-1.1.2.java11.patch
|
||||
|
||||
%description
|
||||
LibRepository provides a simple abstraction layer to access bulk content that
|
||||
is organized in a hierarchical layer.
|
||||
|
||||
%package javadoc
|
||||
Summary: Javadoc for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: jpackage-utils
|
||||
|
||||
%description javadoc
|
||||
Javadoc for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -c
|
||||
%patch0 -p1 -b .build
|
||||
%patch1 -p1 -b .java11
|
||||
find . -name "*.jar" -exec rm -f {} \;
|
||||
mkdir -p lib
|
||||
build-jar-repository -s -p lib commons-logging-api libbase
|
||||
cd lib
|
||||
ln -s /usr/share/java/ant ant-contrib
|
||||
|
||||
%build
|
||||
ant jar javadoc
|
||||
for file in README.txt licence-LGPL.txt ChangeLog.txt; do
|
||||
tr -d '\r' < $file > $file.new
|
||||
mv $file.new $file
|
||||
done
|
||||
|
||||
%install
|
||||
mkdir -p $RPM_BUILD_ROOT%{_javadir}
|
||||
cp -p ./dist/%{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||
cp -rp bin/javadoc/docs/api $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||
|
||||
%files
|
||||
%doc licence-LGPL.txt README.txt ChangeLog.txt
|
||||
%{_javadir}/%{name}.jar
|
||||
|
||||
%files javadoc
|
||||
%{_javadocdir}/%{name}
|
||||
|
||||
%changelog
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-27
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Fri Jul 17 2020 Caolán McNamara <caolanm@redhat.com> - 1.1.3-26
|
||||
- Resolves: rhbz#1858037 disable failing javadoc parts
|
||||
|
||||
* Sat Jul 11 2020 Jiri Vanek <jvanek@redhat.com> - 1.1.3-25
|
||||
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||
|
||||
* Wed Jun 10 2020 Caolán McNamara <caolanm@redhat.com> - 1.1.3-24
|
||||
- allow rebuild with java 11
|
||||
|
||||
* Tue May 05 2020 Caolán McNamara <caolanm@redhat.com> - 1.1.3-23
|
||||
- allow rebuild with java 11
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-22
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Apr 05 2019 Stephan Bergmann <sbergman@redhat.com> - 1.1.3-20
|
||||
- Use /usr/share/java instead of _javadir macro for build dependencies
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Tue Feb 25 2014 Caolán McNamara <caolanm@redhat.com> - 1.1.3-11
|
||||
- Resolves: rhbz#1068365 Switch to java-headless (build)requires
|
||||
|
||||
* Wed Oct 23 2013 Caolán McNamara <caolanm@redhat.com> - 1.1.3-10
|
||||
- Resolves: rhbz#1022137 remove versioned jars
|
||||
|
||||
* Tue Aug 06 2013 Parag Nemade <paragn AT fedoraproject DOT org> - 1.1.3-9
|
||||
- Fix bogus date in %%changelog
|
||||
- ant-nodeps is dropped from ant-1.9.0-2 build in rawhide
|
||||
- Drop buildroot, %%clean, %%defattr and removal of buildroot in %%install
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sat Nov 03 2012 Caolán McNamara <caolanm@redhat.com> - 1.1.3-6
|
||||
- repack source to remove bundled multi-license .jars
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri Oct 28 2011 Caolán McNamara <caolanm@redhat.com> - 1.1.3-3
|
||||
- Related: rhbz#749103 drop gcj aot
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Dec 02 2009 Caolan McNamara <caolanm@redhat.com> 1.1.3-1
|
||||
- latest version
|
||||
|
||||
* Tue Nov 17 2009 Caolan McNamara <caolanm@redhat.com> 1.1.2-1
|
||||
- latest version
|
||||
|
||||
* Fri Jul 24 2009 Caolan McNamara <caolanm@redhat.com> 1.0.0-2.OOo31
|
||||
- make javadoc no-arch when building as arch-dependant aot
|
||||
|
||||
* Mon Mar 16 2009 Caolan McNamara <caolanm@redhat.com> 1.0.0-1.OOo31
|
||||
- Post-release tuned for OpenOffice.org
|
||||
|
||||
* Mon Mar 09 2009 Caolan McNamara <caolanm@redhat.com> 0.2.0-1
|
||||
- latest version
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Wed May 07 2008 Caolan McNamara <caolanm@redhat.com> 0.1.6-1
|
||||
- initial fedora import
|
Loading…
Reference in New Issue
Block a user