+ * Having both an input and output stream open at the same time is not guaranteed to work. Generally if you need + * to append data, first open the inputstream and copy the content to a temporary location and then write the + * content along with the appended content to the new output stream. +@@ -58,7 +58,7 @@ + * Tries to open and return a input stream for reading from the content item. This call will fail if the + * item is not readable. Whether opening multiple input streams at the same time is possible is implementation + * dependent. +- *
++ *+ * Having both an input and output stream open at the same time is not guaranteed to work. Generally if you need + * to append data, first open the inputstream and copy the content to a temporary location and then write the + * content along with the appended content to the new output stream. +--- librepository-1.1.3/source/org/pentaho/reporting/libraries/repository/LibRepositoryBoot.java 2020-06-10 14:13:14.599336328 +0100 ++++ librepository-1.1.3/source/org/pentaho/reporting/libraries/repository/LibRepositoryBoot.java 2020-06-10 14:12:10.690769550 +0100 +@@ -27,7 +27,7 @@ + /** + * The LibRepositoryBoot class is used to initialize the library before it is + * first used. This loads all configurations and initializes all factories. +- *
++ *+ * Without booting, basic services like logging and the global configuration + * will not be availble. + * +--- librepository-1.1.3/source/org/pentaho/reporting/libraries/repository/stream/StreamContentItem.java 2020-06-10 14:13:28.417458875 +0100 ++++ librepository-1.1.3/source/org/pentaho/reporting/libraries/repository/stream/StreamContentItem.java 2020-06-10 14:12:10.693769577 +0100 +@@ -114,7 +114,7 @@ + * Tries to open and return a output stream for writing into the content item. This call will fail if the + * item is not writeable. Whether opening multiple output streams at the same time is possible is implementation + * dependent, but it is generally not recommended to try this. +- *
++ *+ * Having both an input and output stream open at the same time is not guaranteed to work. Generally if you need + * to append data, first open the inputstream and copy the content to a temporary location and then write the + * content along with the appended content to the new output stream. +@@ -132,7 +132,7 @@ + * Tries to open and return a input stream for reading from the content item. This call will fail if the + * item is not readable. Whether opening multiple input streams at the same time is possible is implementation + * dependent. +- *
++ *
+ * Having both an input and output stream open at the same time is not guaranteed to work. Generally if you need
+ * to append data, first open the inputstream and copy the content to a temporary location and then write the
+ * content along with the appended content to the new output stream.
diff --git a/librepository.spec b/librepository.spec
new file mode 100644
index 0000000..d9309fb
--- /dev/null
+++ b/librepository.spec
@@ -0,0 +1,160 @@
+Name: librepository
+Version: 1.1.3
+Release: 27%{?dist}
+Summary: Hierarchical repository abstraction layer
+License: LGPLv2
+#Original source: http://downloads.sourceforge.net/jfreereport/%%name}-%%{version}.zip
+#unzip, find . -name "*.jar" -exec rm {} \;
+#to simplify the licensing
+Source: %{name}-%{version}-jarsdeleted.zip
+URL: http://reporting.pentaho.org/
+BuildRequires: ant, ant-contrib, java-devel, jpackage-utils, libbase >= 1.1.3
+Requires: java-headless, jpackage-utils, libbase >= 1.1.3
+BuildArch: noarch
+Patch0: librepository-1.1.2.build.patch
+Patch1: librepository-1.1.2.java11.patch
+
+%description
+LibRepository provides a simple abstraction layer to access bulk content that
+is organized in a hierarchical layer.
+
+%package javadoc
+Summary: Javadoc for %{name}
+Requires: %{name} = %{version}-%{release}
+Requires: jpackage-utils
+
+%description javadoc
+Javadoc for %{name}.
+
+%prep
+%setup -q -c
+%patch0 -p1 -b .build
+%patch1 -p1 -b .java11
+find . -name "*.jar" -exec rm -f {} \;
+mkdir -p lib
+build-jar-repository -s -p lib commons-logging-api libbase
+cd lib
+ln -s /usr/share/java/ant ant-contrib
+
+%build
+ant jar javadoc
+for file in README.txt licence-LGPL.txt ChangeLog.txt; do
+ tr -d '\r' < $file > $file.new
+ mv $file.new $file
+done
+
+%install
+mkdir -p $RPM_BUILD_ROOT%{_javadir}
+cp -p ./dist/%{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
+
+mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}
+cp -rp bin/javadoc/docs/api $RPM_BUILD_ROOT%{_javadocdir}/%{name}
+
+%files
+%doc licence-LGPL.txt README.txt ChangeLog.txt
+%{_javadir}/%{name}.jar
+
+%files javadoc
+%{_javadocdir}/%{name}
+
+%changelog
+* Tue Jul 28 2020 Fedora Release Engineering