New upstream release 2.1.12

This commit is contained in:
Jakub Filak 2014-01-30 13:49:57 +01:00
parent 0ecc49267d
commit f98d93a4ce
4 changed files with 41 additions and 80 deletions

View File

@ -1,26 +0,0 @@
diff -ruN libreport-2.1.11/configure libreport-2.1.11.fix/configure
--- libreport-2.1.11/configure 2014-01-08 18:46:48.057001105 +0100
+++ libreport-2.1.11.fix/configure 2014-01-08 18:46:33.880000782 +0100
@@ -17814,7 +17814,8 @@
AUTOM4TE=${AUTOM4TE-"${am_missing_run}autom4te"}
# Needed by tests/atlocal.in.
-O0CFLAGS=`echo $CFLAGS | sed 's/-O[0-9] *//' | sed 's/-Werror//'`
+# CFLAGS may contain '-Werror=format-security'
+O0CFLAGS=`echo $CFLAGS | sed 's/-O[[0-9]] *//' | sed 's/-Werror\(=[^ ]*\)\?//g'`
ac_config_headers="$ac_config_headers config.h"
diff -ruN libreport-2.1.11/configure.ac libreport-2.1.11.fix/configure.ac
--- libreport-2.1.11/configure.ac 2013-12-10 10:16:15.000000000 +0100
+++ libreport-2.1.11.fix/configure.ac 2014-01-08 18:46:33.857000781 +0100
@@ -307,7 +307,8 @@
AC_CONFIG_FILES([tests/Makefile tests/atlocal])
AM_MISSING_PROG([AUTOM4TE], [autom4te])
# Needed by tests/atlocal.in.
-AC_SUBST([O0CFLAGS], [`echo $CFLAGS | sed 's/-O[[0-9]] *//' | sed 's/-Werror//'`])
+# CFLAGS may contain '-Werror=format-security'
+AC_SUBST([O0CFLAGS], [`echo $CFLAGS | sed 's/-O[[0-9]] *//' | sed 's/-Werror\(=[[^ ]]*\)\?//g'`])
AC_CONFIG_HEADERS([config.h])

View File

@ -1,29 +0,0 @@
From c193f2d12a6abed6b7e30ba2431e52913dddc26d Mon Sep 17 00:00:00 2001
From: Jakub Filak <jfilak@redhat.com>
Date: Wed, 8 Jan 2014 09:38:30 +0100
Subject: [LIBREPORT PATCH] wizard: do not use deprecated gtk3 API
Signed-off-by: Jakub Filak <jfilak@redhat.com>
---
src/gui-wizard-gtk/wizard.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/src/gui-wizard-gtk/wizard.c b/src/gui-wizard-gtk/wizard.c
index c37f69f..3faa8e8 100644
--- a/src/gui-wizard-gtk/wizard.c
+++ b/src/gui-wizard-gtk/wizard.c
@@ -2597,7 +2597,11 @@ static void add_workflow_buttons(GtkBox *box, GHashTable *workflows, GCallback f
gtk_label_set_use_markup(GTK_LABEL(label), true);
gtk_widget_set_halign(label, GTK_ALIGN_START);
gtk_widget_set_margin_top(label, 10);
+#if ((GTK_MAJOR_VERSION == 3 && GTK_MINOR_VERSION < 11) || (GTK_MAJOR_VERSION == 3 && GTK_MINOR_VERSION == 11 && GTK_MICRO_VERSION < 2))
gtk_widget_set_margin_left(label, 40);
+#else
+ gtk_widget_set_margin_start(label, 40);
+#endif
gtk_widget_set_margin_bottom(label, 10);
free(btn_label);
g_signal_connect(button, "clicked", func, w);
--
1.8.3.1

View File

@ -6,18 +6,14 @@
Summary: Generic library for reporting various problems
Name: libreport
Version: 2.1.11
Release: 3%{?dist}
Version: 2.1.12
Release: 1%{?dist}
License: GPLv2+
Group: System Environment/Libraries
URL: https://fedorahosted.org/abrt/
Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
Source1: autogen.sh
# Remove with libreport > 2.1.11
Patch1: libreport-2.1.11-get_rid_of_gtk3_deprecated_functions.patch
Patch2: libreport-2.1.11-fix_0CFLAGS_in_configure.patch
BuildRequires: dbus-devel
BuildRequires: gtk3-devel
BuildRequires: curl-devel
@ -48,14 +44,6 @@ Requires: libreport-filesystem = %{version}-%{release}
Requires: libreport-python = %{version}-%{release}
Requires: satyr >= %{satyr_ver}
# for rhel6
%if 0%{?rhel} == 6
BuildRequires: gnome-keyring-devel
%else
BuildRequires: libgnome-keyring-devel
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%description
@ -103,7 +91,7 @@ Obsoletes: report < 0:0.23-1
# in report the rhtsupport is in the main package, so we need to install it too
# report is only in RHEL6, we do not need to carry the dependency to newer RHELs
%if 0%{?rhel} == 6
Requires: libreport-plugin-rhtsupport
Requires: libreport-plugin-rhtsupport = %{version}-%{release}
%endif
%description python
@ -188,6 +176,9 @@ Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
Requires: libreport-web = %{version}-%{release}
%description plugin-bugzilla
Plugin to report bugs into the bugzilla.
%package plugin-ureport
Summary: %{name}'s micro report plugin
BuildRequires: json-c-devel
@ -198,9 +189,6 @@ Requires: libreport-web = %{version}-%{release}
%description plugin-ureport
Uploads micro-report to abrt server
%description plugin-bugzilla
Plugin to report bugs into the bugzilla.
%package plugin-rhtsupport
Summary: %{name}'s RHTSupport plugin
Group: System Environment/Libraries
@ -293,8 +281,6 @@ data over ftp/scp...
%prep
%setup -q
%patch1 -p1
%patch2 -p1
# koji in f19 has new autotools, so we need to regenerate everything
cp %SOURCE1 %_builddir/%{name}-%{version}
@ -302,7 +288,7 @@ cp %SOURCE1 %_builddir/%{name}-%{version}
%build
# Commented because of deprecated GTK API
#CFLAGS="%{optflags} -Werror" %configure --disable-silent-rules
#CFLAGS="%%{optflags} -Werror" %%configure --disable-silent-rules
CFLAGS="%{optflags}" %configure --enable-doxygen-docs --disable-silent-rules
make %{?_smp_mflags}
@ -329,6 +315,8 @@ rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_FedoraKerneloops.
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_FedoraPython.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_FedoraVmcore.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_FedoraXorg.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_FedoraLibreport.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_FedoraJava.xml
rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/libreport/workflows.d/report_fedora.conf
rm -f $RPM_BUILD_ROOT%{_mandir}/man5/report_fedora.conf.5
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
@ -341,6 +329,8 @@ rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELKerneloops.xm
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELPython.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELvmcore.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELxorg.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELLibreport.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELJava.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_AnacondaRHEL.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELBugzillaCCpp.xml
@ -348,6 +338,8 @@ rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELBugzillaKerne
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELBugzillaPython.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELBugzillaVmcore.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELBugzillaXorg.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELBugzillaLibreport.xml
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELBugzillaJava.xml
rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/libreport/workflows.d/report_rhel.conf
rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
rm -f $RPM_BUILD_ROOT%{_mandir}/man5/report_rhel.conf.5
@ -404,9 +396,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%dir %{_sysconfdir}/%{name}/
%dir %{_sysconfdir}/%{name}/events.d/
%dir %{_sysconfdir}/%{name}/events/
%dir %{_sysconfdir}/%{name}/plugins/
%dir %{_datadir}/%{name}/events/
%dir %{_datadir}/%{name}/workflows/
%dir %{_sysconfdir}/%{name}/plugins/
%files devel
%defattr(-,root,root,-)
@ -465,7 +457,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_datadir}/%{name}/events/report_EmergencyAnalysis.xml
%{_mandir}/man1/report-gtk.1.gz
%files gtk-devel
%defattr(-,root,root,-)
%{_libdir}/libreport-gtk.so
@ -491,7 +482,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%files plugin-mailx
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
%{_datadir}/%{name}/conf.d/plugins/mailx.conf
%{_datadir}/%{name}/events/report_Mailx.xml
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.mailx.xml
%config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
%{_mandir}/man5/mailx.conf.5.*
%{_mandir}/man5/mailx_event.conf.5.*
@ -501,14 +494,17 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%files plugin-ureport
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
%{_datadir}/%{name}/conf.d/plugins/ureport.conf
%{_bindir}/reporter-ureport
%{_mandir}/man1/reporter-ureport.1.gz
%{_mandir}/man5/ureport.conf.5.gz
%{_datadir}/%{name}/events/report_uReport.xml
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
%files plugin-bugzilla
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla.conf
%{_datadir}/%{name}/conf.d/plugins/bugzilla.conf
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format.conf
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_libreport.conf
@ -516,6 +512,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_datadir}/%{name}/events/report_Bugzilla.xml
%config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
%config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.bugzilla.xml
# FIXME: remove with the old gui
%{_mandir}/man1/reporter-bugzilla.1.gz
%{_mandir}/man5/report_Bugzilla.conf.5.*
@ -530,7 +527,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%files plugin-rhtsupport
%defattr(-,root,root,-)
%config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
%{_datadir}/%{name}/conf.d/plugins/rhtsupport.conf
%{_datadir}/%{name}/events/report_RHTSupport.xml
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
%config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
%{_mandir}/man1/reporter-rhtsupport.1.gz
%{_mandir}/man5/rhtsupport.conf.5.*
@ -559,6 +558,8 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_datadir}/%{name}/workflows/workflow_FedoraPython.xml
%{_datadir}/%{name}/workflows/workflow_FedoraVmcore.xml
%{_datadir}/%{name}/workflows/workflow_FedoraXorg.xml
%{_datadir}/%{name}/workflows/workflow_FedoraLibreport.xml
%{_datadir}/%{name}/workflows/workflow_FedoraJava.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
%{_mandir}/man5/report_fedora.conf.5.*
%endif
@ -571,6 +572,8 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_datadir}/%{name}/workflows/workflow_RHELPython.xml
%{_datadir}/%{name}/workflows/workflow_RHELvmcore.xml
%{_datadir}/%{name}/workflows/workflow_RHELxorg.xml
%{_datadir}/%{name}/workflows/workflow_RHELLibreport.xml
%{_datadir}/%{name}/workflows/workflow_RHELJava.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
%{_mandir}/man5/report_rhel.conf.5.*
@ -581,6 +584,8 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaPython.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaVmcore.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaXorg.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaLibreport.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaJava.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
%{_mandir}/man5/report_rhel_bugzilla.conf.5.*
@ -609,6 +614,17 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%changelog
* Thu Jan 30 2014 Jakub Filak <jfilak@redhat.com> 2.1.12-1
- fix loading of the user list of ignored words
- report-cli: use the Client API for communication to user
- add more forbidden words
- a better message for invalid data in backtrace_rating
- ureport: add support for client-side authentication
- Export plugin config dir in pkg-config
- add Java reporting workflows
- define DBus config interfaces for all plugins
- add a workflow for libreport type problems
* Wed Jan 8 2014 Peter Robinson <pbrobinson@fedoraproject.org> 2.1.11-3
- Don't use deprecated GTK3 API
- Fix unit tests
@ -620,7 +636,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
* Wed Jan 08 2014 Jakub Filak <jfilak@redhat.com> 2.1.11-1
- Update translations
- add type agnostic functions for map_string_t
- %description spelling fix.
- %%description spelling fix.
- update titles of RHTS workflows
- add Anaconda Bugzilla reporting workflows for RHEL
- add Bugzilla reporting workflows for RHEL

View File

@ -1 +1 @@
1fce627d018a730a4b97f15e9bf33103 libreport-2.1.11.tar.gz
3c563d8f9d5564a825f94f17af9c5508 libreport-2.1.12.tar.gz