27 lines
1.2 KiB
Diff
27 lines
1.2 KiB
Diff
diff -ruN libreport-2.1.11/configure libreport-2.1.11.fix/configure
|
|
--- libreport-2.1.11/configure 2014-01-08 18:46:48.057001105 +0100
|
|
+++ libreport-2.1.11.fix/configure 2014-01-08 18:46:33.880000782 +0100
|
|
@@ -17814,7 +17814,8 @@
|
|
AUTOM4TE=${AUTOM4TE-"${am_missing_run}autom4te"}
|
|
|
|
# Needed by tests/atlocal.in.
|
|
-O0CFLAGS=`echo $CFLAGS | sed 's/-O[0-9] *//' | sed 's/-Werror//'`
|
|
+# CFLAGS may contain '-Werror=format-security'
|
|
+O0CFLAGS=`echo $CFLAGS | sed 's/-O[[0-9]] *//' | sed 's/-Werror\(=[^ ]*\)\?//g'`
|
|
|
|
|
|
ac_config_headers="$ac_config_headers config.h"
|
|
diff -ruN libreport-2.1.11/configure.ac libreport-2.1.11.fix/configure.ac
|
|
--- libreport-2.1.11/configure.ac 2013-12-10 10:16:15.000000000 +0100
|
|
+++ libreport-2.1.11.fix/configure.ac 2014-01-08 18:46:33.857000781 +0100
|
|
@@ -307,7 +307,8 @@
|
|
AC_CONFIG_FILES([tests/Makefile tests/atlocal])
|
|
AM_MISSING_PROG([AUTOM4TE], [autom4te])
|
|
# Needed by tests/atlocal.in.
|
|
-AC_SUBST([O0CFLAGS], [`echo $CFLAGS | sed 's/-O[[0-9]] *//' | sed 's/-Werror//'`])
|
|
+# CFLAGS may contain '-Werror=format-security'
|
|
+AC_SUBST([O0CFLAGS], [`echo $CFLAGS | sed 's/-O[[0-9]] *//' | sed 's/-Werror\(=[[^ ]]*\)\?//g'`])
|
|
|
|
AC_CONFIG_HEADERS([config.h])
|
|
|