New upstream release 2.6.0

Signed-off-by: Jakub Filak <jfilak@redhat.com>
This commit is contained in:
Jakub Filak 2015-06-10 08:30:21 +02:00
parent b5a180b66f
commit 025695f441
11 changed files with 108 additions and 6184 deletions

View File

@ -1,42 +0,0 @@
From 953ee16aba113bfd3b445c651ee5a7ad1cedcb26 Mon Sep 17 00:00:00 2001
From: Jakub Filak <jfilak@redhat.com>
Date: Thu, 9 Apr 2015 07:35:55 +0200
Subject: [PATCH] client-python: remove shebang from non-executable scripts
Signed-off-by: Jakub Filak <jfilak@redhat.com>
---
src/client-python/reportclient/debuginfo.py | 1 -
src/client-python/reportclient/dnfdebuginfo.py | 1 -
src/client-python/reportclient/yumdebuginfo.py | 1 -
3 files changed, 3 deletions(-)
diff --git a/src/client-python/reportclient/debuginfo.py b/src/client-python/reportclient/debuginfo.py
index e593476..44521d0 100644
--- a/src/client-python/reportclient/debuginfo.py
+++ b/src/client-python/reportclient/debuginfo.py
@@ -1,4 +1,3 @@
-#!/usr/bin/python
# coding=UTF-8
## Copyright (C) 2015 ABRT team <abrt-devel-list@redhat.com>
diff --git a/src/client-python/reportclient/dnfdebuginfo.py b/src/client-python/reportclient/dnfdebuginfo.py
index 325d4b9..4ad6e0b 100644
--- a/src/client-python/reportclient/dnfdebuginfo.py
+++ b/src/client-python/reportclient/dnfdebuginfo.py
@@ -1,4 +1,3 @@
-#!/usr/bin/python
# coding=UTF-8
## Copyright (C) 2015 ABRT team <abrt-devel-list@redhat.com>
diff --git a/src/client-python/reportclient/yumdebuginfo.py b/src/client-python/reportclient/yumdebuginfo.py
index 571992c..080a394 100644
--- a/src/client-python/reportclient/yumdebuginfo.py
+++ b/src/client-python/reportclient/yumdebuginfo.py
@@ -1,4 +1,3 @@
-#!/usr/bin/python
# coding=UTF-8
## Copyright (C) 2015 ABRT team <abrt-devel-list@redhat.com>
--
2.4.1

View File

@ -0,0 +1,94 @@
From c16f9d4abf944b62bd8e13e6445a8d50f4e8698a Mon Sep 17 00:00:00 2001
From: Jakub Filak <jfilak@redhat.com>
Date: Wed, 10 Jun 2015 08:11:29 +0200
Subject: [PATCH] testsuite: fix parse_numbers on i686
Signed-off-by: Jakub Filak <jfilak@redhat.com>
---
tests/xfuncs.at | 26 +++++++++++++-------------
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/tests/xfuncs.at b/tests/xfuncs.at
index dbcc602..222824c 100644
--- a/tests/xfuncs.at
+++ b/tests/xfuncs.at
@@ -86,23 +86,23 @@ int main(void)
assert(try_atou("foo54321", &uint_value) != 0);
assert(uint_value == 12345);
- char buf[sizeof(unsigned long) * 3 + 1];
+ char buf[sizeof(unsigned long long) * 3 + 1];
- snprintf(buf, sizeof(buf), "%lu", 1LU + UINT_MAX);
+ snprintf(buf, sizeof(buf), "%llu", 1LLU + UINT_MAX);
assert(try_atou(buf, &uint_value) != 0 || !"Above UINT_MAX");
assert(uint_value == 12345);
assert(try_atou("-1", &uint_value) != 0);
assert(uint_value == 12345);
- snprintf(buf, sizeof(buf), "%lu", (long unsigned)UINT_MAX);
+ snprintf(buf, sizeof(buf), "%llu", (unsigned long long)UINT_MAX);
assert(try_atou(buf, &uint_value) == 0);
assert(uint_value == UINT_MAX);
- assert(xatou(buf) == UINT_MAX);
+ assert(xatou(buf) == UINT_MAX);
assert(try_atou("0", &uint_value) == 0);
assert(uint_value == 0);
- assert(xatou("0") == 0);
+ assert(xatou("0") == 0);
}
{
@@ -113,22 +113,22 @@ int main(void)
assert(try_atoi("foo54321", &int_value) != 0);
assert(int_value == 12345);
- char buf[sizeof(long) * 3 + 1];
+ char buf[sizeof(long long) * 3 + 1];
- snprintf(buf, sizeof(buf), "%ld", 1L + INT_MAX);
+ snprintf(buf, sizeof(buf), "%lld", 1LL + INT_MAX);
assert(try_atoi(buf, &int_value) != 0 || !"Parse INT_MAX+1");
assert(int_value == 12345 || !"Above INT_MAX");
- snprintf(buf, sizeof(buf), "%ld", -1L + INT_MIN);
+ snprintf(buf, sizeof(buf), "%lld", -1LL + INT_MIN);
assert(try_atoi(buf, &int_value) != 0 || !"Parse INT_MIN-1");
assert(int_value == 12345 || !"Belove INT_MIN");
- snprintf(buf, sizeof(buf), "%ld", (long unsigned)INT_MAX);
+ snprintf(buf, sizeof(buf), "%lld", (unsigned long long)INT_MAX);
assert(try_atoi(buf, &int_value) == 0 || !"Parse INT_MAX");
assert(int_value == INT_MAX);
assert(xatoi(buf) == INT_MAX);
- snprintf(buf, sizeof(buf), "%ld", (long unsigned)INT_MIN);
+ snprintf(buf, sizeof(buf), "%lld", (unsigned long long)INT_MIN);
assert(try_atoi(buf, &int_value) == 0 || !"Parse INT_MIN");
assert(int_value == INT_MIN);
assert(xatoi(buf) == INT_MIN);
@@ -142,16 +142,16 @@ int main(void)
assert(try_atoi_positive("foo54321", &positive_value) != 0);
assert(positive_value == 12345);
- char buf[sizeof(long) * 3 + 1];
+ char buf[sizeof(long long) * 3 + 1];
- snprintf(buf, sizeof(buf), "%ld", 1L + INT_MAX);
+ snprintf(buf, sizeof(buf), "%lld", 1LL + INT_MAX);
assert(try_atoi_positive(buf, &positive_value) != 0);
assert(positive_value == 12345 || !"Above INT_MAX");
assert(try_atoi_positive("-1", &positive_value) != 0);
assert(positive_value == 12345 || !"After -1");
- snprintf(buf, sizeof(buf), "%ld", (long unsigned)INT_MAX);
+ snprintf(buf, sizeof(buf), "%lld", (unsigned long long)INT_MAX);
assert(try_atoi_positive(buf, &positive_value) == 0 || !"Parse INT_MAX");
assert(positive_value == INT_MAX);
assert(xatoi_positive(buf) == INT_MAX);
--
2.4.1

View File

@ -1,99 +0,0 @@
From 64c97e6452af83a85a5d4a0856643d5e1b4b29a8 Mon Sep 17 00:00:00 2001
From: Matej Habrnal <mhabrnal@redhat.com>
Date: Mon, 13 Apr 2015 15:09:42 +0200
Subject: [PATCH] reporter-mantisbt: switch from 'analyzer' to 'type'
the report_centos.conf and centos_report_event.conf files was forgotten when
the 'analyzer' was switched to 'type'
Related to #314
Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
---
src/plugins/centos_report_event.conf | 12 ++++++------
src/workflows/report_centos.conf | 14 +++++++-------
2 files changed, 13 insertions(+), 13 deletions(-)
diff --git a/src/plugins/centos_report_event.conf b/src/plugins/centos_report_event.conf
index 53f12d8..d313474 100644
--- a/src/plugins/centos_report_event.conf
+++ b/src/plugins/centos_report_event.conf
@@ -1,27 +1,27 @@
-EVENT=report_CentOSBugTracker analyzer=xorg
+EVENT=report_CentOSBugTracker type=xorg
reporter-mantisbt
-EVENT=report_CentOSBugTracker analyzer=Kerneloops
+EVENT=report_CentOSBugTracker type=Kerneloops
reporter-mantisbt
-EVENT=report_CentOSBugTracker analyzer=vmcore
+EVENT=report_CentOSBugTracker type=vmcore
reporter-mantisbt
-EVENT=report_CentOSBugTracker analyzer=Python component!=anaconda
+EVENT=report_CentOSBugTracker type=Python component!=anaconda
test -f component || abrt-action-save-package-data
reporter-mantisbt \
-c /etc/libreport/plugins/mantisbt.conf \
-F /etc/libreport/plugins/mantisbt_format.conf \
-A /etc/libreport/plugins/mantisbt_formatdup.conf
-EVENT=report_CentOSBugTracker analyzer=Python3 component!=anaconda
+EVENT=report_CentOSBugTracker type=Python3 component!=anaconda
test -f component || abrt-action-save-package-data
reporter-mantisbt \
-c /etc/libreport/plugins/mantisbt.conf \
-F /etc/libreport/plugins/mantisbt_format.conf \
-A /etc/libreport/plugins/mantisbt_formatdup.conf
-EVENT=report_CentOSBugTracker analyzer=CCpp duphash!=
+EVENT=report_CentOSBugTracker type=CCpp duphash!=
test -f component || abrt-action-save-package-data
component="`cat component`"
format="mantisbt_format.conf"
diff --git a/src/workflows/report_centos.conf b/src/workflows/report_centos.conf
index 07b0d40..258edf4 100644
--- a/src/workflows/report_centos.conf
+++ b/src/workflows/report_centos.conf
@@ -2,30 +2,30 @@ EVENT=workflow_CentOSLibreport analyzer=libreport
# this is just a meta event which consists of other events
# the list is defined in the xml file
-EVENT=workflow_CentOSCCpp analyzer=CCpp
+EVENT=workflow_CentOSCCpp type=CCpp
# this is just a meta event which consists of other events
# the list is defined in the xml file
-EVENT=workflow_CentOSPython analyzer=Python component!=anaconda
+EVENT=workflow_CentOSPython type=Python component!=anaconda
# this is just a meta event which consists of other events
# the list is defined in the xml file
-EVENT=workflow_CentOSPython3 analyzer=Python3 component!=anaconda
+EVENT=workflow_CentOSPython3 type=Python3 component!=anaconda
# this is just a meta event which consists of other events
# the list is defined in the xml file
-EVENT=workflow_CentOSKerneloops analyzer=Kerneloops
+EVENT=workflow_CentOSKerneloops type=Kerneloops
# this is just a meta event which consists of other events
# the list is defined in the xml file
-EVENT=workflow_CentOSVmcore analyzer=vmcore
+EVENT=workflow_CentOSVmcore type=vmcore
# this is just a meta event which consists of other events
# the list is defined in the xml file
-EVENT=workflow_CentOSXorg analyzer=xorg
+EVENT=workflow_CentOSXorg type=xorg
# this is just a meta event which consists of other events
# the list is defined in the xml file
-EVENT=workflow_CentOSJava analyzer=Java
+EVENT=workflow_CentOSJava type=Java
# this is just a meta event which consists of other events
# the list is defined in the xml file
--
2.4.1

View File

@ -1,52 +0,0 @@
From d87be387a8d3ab91d5771a479fff4f144d1fd97e Mon Sep 17 00:00:00 2001
From: Matej Habrnal <mhabrnal@redhat.com>
Date: Wed, 22 Apr 2015 14:51:24 +0200
Subject: [PATCH] report client: provide cpio log when unpacking fails
Related to rhbz#1169774 rhbz#1213485 rhbz#1036918
Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
---
src/client-python/reportclient/debuginfo.py | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)
diff --git a/src/client-python/reportclient/debuginfo.py b/src/client-python/reportclient/debuginfo.py
index 44521d0..24bece3 100644
--- a/src/client-python/reportclient/debuginfo.py
+++ b/src/client-python/reportclient/debuginfo.py
@@ -27,6 +27,7 @@ import time
import errno
import shutil
from subprocess import Popen
+import tempfile
from reportclient import (_, log1, log2, RETURN_OK, RETURN_FAILURE,
RETURN_CANCEL_BY_USER, verbose, ask_yes_no,
@@ -127,17 +128,21 @@ def unpack_rpm(package_full_path, files, tmp_dir, destdir, exact_files=False):
file_patterns += "." + filename + " "
cpio_args = ["cpio", "-idu", file_patterns.strip()]
- with open("/dev/null", "w") as null:
+ with tempfile.NamedTemporaryFile(prefix='abrt-unpacking-', dir='/tmp',
+ delete=False) as log_file:
+ log_file_name = log_file.name
cpio = Popen(cpio_args, cwd=destdir, bufsize=-1,
- stdin=unpacked_cpio, stdout=null, stderr=null)
+ stdin=unpacked_cpio, stdout=log_file, stderr=log_file)
retcode = cpio.wait()
if retcode == 0:
log1("files extracted OK")
#print _("Removing temporary cpio file")
+ os.unlink(log_file_name)
os.unlink(unpacked_cpio_path)
else:
- print(_("Can't extract files from '{0}'").format(unpacked_cpio_path))
+ print(_("Can't extract files from '{0}'. For more information see '{1}'")
+ .format(unpacked_cpio_path, log_file_name))
return RETURN_FAILURE
def clean_up(tmp_dir):
--
2.4.1

View File

@ -1,26 +0,0 @@
From af400c8b78a1d55bdbad7b454b03f176cd9fafd0 Mon Sep 17 00:00:00 2001
From: Matej Habrnal <mhabrnal@redhat.com>
Date: Wed, 22 Apr 2015 16:10:45 +0200
Subject: [PATCH] report client: fix - close an unclosed file
Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
---
src/client-python/reportclient/debuginfo.py | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/client-python/reportclient/debuginfo.py b/src/client-python/reportclient/debuginfo.py
index 24bece3..9daf7aa 100644
--- a/src/client-python/reportclient/debuginfo.py
+++ b/src/client-python/reportclient/debuginfo.py
@@ -135,6 +135,8 @@ def unpack_rpm(package_full_path, files, tmp_dir, destdir, exact_files=False):
stdin=unpacked_cpio, stdout=log_file, stderr=log_file)
retcode = cpio.wait()
+ unpacked_cpio.close()
+
if retcode == 0:
log1("files extracted OK")
#print _("Removing temporary cpio file")
--
2.4.1

View File

@ -1,54 +0,0 @@
From 70414c99d98c5ed65a2b8b431aca9a3455d24ce2 Mon Sep 17 00:00:00 2001
From: Matej Habrnal <mhabrnal@redhat.com>
Date: Tue, 12 May 2015 14:54:20 +0200
Subject: [PATCH] report client: check owner of /var/cache/abrt-di when
unpacking fails
If unpacking of debuginfo fails and '/vat/cache/abrt-di' is not owned by
abrt.abrt the client provides a solution how to fix the issue.
Related to rhbz#1213485
Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
---
src/client-python/reportclient/debuginfo.py | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/src/client-python/reportclient/debuginfo.py b/src/client-python/reportclient/debuginfo.py
index 9daf7aa..6a3b67c 100644
--- a/src/client-python/reportclient/debuginfo.py
+++ b/src/client-python/reportclient/debuginfo.py
@@ -23,6 +23,7 @@
import sys
import os
+import pwd
import time
import errno
import shutil
@@ -42,7 +43,6 @@ def ensure_abrt_uid(fn):
the function.
"""
- import pwd
current_uid = os.getuid()
current_gid = os.getgid()
abrt = pwd.getpwnam("abrt")
@@ -381,6 +381,14 @@ class DebugInfoDownload(object):
if unpack_result == RETURN_FAILURE:
# recursively delete the temp dir on failure
print(_("Unpacking failed, aborting download..."))
+
+ s = os.stat(self.cachedir)
+ abrt = pwd.getpwnam("abrt")
+ if (s.st_uid != abrt.pw_uid) or (s.st_gid != abrt.pw_gid):
+ print(_("'{0}' must be owned by abrt. "
+ "Please run '# chown -R abrt.abrt {0}' "
+ "to fix the issue.").format(self.cachedir))
+
clean_up(self.tmpdir)
return RETURN_FAILURE
--
2.4.1

View File

@ -1,246 +0,0 @@
From 91b54debb692a035d2db17d5e9654698462a7b34 Mon Sep 17 00:00:00 2001
From: Matej Habrnal <mhabrnal@redhat.com>
Date: Wed, 13 May 2015 16:37:19 +0200
Subject: [PATCH] reporter-mantisbt: add event for reporting AVCs
Without this commit is not possible to report AVCs because there are not event
for 'report_CentOSBugTracker' with analyzer=libreport which is used for
reporting AVCs.
Related to bugs.centos#8422
Related to #348
Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
---
doc/Makefile.am | 2 +
doc/mantisbt_format_analyzer_libreport.conf.txt | 18 +++++++
doc/mantisbt_formatdup_analyzer_libreport.conf.txt | 18 +++++++
src/plugins/Makefile.am | 4 +-
src/plugins/centos_report_event.conf | 5 ++
.../mantisbt_format_analyzer_libreport.conf | 59 ++++++++++++++++++++++
.../mantisbt_formatdup_analyzer_libreport.conf | 56 ++++++++++++++++++++
7 files changed, 161 insertions(+), 1 deletion(-)
create mode 100644 doc/mantisbt_format_analyzer_libreport.conf.txt
create mode 100644 doc/mantisbt_formatdup_analyzer_libreport.conf.txt
create mode 100644 src/plugins/mantisbt_format_analyzer_libreport.conf
create mode 100644 src/plugins/mantisbt_formatdup_analyzer_libreport.conf
diff --git a/doc/Makefile.am b/doc/Makefile.am
index b572a5f..a549362 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -41,6 +41,8 @@ MAN5_TXT += bugzilla_format_analyzer_libreport.conf.txt
MAN5_TXT += mantisbt.conf.txt
MAN5_TXT += mantisbt_format.conf.txt
MAN5_TXT += mantisbt_formatdup.conf.txt
+MAN5_TXT += mantisbt_format_analyzer_libreport.conf.txt
+MAN5_TXT += mantisbt_formatdup_analyzer_libreport.conf.txt
MAN5_TXT += emergencyanalysis_event.conf.txt
MAN5_TXT += ignored_words.conf.txt
MAN5_TXT += forbidden_words.conf.txt
diff --git a/doc/mantisbt_format_analyzer_libreport.conf.txt b/doc/mantisbt_format_analyzer_libreport.conf.txt
new file mode 100644
index 0000000..8cbd327
--- /dev/null
+++ b/doc/mantisbt_format_analyzer_libreport.conf.txt
@@ -0,0 +1,18 @@
+mantisbt_format_analyzer_libreport.conf(5)
+==========================================
+
+NAME
+----
+mantisbt_format_analyzer_libreport.conf - configuration file for libreport.
+
+DESCRIPTION
+-----------
+This configuration file provides definition of general formatting for duplicate MantisBT issues.
+
+SEE ALSO
+--------
+reporter-mantisbt(1)
+
+AUTHOR
+------
+* ABRT Team
diff --git a/doc/mantisbt_formatdup_analyzer_libreport.conf.txt b/doc/mantisbt_formatdup_analyzer_libreport.conf.txt
new file mode 100644
index 0000000..cd082de
--- /dev/null
+++ b/doc/mantisbt_formatdup_analyzer_libreport.conf.txt
@@ -0,0 +1,18 @@
+mantisbt_formatdup_analyzer_libreport.conf(5)
+=============================================
+
+NAME
+----
+mantisbt_formatdup_analyzer_libreport.conf - configuration file for libreport.
+
+DESCRIPTION
+-----------
+This configuration file provides definition of general formatting for duplicate MantisBT issues.
+
+SEE ALSO
+--------
+reporter-mantisbt(1)
+
+AUTHOR
+------
+* ABRT Team
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 144624a..4030ab3 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -42,7 +42,9 @@ endif
if BUILD_MANTISBT
reporters_plugin_conf += mantisbt.conf
reporters_plugin_format_conf += mantisbt_format.conf \
- mantisbt_formatdup.conf
+ mantisbt_formatdup.conf \
+ mantisbt_format_analyzer_libreport.conf \
+ mantisbt_formatdup_analyzer_libreport.conf
endif
defaultreportpluginsconfdir = $(DEFAULT_REPORT_PLUGINS_CONF_DIR)
diff --git a/src/plugins/centos_report_event.conf b/src/plugins/centos_report_event.conf
index d313474..8cf2a50 100644
--- a/src/plugins/centos_report_event.conf
+++ b/src/plugins/centos_report_event.conf
@@ -35,3 +35,8 @@ EVENT=report_CentOSBugTracker type=CCpp duphash!=
-F "/etc/libreport/plugins/$format" \
-A "/etc/libreport/plugins/$formatdup"
+EVENT=report_CentOSBugTracker analyzer=libreport
+ reporter-mantisbt \
+ -c /etc/libreport/plugins/mantisbt.conf \
+ -F /etc/libreport/plugins/mantisbt_format_analyzer_libreport.conf \
+ -A /etc/libreport/plugins/mantisbt_formatdup_analyzer_libreport.conf
diff --git a/src/plugins/mantisbt_format_analyzer_libreport.conf b/src/plugins/mantisbt_format_analyzer_libreport.conf
new file mode 100644
index 0000000..a514e38
--- /dev/null
+++ b/src/plugins/mantisbt_format_analyzer_libreport.conf
@@ -0,0 +1,59 @@
+# Lines starting with # are ignored.
+# Lines can be continued on the next line using trailing backslash.
+#
+# Format:
+# %summary:: summary format
+# section:: element1[,element2]...
+# The literal text line to be added to Bugzilla comment. Can be empty.
+# (IOW: empty lines are NOT ignored!)
+#
+# Summary format is a line of text, where %element% is replaced by
+# text element's content, and [[...%element%...]] block is used only if
+# %element% exists. [[...]] blocks can nest.
+#
+# Sections can be:
+# - %summary: bug summary format string.
+# - %attach: a list of elements to attach.
+# - text, double colon (::) and the list of comma-separated elements.
+# Text can be empty (":: elem1, elem2, elem3" works),
+# in this case "Text:" header line will be omitted.
+#
+# Elements can be:
+# - problem directory element names, which get formatted as
+# <element_name>: <contents>
+# or
+# <element_name>:
+# :<contents>
+# :<contents>
+# :<contents>
+# - problem directory element names prefixed by "%bare_",
+# which is formatted as-is, without "<element_name>:" and colons
+# - %oneline, %multiline, %text wildcards, which select all corresponding
+# elements for output or attachment
+# - %binary wildcard, valid only for %attach section, instructs to attach
+# binary elements
+# - problem directory element names prefixed by "-",
+# which excludes given element from all wildcards
+#
+# Nonexistent elements are silently ignored.
+# If none of elements exists, the section will not be created.
+
+%summary:: %reason%
+
+Description of problem:: %bare_comment, %bare_description
+
+Version-Release number of selected component:: %bare_package
+
+Truncated backtrace:: %bare_%short_backtrace
+
+%Additional info::
+:: -pkg_arch,-pkg_epoch,-pkg_name,-pkg_release,-pkg_version,\
+ -component,-architecture,\
+ -analyzer,-count,-duphash,-uuid,-abrt_version,\
+ -username,-hostname,-os_release,-os_info,\
+ -time,-pid,-pwd,-last_occurrence,-ureports_counter,\
+ %reporter,\
+ %oneline
+
+%attach:: -reported_to,-comment,-reason,-event_log,%multiline,\
+ -coredump,%binary
diff --git a/src/plugins/mantisbt_formatdup_analyzer_libreport.conf b/src/plugins/mantisbt_formatdup_analyzer_libreport.conf
new file mode 100644
index 0000000..d9ab0e3
--- /dev/null
+++ b/src/plugins/mantisbt_formatdup_analyzer_libreport.conf
@@ -0,0 +1,56 @@
+# Lines starting with # are ignored.
+# Lines can be continued on the next line using trailing backslash.
+#
+# Format:
+# %summary:: summary format
+# section:: element1[,element2]...
+# The literal text line to be added to Bugzilla comment. Can be empty.
+# (IOW: empty lines are NOT ignored!)
+#
+# Summary format is a line of text, where %element% is replaced by
+# text element's content, and [[...%element%...]] block is used only if
+# %element% exists. [[...]] blocks can nest.
+#
+# Sections can be:
+# - %summary: bug summary format string.
+# - %attach: a list of elements to attach.
+# - text, double colon (::) and the list of comma-separated elements.
+# Text can be empty (":: elem1, elem2, elem3" works),
+# in this case "Text:" header line will be omitted.
+#
+# Elements can be:
+# - problem directory element names, which get formatted as
+# <element_name>: <contents>
+# or
+# <element_name>:
+# :<contents>
+# :<contents>
+# :<contents>
+# - problem directory element names prefixed by "%bare_",
+# which is formatted as-is, without "<element_name>:" and colons
+# - %oneline, %multiline, %text wildcards, which select all corresponding
+# elements for output or attachment
+# - %binary wildcard, valid only for %attach section, instructs to attach
+# binary elements
+# - problem directory element names prefixed by "-",
+# which excludes given element from all wildcards
+#
+# Nonexistent elements are silently ignored.
+# If none of elements exists, the section will not be created.
+
+Another user experienced a similar problem:
+
+# If user filled out comment field, show it:
+:: %bare_comment
+
+# var_log_messages has too much variance (time/date),
+# we exclude it from message so that dup message elimination has more chances to work
+:: \
+ -pkg_arch,-pkg_epoch,-pkg_name,-pkg_release,-pkg_version,\
+ -component,-architecture,\
+ -analyzer,-count,-duphash,-uuid,-abrt_version,\
+ -username,-hostname,-os_release,-os_info,\
+ -time,-pid,-pwd,-last_occurrence,-ureports_counter,\
+ -var_log_messages,\
+ %reporter,\
+ %oneline
--
2.4.1

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

View File

@ -2,12 +2,12 @@
# platform-dependent
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%define satyr_ver 0.16
%define satyr_ver 0.18
Summary: Generic library for reporting various problems
Name: libreport
Version: 2.5.1
Release: 2%{?dist}
Version: 2.6.0
Release: 1%{?dist}
License: GPLv2+
Group: System Environment/Libraries
URL: https://github.com/abrt/abrt/wiki/ABRT-Project
@ -16,15 +16,7 @@ Source1: autogen.sh
# git format-patch %%{Version} -N -M --topo-order
# i=0; for p in `ls 0*.patch`; do printf "Patch%04d: %s\n" $i $p; ((i++)); done
Patch0001: 0001-client-python-remove-shebang-from-non-executable-scr.patch
Patch0002: 0002-reporter-mantisbt-switch-from-analyzer-to-type.patch
Patch0003: 0003-report-client-provide-cpio-log-when-unpacking-fails.patch
Patch0004: 0004-report-client-fix-close-an-unclosed-file.patch
Patch0005: 0005-report-client-check-owner-of-var-cache-abrt-di-when-.patch
Patch0006: 0006-reporter-mantisbt-add-event-for-reporting-AVCs.patch
#Patch0007: 0007-spec-add-files-related-to-reporting-AVCs-by-reporter.patch
Patch0008: 0008-translations-updates.patch
Patch0009: 0009-bugzilla-Spell-Bugzilla-not-BZ-in-UI.patch
Patch0001: 0001-testsuite-fix-parse_numbers-on-i686.patch
# git is need for '%%autosetup -S git' which automatically applies all the
# patches above. Please, be aware that the patches must be generated
@ -745,6 +737,15 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%changelog
* Tue Jun 09 2015 Jakub Filak <jfilak@redhat.com> 2.6.0-1
- harden the code against directory traversal, symbolic and hard link attacks
- fix a bug causing that the first value of AlwaysExcludedElements was ignored
- fix missing icon for the "Stop" button icon name
- switch the default dump dir mode to 0640
- fix races in dump directory handling code
- improve development documentation
- translations updates
* Wed May 20 2015 Matej Habrnal <mhabrnal@redhat.com> 2.5.1-2
- reporter-mantisbt: switch from 'analyzer' to 'type'
- report client: provide cpio log when unpacking fails

View File

@ -1 +1 @@
c9cc7971897ae7d49a9901cc8d3cdb7b libreport-2.5.1.tar.gz
764ef9745518391abe8349f979d6ce1d libreport-2.6.0.tar.gz