Rebase to version 0.14.0
Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
This commit is contained in:
parent
2ab927381d
commit
e46ce01fcb
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@
|
||||
/libqb-0.11.0.tar.xz
|
||||
/libqb-0.11.1.tar.xz
|
||||
/libqb-0.13.0.tar.xz
|
||||
/libqb-0.14.0.tar.xz
|
||||
|
@ -1,24 +1,13 @@
|
||||
From 2f400ae9a252543a09bb42b45aa6ac90a898ede7 Mon Sep 17 00:00:00 2001
|
||||
From: Angus Salkeld <asalkeld@redhat.com>
|
||||
Date: Fri, 3 Feb 2012 09:20:28 +1000
|
||||
Subject: [PATCH] rhel brew
|
||||
|
||||
Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
tests/Makefile.am | 22 ++++++++++++----------
|
||||
2 files changed, 13 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index fd158aa..e2efcc8 100644
|
||||
index 4a4dd0a..10981e4 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -8,7 +8,7 @@ AC_INIT([libqb],
|
||||
@@ -11,7 +11,7 @@ AC_CONFIG_SRCDIR([lib/ringbuffer.c])
|
||||
AC_CONFIG_HEADERS([include/config.h include/qb/qbconfig.h])
|
||||
AC_USE_SYSTEM_EXTENSIONS
|
||||
|
||||
|
||||
-AM_INIT_AUTOMAKE([-Wno-portability dist-xz color-tests parallel-tests])
|
||||
+AM_INIT_AUTOMAKE([-Wno-portability dist-xz])
|
||||
dnl automake >= 1.11 offers --enable-silent-rules for suppressing the output from
|
||||
dnl normal compilation. When a failure occurs, it will then display the full
|
||||
dnl normal compilation. When a failure occurs, it will then display the full
|
||||
dnl command line
|
||||
|
59
libqb.spec
59
libqb.spec
@ -1,5 +1,5 @@
|
||||
Name: libqb
|
||||
Version: 0.13.0
|
||||
Version: 0.14.0
|
||||
Release: 1%{?dist}
|
||||
Summary: An IPC library for high performance servers
|
||||
|
||||
@ -49,6 +49,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%{_sbindir}/qb-blackbox
|
||||
%{_libdir}/libqb.so.*
|
||||
|
||||
%package devel
|
||||
@ -67,8 +68,64 @@ developing applications that use %{name}.
|
||||
%{_libdir}/libqb.so
|
||||
%{_libdir}/pkgconfig/libqb.pc
|
||||
%{_mandir}/man3/qb*3*
|
||||
%{_mandir}/man8/qb-blackbox.8.gz
|
||||
|
||||
%changelog
|
||||
* Sun Jun 24 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.0-1
|
||||
LOG: fix threaded logging.
|
||||
Add user control of the permissions that are set on the shared mem files
|
||||
LOG: Restrict string trucation during serialization to when a precision is specified
|
||||
LOG: Gracefully fail when the caller exceeds QB_LOG_MAX_LEN
|
||||
LOG: Observe field widths when serializing string arguments
|
||||
RB: use the same mechanism in reclaim as read/peek to detect end-of-ring
|
||||
Add needs_response_ack option to ./check
|
||||
RB: fix wrong sem_flg IPC_NOWAIT option
|
||||
TESTS: fix warning about unused functions
|
||||
Remove D_FORTIFY_SOURCE from check.
|
||||
Open shared mem file in /dev/shm only for linux
|
||||
Don't use msg_flags on solaris (recvmsg).
|
||||
Turn off attribute_section on solaris
|
||||
ipc example: add -e (events) option
|
||||
IPC: if the server returns EAGAIN or ETIMEOUT the check the connection
|
||||
LOG: make it possible to fsync() on each file log.
|
||||
IPC: make sure that the created callback happens before dispatches
|
||||
LOG: fix the printing of %p in the blackbox
|
||||
IPC: On bsd's use the notifier for responses
|
||||
IPC: interpret ECONNRESET and EPIPE as ENOTCONN
|
||||
cleanup some warnings
|
||||
config: use newer AC_COMPILE_IFELSE()
|
||||
blackbox: fix %p formatting
|
||||
LOG: put all fields in the blackbox (added priority and tags)
|
||||
example: make the priority uint8_t
|
||||
Remove strerror out of check_funcs
|
||||
RB: fix compiler warning.
|
||||
Add replacement function stpcpy
|
||||
Add missing AC_TYPE_UINT16_T to configure.ac
|
||||
Use AC_FUNC_STRERROR_R and STRERROR_R_CHAR_P
|
||||
Add stpcpy strcasecmp to the check_funcs
|
||||
Move some conditional defines into code (from the configure script)
|
||||
Remove some unused configure checks
|
||||
Remove message queues
|
||||
Check for union semun properly
|
||||
Blackbox: provide more space for log messages when reading from the blackbox.
|
||||
Add the blackbox reader manpage to the spec file
|
||||
Enable error logging for the blackbox reader
|
||||
RB: Read the file size into an initialized variable of the correct size
|
||||
Add a tool to dump the blackbox.
|
||||
RB: to be safer save the read and write pointers at the top of the blackbox
|
||||
avoid unwarranted use of strncpy: use memcpy instead
|
||||
blackbox: fix the print_from_file()
|
||||
RB: add an option to not use any semaphores
|
||||
LOG: tweak the blackbox format string
|
||||
LOG: accept NULL strings into the blackbox
|
||||
LOG: protect close and reload from calling log
|
||||
Add benchmark option (-b) to examples/ipcclient
|
||||
TEST: make rbreader/writer more like the other benchmarking apps
|
||||
IPC: log the connection description in all logs
|
||||
TEST: re-organise the ipc test suites
|
||||
IPC: only modify the dispatch if we get EAGAIN
|
||||
Correctly display timestamp in blackbox
|
||||
|
||||
* Thu May 10 2012 Angus Salkeld <asalkeld@redhat.com> - 0.13.0-1
|
||||
- Remove unneccessary __attribute__ ((aligned(8))) from internal headers
|
||||
- IPC: add a new function to get (and alloc) the extended stats.
|
||||
|
Loading…
Reference in New Issue
Block a user