Rebase to 0.13.0
Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
This commit is contained in:
parent
61516b4a4e
commit
2ab927381d
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@
|
||||
/libqb-0.10.1.tar.xz
|
||||
/libqb-0.11.0.tar.xz
|
||||
/libqb-0.11.1.tar.xz
|
||||
/libqb-0.13.0.tar.xz
|
||||
|
@ -14,12 +14,11 @@ index fd158aa..e2efcc8 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -8,7 +8,7 @@ AC_INIT([libqb],
|
||||
[quarterback-devel@fedorahosted.org])
|
||||
AC_CONFIG_SRCDIR([lib/ringbuffer.c])
|
||||
AC_CONFIG_HEADERS([include/config.h include/qb/qbconfig.h])
|
||||
AC_USE_SYSTEM_EXTENSIONS
|
||||
|
||||
-AM_INIT_AUTOMAKE([-Wno-portability dist-xz color-tests parallel-tests])
|
||||
+AM_INIT_AUTOMAKE([-Wno-portability dist-xz])
|
||||
dnl automake >= 1.11 offers --enable-silent-rules for suppressing the output from
|
||||
dnl normal compilation. When a failure occurs, it will then display the full
|
||||
dnl command line
|
||||
|
||||
|
65
libqb.spec
65
libqb.spec
@ -1,5 +1,5 @@
|
||||
Name: libqb
|
||||
Version: 0.11.1
|
||||
Version: 0.13.0
|
||||
Release: 1%{?dist}
|
||||
Summary: An IPC library for high performance servers
|
||||
|
||||
@ -69,6 +69,69 @@ developing applications that use %{name}.
|
||||
%{_mandir}/man3/qb*3*
|
||||
|
||||
%changelog
|
||||
* Thu May 10 2012 Angus Salkeld <asalkeld@redhat.com> - 0.13.0-1
|
||||
- Remove unneccessary __attribute__ ((aligned(8))) from internal headers
|
||||
- IPC: add a new function to get (and alloc) the extended stats.
|
||||
- Revert "Add the event queue length to the connection stats."
|
||||
- IPC: cleanup better on a failed client connect.
|
||||
- IPC(soc): be more consistent with control struct size
|
||||
- IPC: kill a compiler warning
|
||||
- IPC(soc): pass in the correct size into munmap()
|
||||
- TEST: Use /bin/sh not /bin/bash
|
||||
- TEST: check for lost shared mem on bsd too
|
||||
- rb: cleanup the semaphores
|
||||
- Fix some small issues in ./check
|
||||
- Cleanup the .gitignore files
|
||||
- configure.ac tweaks
|
||||
- Remove HZ and use sysconf instead.
|
||||
- SUN_LEN() macro is present if __EXTENSIONS__ is defined on Illumos
|
||||
- PF_UNIX is a POSIX standard name
|
||||
- Test for log facility names
|
||||
- IPC: drop log message to debug.
|
||||
- IPC: fix retrying of partial recv's and sends.
|
||||
- IPC: initialize enough shared mem for all 3 one way connections.
|
||||
- IPC: keep retrying to recv the socket message if partially recv'ed (part 2)
|
||||
- IPC: keep retrying to recv the socket message if partially recv'ed
|
||||
- IPC: handle the server shutdown better
|
||||
- IPC: handle a connection disconnect from the server better
|
||||
- IPC: make it possible to send events in the connected callback.
|
||||
- Add the event queue length to the connection stats.
|
||||
- IPC: add a is_connected client side function.
|
||||
- Fix typo in ./check
|
||||
- docs: clarify the need to use request/response headers
|
||||
- Remove unused local variable
|
||||
- IPC: change the socket recv function to read the response header.
|
||||
- Add some special commands into the ipc example
|
||||
- TEST: improve the tracing in the ipc tests.
|
||||
- Make "make (s)rpm" work more reliably
|
||||
- TEST: add a test to confirm we get the events we send.
|
||||
- TEST: reuse send_and_check for events.
|
||||
- IPC: make it possible for a root client to talk to a non-root server.
|
||||
- Run ./Lindent in the examples directory
|
||||
- Add some debug code to the ipcclient example
|
||||
- IPC: make sure ipc (socket) clients can connect to a server running as root.
|
||||
- IPC: allow qb to bump the max_message_size
|
||||
- IPC: check for a sane minimum max_message_size
|
||||
- add rpl_sem.h loop_poll_int.h to noinst_headers
|
||||
- Handle errors more consistently
|
||||
- call recv_ready on socket types
|
||||
- Handle a recv of size 0
|
||||
- make bsd shm path better by default.
|
||||
- Fix kqueue on freebsd.
|
||||
- Get the example socket includes right.
|
||||
- Fix kqueue compiling.
|
||||
- POLL: seperate out the poll/epoll and add kqueue
|
||||
- Test existence of getpeer* functions
|
||||
- Add inet header to tcpclient example
|
||||
- Don't link with setpshared if unavailable
|
||||
- NetBSD doesn't have semun defined
|
||||
- Use MADV_NOSYNC only on systems where available
|
||||
- Use SCHED_BATCH only on platforms where available
|
||||
- Fix a bug introduced by the bsd patch.
|
||||
- Cleanup the selection of semaphores to use
|
||||
- Fix some leaks in the logging.
|
||||
- Try and improve the portability on bsd variants.
|
||||
|
||||
* Sun Mar 11 2012 Angus Salkeld <asalkeld@redhat.com> - 0.11.1-1
|
||||
- configue libqb to not use epoll as it seems broken (#800865)
|
||||
- LOOP: remove some old timerfd code.
|
||||
|
Loading…
Reference in New Issue
Block a user