Rebase 4.10.1.
This commit is contained in:
parent
d7cc62017d
commit
e8ae3bf138
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@
|
|||||||
/libpfm-4.8.0.tar.gz
|
/libpfm-4.8.0.tar.gz
|
||||||
/libpfm-4.9.0.tar.gz
|
/libpfm-4.9.0.tar.gz
|
||||||
/libpfm-4.10.0.tar.gz
|
/libpfm-4.10.0.tar.gz
|
||||||
|
/libpfm-4.10.1.tar.gz
|
||||||
|
@ -1,44 +0,0 @@
|
|||||||
commit c3ca7e011e7ad23df326d9817453674d1290fb1a
|
|
||||||
Author: Stephane Eranian <eranian@gmail.com>
|
|
||||||
Date: Tue Jun 12 08:26:53 2018 -0700
|
|
||||||
|
|
||||||
Fix Cavium Thunder X2 build issues
|
|
||||||
|
|
||||||
Release v4.10.0 had a few bugs related to Cavium Thunder X2 build.
|
|
||||||
|
|
||||||
- lib/Makefile dependency was pointing to the wrong Cavium Thunder X2 event file name
|
|
||||||
- lib/Makefile was missing Cavium event file dependency for ARM64
|
|
||||||
- lib/pfmlib_commmon.c was missing support for Cavium Thunder X2 in 32-bit mode
|
|
||||||
|
|
||||||
Signed-off-by: Stephane Eranian <eranian@gmail.com>
|
|
||||||
|
|
||||||
diff --git a/lib/Makefile b/lib/Makefile
|
|
||||||
index 129db90..2eb3ebb 100644
|
|
||||||
--- a/lib/Makefile
|
|
||||||
+++ b/lib/Makefile
|
|
||||||
@@ -360,10 +360,11 @@ INC_ARM=pfmlib_arm_priv.h \
|
|
||||||
events/arm_cortex_a15_events.h \
|
|
||||||
events/arm_cortex_a57_events.h \
|
|
||||||
events/arm_cortex_a53_events.h \
|
|
||||||
- events/arm_thunderx2_events.h
|
|
||||||
+ events/arm_cavium_tx2_events.h
|
|
||||||
|
|
||||||
INC_ARM64=events/arm_cortex_a57_events.h \
|
|
||||||
- events/arm_cortex_a53_events.h
|
|
||||||
+ events/arm_cortex_a53_events.h \
|
|
||||||
+ events/arm_cavium_tx2_events.h
|
|
||||||
|
|
||||||
INCDEP=$(INC_COMMON) $(INCARCH)
|
|
||||||
|
|
||||||
diff --git a/lib/pfmlib_common.c b/lib/pfmlib_common.c
|
|
||||||
index f5bce8b..ca93d72 100644
|
|
||||||
--- a/lib/pfmlib_common.c
|
|
||||||
+++ b/lib/pfmlib_common.c
|
|
||||||
@@ -482,6 +482,7 @@ static pfmlib_pmu_t *pfmlib_pmus[]=
|
|
||||||
&arm_cortex_a57_support,
|
|
||||||
&arm_cortex_a53_support,
|
|
||||||
&arm_xgene_support,
|
|
||||||
+ &arm_thunderx2_support,
|
|
||||||
#endif
|
|
||||||
#ifdef CONFIG_PFMLIB_ARCH_ARM64
|
|
||||||
&arm_cortex_a57_support,
|
|
@ -9,8 +9,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: libpfm
|
Name: libpfm
|
||||||
Version: 4.10.0
|
Version: 4.10.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
Summary: Library to encode performance events for use by perf tool
|
Summary: Library to encode performance events for use by perf tool
|
||||||
|
|
||||||
@ -18,7 +18,6 @@ Group: System Environment/Libraries
|
|||||||
License: MIT
|
License: MIT
|
||||||
URL: http://perfmon2.sourceforge.net/
|
URL: http://perfmon2.sourceforge.net/
|
||||||
Source0: http://sourceforge.net/projects/perfmon2/files/libpfm4/%{name}-%{version}.tar.gz
|
Source0: http://sourceforge.net/projects/perfmon2/files/libpfm4/%{name}-%{version}.tar.gz
|
||||||
Patch1: libpfm-cavium-tx2.patch
|
|
||||||
Patch2: libpfm-python3-setup.patch
|
Patch2: libpfm-python3-setup.patch
|
||||||
|
|
||||||
%if %{with python}
|
%if %{with python}
|
||||||
@ -69,7 +68,6 @@ Python bindings for libpfm4 and perf_event_open system call.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .cavium
|
|
||||||
%patch2 -p1 -b .python3
|
%patch2 -p1 -b .python3
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -119,6 +117,9 @@ make \
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 15 2018 William Cohen <wcohen@redhat.com> - 4.10.1-1
|
||||||
|
- Rebase on libpfm-4.10.1.
|
||||||
|
|
||||||
* Tue Jun 12 2018 William Cohen <wcohen@redhat.com> - 4.10.0-2
|
* Tue Jun 12 2018 William Cohen <wcohen@redhat.com> - 4.10.0-2
|
||||||
- Use upstream libpfm cavium patch.
|
- Use upstream libpfm cavium patch.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libpfm-4.10.0.tar.gz) = c2e1a7d389efebc27a32dd3a5a6f3e8e8d624347616e06daf7bf06c0d5b8ca39cee5821ad5cf23330d47ed987697fcc05aa54660b8f6899f62aad9cd05e908f9
|
SHA512 (libpfm-4.10.1.tar.gz) = 33d99824216b4d83784e0db9f1aae3b39f84c2ba42dee64dde0b3c43cc5ee3a18c206d9044e75bf10867768add7cb9967c6318f7aa196f178f334271fa05e1aa
|
||||||
|
Loading…
Reference in New Issue
Block a user