Use upstream libpfm cavium patch.
This commit is contained in:
parent
360481a7b3
commit
d7cc62017d
@ -1,8 +1,22 @@
|
||||
commit c3ca7e011e7ad23df326d9817453674d1290fb1a
|
||||
Author: Stephane Eranian <eranian@gmail.com>
|
||||
Date: Tue Jun 12 08:26:53 2018 -0700
|
||||
|
||||
Fix Cavium Thunder X2 build issues
|
||||
|
||||
Release v4.10.0 had a few bugs related to Cavium Thunder X2 build.
|
||||
|
||||
- lib/Makefile dependency was pointing to the wrong Cavium Thunder X2 event file name
|
||||
- lib/Makefile was missing Cavium event file dependency for ARM64
|
||||
- lib/pfmlib_commmon.c was missing support for Cavium Thunder X2 in 32-bit mode
|
||||
|
||||
Signed-off-by: Stephane Eranian <eranian@gmail.com>
|
||||
|
||||
diff --git a/lib/Makefile b/lib/Makefile
|
||||
index 129db90..f1241ad 100644
|
||||
index 129db90..2eb3ebb 100644
|
||||
--- a/lib/Makefile
|
||||
+++ b/lib/Makefile
|
||||
@@ -360,7 +360,7 @@ INC_ARM=pfmlib_arm_priv.h \
|
||||
@@ -360,10 +360,11 @@ INC_ARM=pfmlib_arm_priv.h \
|
||||
events/arm_cortex_a15_events.h \
|
||||
events/arm_cortex_a57_events.h \
|
||||
events/arm_cortex_a53_events.h \
|
||||
@ -10,4 +24,21 @@ index 129db90..f1241ad 100644
|
||||
+ events/arm_cavium_tx2_events.h
|
||||
|
||||
INC_ARM64=events/arm_cortex_a57_events.h \
|
||||
events/arm_cortex_a53_events.h
|
||||
- events/arm_cortex_a53_events.h
|
||||
+ events/arm_cortex_a53_events.h \
|
||||
+ events/arm_cavium_tx2_events.h
|
||||
|
||||
INCDEP=$(INC_COMMON) $(INCARCH)
|
||||
|
||||
diff --git a/lib/pfmlib_common.c b/lib/pfmlib_common.c
|
||||
index f5bce8b..ca93d72 100644
|
||||
--- a/lib/pfmlib_common.c
|
||||
+++ b/lib/pfmlib_common.c
|
||||
@@ -482,6 +482,7 @@ static pfmlib_pmu_t *pfmlib_pmus[]=
|
||||
&arm_cortex_a57_support,
|
||||
&arm_cortex_a53_support,
|
||||
&arm_xgene_support,
|
||||
+ &arm_thunderx2_support,
|
||||
#endif
|
||||
#ifdef CONFIG_PFMLIB_ARCH_ARM64
|
||||
&arm_cortex_a57_support,
|
||||
|
@ -10,7 +10,7 @@
|
||||
|
||||
Name: libpfm
|
||||
Version: 4.10.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
|
||||
Summary: Library to encode performance events for use by perf tool
|
||||
|
||||
@ -119,6 +119,9 @@ make \
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jun 12 2018 William Cohen <wcohen@redhat.com> - 4.10.0-2
|
||||
- Use upstream libpfm cavium patch.
|
||||
|
||||
* Fri Jun 8 2018 William Cohen <wcohen@redhat.com> - 4.10.0-1
|
||||
- Rebase on libpfm-4.10.0.
|
||||
- Use Python 3.
|
||||
|
Loading…
Reference in New Issue
Block a user