60 lines
1.9 KiB
Diff
60 lines
1.9 KiB
Diff
From 8c7d89af16b943ce8746c2838277c7033967308f Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?V=C4=9Bra=20Cholasta?= <vbudikov@redhat.com>
|
|
Date: Wed, 17 Oct 2018 19:23:00 +0200
|
|
Subject: [PATCH] test-isodetect: continue after failure
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
https://bugzilla.redhat.com/show_bug.cgi?id=1639108
|
|
|
|
Reviewed-by: Fabiano Fidêncio <fidencio@redhat.com>
|
|
---
|
|
configure.ac | 4 ++--
|
|
tests/test-isodetect.c | 7 +++++--
|
|
2 files changed, 7 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index f7f1c72..c0917d4 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -37,8 +37,8 @@ m4_if(m4_version_compare([2.61a.100],
|
|
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
|
|
|
|
# Keep these two definitions in agreement.
|
|
-GLIB_MINIMUM_VERSION="2.36"
|
|
-GLIB_ENCODED_VERSION="GLIB_VERSION_2_36"
|
|
+GLIB_MINIMUM_VERSION="2.38"
|
|
+GLIB_ENCODED_VERSION="GLIB_VERSION_2_38"
|
|
|
|
PKG_CHECK_MODULES([LIBXML], [libxml-2.0 >= 2.6.0])
|
|
PKG_CHECK_MODULES([LIBXSLT], [libxslt >= 1.0.0])
|
|
diff --git a/tests/test-isodetect.c b/tests/test-isodetect.c
|
|
index b3834b9..b2a4e06 100644
|
|
--- a/tests/test-isodetect.c
|
|
+++ b/tests/test-isodetect.c
|
|
@@ -396,8 +396,10 @@ static void test_one(const gchar *vendor)
|
|
g_test_message("checking OS %s for ISO %s",
|
|
info->shortid, info->filename);
|
|
if (!matched) {
|
|
- g_error("ISO %s was not matched by OS %s",
|
|
- info->filename, info->shortid);
|
|
+ g_printerr("ISO %s was not matched by OS %s\n/isodetect/%s: ",
|
|
+ info->filename, info->shortid, vendor);
|
|
+ g_test_fail();
|
|
+ continue;
|
|
}
|
|
|
|
g_object_get(info->media, "os", &os, NULL);
|
|
@@ -417,6 +419,7 @@ int
|
|
main(int argc, char *argv[])
|
|
{
|
|
g_test_init(&argc, &argv, NULL);
|
|
+ g_test_set_nonfatal_assertions();
|
|
|
|
GList *vendors = load_vendors(NULL);
|
|
GList *it;
|
|
--
|
|
2.19.1
|
|
|