import libosinfo-1.2.0-5.el8

This commit is contained in:
CentOS Sources 2019-05-07 09:08:49 -04:00 committed by Andrew Lukoshko
commit d2d7d22254
7 changed files with 701 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/libosinfo-1.2.0.tar.gz

1
.libosinfo.metadata Normal file
View File

@ -0,0 +1 @@
e79bcc14f0506e75e8fd4a2845155d50dc493a85 SOURCES/libosinfo-1.2.0.tar.gz

View File

@ -0,0 +1,39 @@
From c458e1aa57e3c55b56afee699112fa35a3839ba9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?V=C4=9Bra=20Cholasta?= <vbudikov@redhat.com>
Date: Wed, 17 Oct 2018 19:22:59 +0200
Subject: [PATCH] test-isodetect: replace while loop with for loop
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Reviewed-by: Fabiano Fidêncio <fidencio@redhat.com>
---
tests/test-isodetect.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/tests/test-isodetect.c b/tests/test-isodetect.c
index 415770b..b3834b9 100644
--- a/tests/test-isodetect.c
+++ b/tests/test-isodetect.c
@@ -388,8 +388,7 @@ static void test_one(const gchar *vendor)
g_assert_nonnull(isos);
- tmp = isos;
- while (tmp) {
+ for (tmp = isos; tmp; tmp = tmp->next) {
struct ISOInfo *info = tmp->data;
gboolean matched = osinfo_db_identify_media(db, info->media);
OsinfoOs *os;
@@ -406,8 +405,6 @@ static void test_one(const gchar *vendor)
g_assert_cmpstr(shortid, ==, info->shortid);
g_object_unref(G_OBJECT(os));
test_langs(info);
-
- tmp = tmp->next;
}
g_list_foreach(isos, (GFunc)free_iso, NULL);
--
2.19.1

View File

@ -0,0 +1,59 @@
From 8c7d89af16b943ce8746c2838277c7033967308f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?V=C4=9Bra=20Cholasta?= <vbudikov@redhat.com>
Date: Wed, 17 Oct 2018 19:23:00 +0200
Subject: [PATCH] test-isodetect: continue after failure
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
https://bugzilla.redhat.com/show_bug.cgi?id=1639108
Reviewed-by: Fabiano Fidêncio <fidencio@redhat.com>
---
configure.ac | 4 ++--
tests/test-isodetect.c | 7 +++++--
2 files changed, 7 insertions(+), 4 deletions(-)
diff --git a/configure.ac b/configure.ac
index f7f1c72..c0917d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,8 +37,8 @@ m4_if(m4_version_compare([2.61a.100],
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
# Keep these two definitions in agreement.
-GLIB_MINIMUM_VERSION="2.36"
-GLIB_ENCODED_VERSION="GLIB_VERSION_2_36"
+GLIB_MINIMUM_VERSION="2.38"
+GLIB_ENCODED_VERSION="GLIB_VERSION_2_38"
PKG_CHECK_MODULES([LIBXML], [libxml-2.0 >= 2.6.0])
PKG_CHECK_MODULES([LIBXSLT], [libxslt >= 1.0.0])
diff --git a/tests/test-isodetect.c b/tests/test-isodetect.c
index b3834b9..b2a4e06 100644
--- a/tests/test-isodetect.c
+++ b/tests/test-isodetect.c
@@ -396,8 +396,10 @@ static void test_one(const gchar *vendor)
g_test_message("checking OS %s for ISO %s",
info->shortid, info->filename);
if (!matched) {
- g_error("ISO %s was not matched by OS %s",
- info->filename, info->shortid);
+ g_printerr("ISO %s was not matched by OS %s\n/isodetect/%s: ",
+ info->filename, info->shortid, vendor);
+ g_test_fail();
+ continue;
}
g_object_get(info->media, "os", &os, NULL);
@@ -417,6 +419,7 @@ int
main(int argc, char *argv[])
{
g_test_init(&argc, &argv, NULL);
+ g_test_set_nonfatal_assertions();
GList *vendors = load_vendors(NULL);
GList *it;
--
2.19.1

View File

@ -0,0 +1,43 @@
From 9ac796a5476d9973376fbea9d49876ddc1c7008c Mon Sep 17 00:00:00 2001
From: Vera Cholasta <vbudikov@redhat.com>
Date: Thu, 8 Nov 2018 20:51:19 +0100
Subject: [PATCH] tests: continue after failure in mediauris & treeuris
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
https://bugzilla.redhat.com/show_bug.cgi?id=1639108
Reviewed-by: Fabiano Fidêncio <fidencio@redhat.com>
---
tests/test-mediauris.c | 1 +
tests/test-treeuris.c | 1 +
2 files changed, 2 insertions(+)
diff --git a/tests/test-mediauris.c b/tests/test-mediauris.c
index 4bf8ead..811b57f 100644
--- a/tests/test-mediauris.c
+++ b/tests/test-mediauris.c
@@ -116,6 +116,7 @@ main(int argc, char *argv[])
int ret;
g_test_init(&argc, &argv, NULL);
+ g_test_set_nonfatal_assertions();
g_test_add_func("/mediauris/uris", test_uris);
diff --git a/tests/test-treeuris.c b/tests/test-treeuris.c
index 2b37bfb..bba3aa0 100644
--- a/tests/test-treeuris.c
+++ b/tests/test-treeuris.c
@@ -116,6 +116,7 @@ main(int argc, char *argv[])
int ret;
g_test_init(&argc, &argv, NULL);
+ g_test_set_nonfatal_assertions();
g_test_add_func("/treeuris/uris", test_uris);
--
2.19.1

View File

@ -0,0 +1,286 @@
From b5274811ca21ed3ff672a3530a0d78e9d034d77b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Fabiano=20Fid=C3=AAncio?= <fidencio@redhat.com>
Date: Thu, 15 Nov 2018 16:13:31 +0100
Subject: [PATCH] rhel: Add rhel8.0 isodata
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Fabiano Fidêncio <fidencio@redhat.com>
Reviewed-by: Christophe Fergeau <cfergeau@redhat.com>
---
.../RHEL-8.0-20181113.1-aarch64-boot.iso.txt | 29 +++++++++++++++++++
.../RHEL-8.0-20181113.1-aarch64-dvd1.iso.txt | 29 +++++++++++++++++++
.../RHEL-8.0-20181113.1-ppc64le-boot.iso.txt | 16 ++++++++++
.../RHEL-8.0-20181113.1-ppc64le-dvd1.iso.txt | 16 ++++++++++
.../RHEL-8.0-20181113.1-s390x-boot.iso.txt | 29 +++++++++++++++++++
.../RHEL-8.0-20181113.1-s390x-dvd1.iso.txt | 29 +++++++++++++++++++
.../RHEL-8.0-20181113.1-x86_64-boot.iso.txt | 29 +++++++++++++++++++
.../RHEL-8.0-20181113.1-x86_64-dvd1.iso.txt | 29 +++++++++++++++++++
8 files changed, 206 insertions(+)
create mode 100644 tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-aarch64-boot.iso.txt
create mode 100644 tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-aarch64-dvd1.iso.txt
create mode 100644 tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-ppc64le-boot.iso.txt
create mode 100644 tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-ppc64le-dvd1.iso.txt
create mode 100644 tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-s390x-boot.iso.txt
create mode 100644 tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-s390x-dvd1.iso.txt
create mode 100644 tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-x86_64-boot.iso.txt
create mode 100644 tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-x86_64-dvd1.iso.txt
diff --git a/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-aarch64-boot.iso.txt b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-aarch64-boot.iso.txt
new file mode 100644
index 0000000..b1b7cba
--- /dev/null
+++ b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-aarch64-boot.iso.txt
@@ -0,0 +1,29 @@
+CD-ROM is in ISO 9660 format
+System id: LINUX
+Volume id: RHEL-8-0-BaseOS-aarch64
+Volume set id:
+Publisher id:
+Data preparer id:
+Application id: GENISOIMAGE ISO 9660/HFS FILESYSTEM CREATOR (C) 1993 E.YOUNGDALE (C) 1997-2006 J.PEARSON/J.SCHILLING (C) 2006-2007 CDRKIT TEAM
+Copyright File id:
+Abstract File id:
+Bibliographic File id:
+Volume set size is: 1
+Volume set sequence number is: 1
+Logical block size is: 2048
+Volume size is: 256972
+El Torito VD version 1 found, boot catalog is in sector 42
+Joliet with UCS level 3 found
+Rock Ridge signatures version 1 found
+Eltorito validation header:
+ Hid 1
+ Arch 239 (Unknown Arch)
+ ID ''
+ Key 55 AA
+ Eltorito defaultboot header:
+ Bootid 88 (bootable)
+ Boot media 0 (No Emulation Boot)
+ Load segment 0
+ Sys type 0
+ Nsect 32D0
+ Bootoff 2C 44
diff --git a/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-aarch64-dvd1.iso.txt b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-aarch64-dvd1.iso.txt
new file mode 100644
index 0000000..ce01c02
--- /dev/null
+++ b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-aarch64-dvd1.iso.txt
@@ -0,0 +1,29 @@
+CD-ROM is in ISO 9660 format
+System id: LINUX
+Volume id: RHEL-8-0-BaseOS-aarch64
+Volume set id:
+Publisher id:
+Data preparer id:
+Application id: GENISOIMAGE ISO 9660/HFS FILESYSTEM CREATOR (C) 1993 E.YOUNGDALE (C) 1997-2006 J.PEARSON/J.SCHILLING (C) 2006-2007 CDRKIT TEAM
+Copyright File id:
+Abstract File id:
+Bibliographic File id:
+Volume set size is: 1
+Volume set sequence number is: 1
+Logical block size is: 2048
+Volume size is: 2867727
+El Torito VD version 1 found, boot catalog is in sector 847
+Joliet with UCS level 3 found
+Rock Ridge signatures version 1 found
+Eltorito validation header:
+ Hid 1
+ Arch 239 (Unknown Arch)
+ ID ''
+ Key 55 AA
+ Eltorito defaultboot header:
+ Bootid 88 (bootable)
+ Boot media 0 (No Emulation Boot)
+ Load segment 0
+ Sys type 0
+ Nsect 32D0
+ Bootoff F08 3848
diff --git a/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-ppc64le-boot.iso.txt b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-ppc64le-boot.iso.txt
new file mode 100644
index 0000000..ccf738a
--- /dev/null
+++ b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-ppc64le-boot.iso.txt
@@ -0,0 +1,16 @@
+CD-ROM is in ISO 9660 format
+System id: PPC
+Volume id: RHEL_8_0_BaseOS_ppc64le
+Volume set id: 8.0
+Publisher id:
+Data preparer id:
+Application id: Red Hat Enterprise Linux 8.0
+Copyright File id:
+Abstract File id:
+Bibliographic File id:
+Volume set size is: 1
+Volume set sequence number is: 1
+Logical block size is: 2048
+Volume size is: 279805
+Joliet with UCS level 3 found
+Rock Ridge signatures version 1 found
diff --git a/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-ppc64le-dvd1.iso.txt b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-ppc64le-dvd1.iso.txt
new file mode 100644
index 0000000..1eb781b
--- /dev/null
+++ b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-ppc64le-dvd1.iso.txt
@@ -0,0 +1,16 @@
+CD-ROM is in ISO 9660 format
+System id: PPC
+Volume id: RHEL-8-0-BaseOS-ppc64le
+Volume set id:
+Publisher id:
+Data preparer id:
+Application id: GENISOIMAGE ISO 9660/HFS FILESYSTEM CREATOR (C) 1993 E.YOUNGDALE (C) 1997-2006 J.PEARSON/J.SCHILLING (C) 2006-2007 CDRKIT TEAM
+Copyright File id:
+Abstract File id:
+Bibliographic File id:
+Volume set size is: 1
+Volume set sequence number is: 1
+Logical block size is: 2048
+Volume size is: 3073014
+Joliet with UCS level 3 found
+Rock Ridge signatures version 1 found
diff --git a/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-s390x-boot.iso.txt b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-s390x-boot.iso.txt
new file mode 100644
index 0000000..2014004
--- /dev/null
+++ b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-s390x-boot.iso.txt
@@ -0,0 +1,29 @@
+CD-ROM is in ISO 9660 format
+System id: LINUX
+Volume id: RHEL-8-0-BaseOS-s390x
+Volume set id:
+Publisher id:
+Data preparer id:
+Application id: GENISOIMAGE ISO 9660/HFS FILESYSTEM CREATOR (C) 1993 E.YOUNGDALE (C) 1997-2006 J.PEARSON/J.SCHILLING (C) 2006-2007 CDRKIT TEAM
+Copyright File id:
+Abstract File id:
+Bibliographic File id:
+Volume set size is: 1
+Volume set sequence number is: 1
+Logical block size is: 2048
+Volume size is: 237307
+El Torito VD version 1 found, boot catalog is in sector 34
+Joliet with UCS level 3 found
+Rock Ridge signatures version 1 found
+Eltorito validation header:
+ Hid 1
+ Arch 0 (x86)
+ ID ''
+ Key 55 AA
+ Eltorito defaultboot header:
+ Bootid 88 (bootable)
+ Boot media 0 (No Emulation Boot)
+ Load segment 0
+ Sys type 0
+ Nsect 4
+ Bootoff 23 35
diff --git a/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-s390x-dvd1.iso.txt b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-s390x-dvd1.iso.txt
new file mode 100644
index 0000000..d00ccfb
--- /dev/null
+++ b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-s390x-dvd1.iso.txt
@@ -0,0 +1,29 @@
+CD-ROM is in ISO 9660 format
+System id: LINUX
+Volume id: RHEL-8-0-BaseOS-s390x
+Volume set id:
+Publisher id:
+Data preparer id:
+Application id: GENISOIMAGE ISO 9660/HFS FILESYSTEM CREATOR (C) 1993 E.YOUNGDALE (C) 1997-2006 J.PEARSON/J.SCHILLING (C) 2006-2007 CDRKIT TEAM
+Copyright File id:
+Abstract File id:
+Bibliographic File id:
+Volume set size is: 1
+Volume set sequence number is: 1
+Logical block size is: 2048
+Volume size is: 2746748
+El Torito VD version 1 found, boot catalog is in sector 815
+Joliet with UCS level 3 found
+Rock Ridge signatures version 1 found
+Eltorito validation header:
+ Hid 1
+ Arch 0 (x86)
+ ID ''
+ Key 55 AA
+ Eltorito defaultboot header:
+ Bootid 88 (bootable)
+ Boot media 0 (No Emulation Boot)
+ Load segment 0
+ Sys type 0
+ Nsect 73DC
+ Bootoff 335 821
diff --git a/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-x86_64-boot.iso.txt b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-x86_64-boot.iso.txt
new file mode 100644
index 0000000..07a61b8
--- /dev/null
+++ b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-x86_64-boot.iso.txt
@@ -0,0 +1,29 @@
+CD-ROM is in ISO 9660 format
+System id: LINUX
+Volume id: RHEL-8-0-BaseOS-x86_64
+Volume set id:
+Publisher id:
+Data preparer id:
+Application id: GENISOIMAGE ISO 9660/HFS FILESYSTEM CREATOR (C) 1993 E.YOUNGDALE (C) 1997-2006 J.PEARSON/J.SCHILLING (C) 2006-2007 CDRKIT TEAM
+Copyright File id:
+Abstract File id:
+Bibliographic File id:
+Volume set size is: 1
+Volume set sequence number is: 1
+Logical block size is: 2048
+Volume size is: 276128
+El Torito VD version 1 found, boot catalog is in sector 44
+Joliet with UCS level 3 found
+Rock Ridge signatures version 1 found
+Eltorito validation header:
+ Hid 1
+ Arch 0 (x86)
+ ID ''
+ Key 55 AA
+ Eltorito defaultboot header:
+ Bootid 88 (bootable)
+ Boot media 0 (No Emulation Boot)
+ Load segment 0
+ Sys type 0
+ Nsect 4
+ Bootoff 4227F 270975
diff --git a/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-x86_64-dvd1.iso.txt b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-x86_64-dvd1.iso.txt
new file mode 100644
index 0000000..e53b2aa
--- /dev/null
+++ b/tests/isodata/rhel/rhel8.0/RHEL-8.0-20181113.1-x86_64-dvd1.iso.txt
@@ -0,0 +1,29 @@
+CD-ROM is in ISO 9660 format
+System id: LINUX
+Volume id: RHEL-8-0-BaseOS-x86_64
+Volume set id:
+Publisher id:
+Data preparer id:
+Application id: GENISOIMAGE ISO 9660/HFS FILESYSTEM CREATOR (C) 1993 E.YOUNGDALE (C) 1997-2006 J.PEARSON/J.SCHILLING (C) 2006-2007 CDRKIT TEAM
+Copyright File id:
+Abstract File id:
+Bibliographic File id:
+Volume set size is: 1
+Volume set sequence number is: 1
+Logical block size is: 2048
+Volume size is: 3400439
+El Torito VD version 1 found, boot catalog is in sector 1028
+Joliet with UCS level 3 found
+Rock Ridge signatures version 1 found
+Eltorito validation header:
+ Hid 1
+ Arch 0 (x86)
+ ID ''
+ Key 55 AA
+ Eltorito defaultboot header:
+ Bootid 88 (bootable)
+ Boot media 0 (No Emulation Boot)
+ Load segment 0
+ Sys type 0
+ Nsect 4
+ Bootoff 438C9 276681
--
2.19.1

272
SPECS/libosinfo.spec Normal file
View File

@ -0,0 +1,272 @@
# -*- rpm-spec -*-
Summary: A library for managing OS information for virtualization
Name: libosinfo
Version: 1.2.0
Release: 5%{?dist}%{?extra_release}
License: LGPLv2+
Group: Development/Libraries
Source: https://releases.pagure.io/%{name}/%{name}-%{version}.tar.gz
URL: https://libosinfo.org/
### Patches ###
Patch0001: 0001-test-isodetect-replace-while-loop-with-for-loop.patch
Patch0002: 0002-test-isodetect-continue-after-failure.patch
Patch0003: 0003-tests-continue-after-failure-in-mediauris-treeuris.patch
Patch0004: 0004-rhel-Add-rhel8.0-isodata.patch
BuildRequires: intltool
BuildRequires: glib2-devel >= 2.38
BuildRequires: libxml2-devel >= 2.6.0
BuildRequires: libxslt-devel >= 1.0.0
BuildRequires: vala
BuildRequires: vala-tools
BuildRequires: libcurl-devel
BuildRequires: /usr/bin/pod2man
BuildRequires: hwdata
BuildRequires: gobject-introspection-devel
BuildRequires: osinfo-db >= 20181011-7
Requires: hwdata
Requires: osinfo-db >= 20181011-1
Requires: osinfo-db-tools
%description
libosinfo is a library that allows virtualization provisioning tools to
determine the optimal device settings for a hypervisor/operating system
combination.
%package devel
Summary: Libraries, includes, etc. to compile with the libosinfo library
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: pkgconfig
Requires: glib2-devel
%description devel
libosinfo is a library that allows virtualization provisioning tools to
determine the optimal device settings for a hypervisor/operating system
combination.
Libraries, includes, etc. to compile with the libosinfo library
%package vala
Summary: Vala bindings
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%description vala
libosinfo is a library that allows virtualization provisioning tools to
determine the optimal device settings for a hypervisor/operating system
combination.
This package provides the Vala bindings for libosinfo library.
%prep
%setup -q
for p in %patches ; do
%__patch -p1 -i $p
done
%build
autoreconf -vi
%configure --enable-introspection=yes --enable-vala=yes
%__make %{?_smp_mflags} V=1
chmod a-x examples/*.js examples/*.py
%install
rm -fr %{buildroot}
%__make install DESTDIR=%{buildroot}
rm -f %{buildroot}%{_libdir}/*.a
rm -f %{buildroot}%{_libdir}/*.la
%find_lang %{name}
%check
if ! make check
then
cat tests/test-suite.log || true
exit 1
fi
%ldconfig_scriptlets
%files -f %{name}.lang
%defattr(-, root, root)
%doc AUTHORS ChangeLog COPYING.LIB NEWS README
%{_bindir}/osinfo-detect
%{_bindir}/osinfo-query
%{_bindir}/osinfo-install-script
%{_mandir}/man1/osinfo-detect.1*
%{_mandir}/man1/osinfo-query.1*
%{_mandir}/man1/osinfo-install-script.1*
%{_libdir}/%{name}-1.0.so.*
%{_libdir}/girepository-1.0/Libosinfo-1.0.typelib
%files devel
%defattr(-, root, root)
%doc examples/demo.js
%doc examples/demo.py
%{_libdir}/%{name}-1.0.so
%dir %{_includedir}/%{name}-1.0/
%dir %{_includedir}/%{name}-1.0/osinfo/
%{_includedir}/%{name}-1.0/osinfo/*.h
%{_libdir}/pkgconfig/%{name}-1.0.pc
%{_datadir}/gir-1.0/Libosinfo-1.0.gir
%{_datadir}/gtk-doc/html/Libosinfo
%files vala
%defattr(-, root, root)
%{_datadir}/vala/vapi/libosinfo-1.0.vapi
%changelog
* Fri Nov 30 2018 Fabiano Fidêncio <fidencio@redhat.com> - 1.2.0-5
- Related: rhbz#1650197 - Fix volume-ids for rhel8.0 entry
* Wed Nov 14 2018 Fabiano Fidêncio <fidencio@redhat.com> - 1.2.0-4
- Resolves: rhbz#1649632 - libosinfo test suite should collect+report all
failures, not exit on first error
* Mon Oct 08 2018 Fabiano Fidêncio <fidencio@redhat.com> - 1.2.0-3
- Related: rhbz#1628027 - Revert ca945cdf04f
* Fri Sep 21 2018 Fabiano Fidêncio <fidencio@redhat.com> - 1.2.0-2
- Resolves: rhbz#1628027 - Force anchored patterns when matching regex
* Wed Jun 20 2018 Daniel P. Berrangé <berrange@redhat.com> - 1.2.0-1
- Update to 1.2.0 release
* Tue Feb 06 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.1.0-2
- Switch to %%ldconfig_scriptlets
* Tue Aug 15 2017 Daniel P. Berrange <berrange@redhat.com> 1.1.0-1
- New upstream release 1.1.0
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Fri Oct 7 2016 Daniel P. Berrange <berrange@redhat.com> 1.0.0-1
- New upstream release 1.0.0
* Fri Jul 1 2016 Daniel P. Berrange <berrange@redhat.com> 0.3.1-1
- New upstream release 0.3.1
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Fri Jan 8 2016 Zeeshan Ali <zeenix@redhat.com> 0.3.0-1
- New upstream release 0.3.0
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.12-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Thu May 28 2015 Zeeshan Ali <zeenix@redhat.com> 0.2.12-1
- New upstream release 0.2.12
* Mon Sep 22 2014 Cole Robinson <crobinso@redhat.com> - 0.2.11-2
- os: Add Fedora 21
* Tue Aug 26 2014 Christophe Fergeau <cfergeau@redhat.com> 0.2.11-1
- New upstream release 0.2.11
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.9-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Tue Jul 22 2014 Kalev Lember <kalevlember@gmail.com> - 0.2.9-3
- Rebuilt for gobject-introspection 1.41.4
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Wed Dec 18 2013 Debarshi Ray <rishi@fedoraproject.org> - 0.2.9-1
- New upstream release 0.2.9
* Thu Nov 28 2013 Zeeshan Ali <zeenix@redhat.com> - 0.2.8-1
- New upstream release 0.2.8
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Tue May 14 2013 Zeeshan Ali <zeenix@redhat.com> - 0.2.7-1
- New upstream release 0.2.7
* Thu Mar 21 2013 Zeeshan Ali <zeenix@redhat.com> - 0.2.6-1
- New upstream release 0.2.6
* Wed Mar 06 2013 Christophe Fergeau <cfergeau@redhat.com> - 0.2.5-2
- BuildRequires /usr/bin/pod2man as this will automatically pick the right
package rather than conditionally requiring a package that is only
available in f19+
- Do not Requires: udev when building libosinfo without its udev rule
(which is done on f19+)
* Tue Mar 05 2013 Christophe Fergeau <cfergeau@redhat.com> 0.2.5-1
- New upstream release 0.2.5
- Disable udev rule as it's no longer required with newer
systemd/util-linux
* Tue Feb 12 2013 Cole Robinson <crobinso@redhat.com> - 0.2.3-2
- Fix osinfo-detect crash with non-bootable media (bz #901910)
* Mon Jan 14 2013 Zeeshan Ali <zeenix@redhat.com> - 0.2.3-1
- New upstream release 0.2.3
* Thu Dec 20 2012 Christophe Fergeau <cfergeau@redhat.com> - 0.2.2-1
- New upstream release 0.2.2
* Fri Oct 12 2012 Zeeshan Ali <zeenix@redhat.com> - 0.2.1-1
- Fix and simplify udev rule.
- Fedora:
- Fix minimum RAM requirements for F16 and F17.
- Add data on:
- Fedora 18
- GNOME 3.6
- Ubuntu 12.10
- Fixes to doc build.
- Install script:
- Add get_config_param method.
- Differenciate between expected/output script names.
- Add more utility functions.
- Add 'installer-reboots' parameter to medias.
- osinfo-detect does not die of DB loading errors anymore.
- More type-specific entity value getters/setters.
- Fixe and update RNG file.
- Add 'subsystem' property/attribute to devices.
* Mon Sep 03 2012 Christophe Fergeau <cfergeau@redhat.com> - 0.2.0-1
- Update to 0.2.0 release.
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Tue Jun 12 2012 Zeeshan Ali <zeenix@redhat.com> - 0.1.2-1
- Update to 0.1.2 release.
* Thu Apr 12 2012 Zeeshan Ali <zeenix@redhat.com> - 0.1.1-1
- Update to 0.1.1 release.
* Wed Mar 14 2012 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-2
- Remove obsolete perl based scripts (rhbz #803086)
* Wed Feb 08 2012 Christophe Fergeau <cfergeau@redhat.com> - 0.1.0-1
- Update to 0.1.0 release
* Tue Jan 17 2012 Zeeshan Ali <zeenix@redhat.com> - 0.0.5-1
- Update to 0.0.5 release
* Tue Jan 3 2012 Daniel P. Berrange <berrange@redhat.com> - 0.0.4-2
- Remove pointless gir conditionals
* Wed Dec 21 2011 Daniel P. Berrange <berrange@redhat.com> - 0.0.4-1
- Update to 0.0.4 release
* Thu Nov 24 2011 Daniel P. Berrange <berrange@redhat.com> - 0.0.2-1
- Initial package