fix meta data for python package
This commit is contained in:
parent
e1be7a9da3
commit
c42a3ddece
32
0003-fix-python-meta-data.patch
Normal file
32
0003-fix-python-meta-data.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From 8d37b0184165ab2eece798c17146b290cfd3103c Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Haller <thaller@redhat.com>
|
||||
Date: Mon, 5 Jan 2015 12:12:25 +0100
|
||||
Subject: [PATCH 1/1] python: fix package meta data in setup.py
|
||||
|
||||
http://lists.infradead.org/pipermail/libnl/2015-January/001802.html
|
||||
|
||||
Acked-by: Thomas Graf <tgraf@suug.ch>
|
||||
Signed-off-by: Thomas Haller <thaller@redhat.com>
|
||||
(cherry picked from commit c7ae0c7d67d376bb8a3fbbe8e35a25de7e4c8ebd)
|
||||
---
|
||||
python/setup.py.in | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/python/setup.py.in b/python/setup.py.in
|
||||
index 346c770..0cd35d0 100644
|
||||
--- a/python/setup.py.in
|
||||
+++ b/python/setup.py.in
|
||||
@@ -35,6 +35,10 @@ setup(name = 'netlink',
|
||||
description = 'Python wrapper for netlink protocols',
|
||||
author = 'Thomas Graf',
|
||||
author_email = 'tgraf@suug.ch',
|
||||
+ url = 'http://www.infradead.org/~tgr/libnl/',
|
||||
+ license = 'LGPL 2',
|
||||
+ platforms = 'linux2',
|
||||
+ long_description = 'Experimental python bindings for libnl',
|
||||
ext_modules = [netlink_capi, route_capi, genl_capi],
|
||||
package_dir = {'': '@srcdir@'},
|
||||
packages = ['netlink', 'netlink.genl', 'netlink.route',
|
||||
--
|
||||
1.9.3
|
||||
|
@ -12,6 +12,7 @@ Source: http://www.infradead.org/~tgr/libnl/files/libnl-%{fullversion}.tar.gz
|
||||
Source1: http://www.infradead.org/~tgr/libnl/files/libnl-doc-%{fullversion}.tar.gz
|
||||
Patch1: 0001-link-inet6-add-support-for-tokenized-interface-ident.patch
|
||||
Patch2: 0002-i6-addr-gen-mode.patch
|
||||
Patch3: 0003-fix-python-meta-data.patch
|
||||
|
||||
BuildRequires: flex bison
|
||||
BuildRequires: python
|
||||
@ -53,6 +54,7 @@ This package contains libnl3 API documentation
|
||||
%setup -q -n libnl-%{fullversion}
|
||||
%patch1 -p1 -b .0001-link-inet6-add-support-for-tokenized-interface-ident.orig
|
||||
%patch2 -p1 -b .0002-i6-addr-gen-mode.orig
|
||||
%patch3 -p1 -b .0003-fix-python-meta-data.orig
|
||||
|
||||
tar -xzf %SOURCE1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user