33 lines
1.1 KiB
Diff
33 lines
1.1 KiB
Diff
From 8d37b0184165ab2eece798c17146b290cfd3103c Mon Sep 17 00:00:00 2001
|
|
From: Thomas Haller <thaller@redhat.com>
|
|
Date: Mon, 5 Jan 2015 12:12:25 +0100
|
|
Subject: [PATCH 1/1] python: fix package meta data in setup.py
|
|
|
|
http://lists.infradead.org/pipermail/libnl/2015-January/001802.html
|
|
|
|
Acked-by: Thomas Graf <tgraf@suug.ch>
|
|
Signed-off-by: Thomas Haller <thaller@redhat.com>
|
|
(cherry picked from commit c7ae0c7d67d376bb8a3fbbe8e35a25de7e4c8ebd)
|
|
---
|
|
python/setup.py.in | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/python/setup.py.in b/python/setup.py.in
|
|
index 346c770..0cd35d0 100644
|
|
--- a/python/setup.py.in
|
|
+++ b/python/setup.py.in
|
|
@@ -35,6 +35,10 @@ setup(name = 'netlink',
|
|
description = 'Python wrapper for netlink protocols',
|
|
author = 'Thomas Graf',
|
|
author_email = 'tgraf@suug.ch',
|
|
+ url = 'http://www.infradead.org/~tgr/libnl/',
|
|
+ license = 'LGPL 2',
|
|
+ platforms = 'linux2',
|
|
+ long_description = 'Experimental python bindings for libnl',
|
|
ext_modules = [netlink_capi, route_capi, genl_capi],
|
|
package_dir = {'': '@srcdir@'},
|
|
packages = ['netlink', 'netlink.genl', 'netlink.route',
|
|
--
|
|
1.9.3
|
|
|