Update to 0.1.16
This commit is contained in:
parent
279d176c5f
commit
cf9b3c494c
@ -1,54 +0,0 @@
|
|||||||
From a38c2adfc4bed2a69dc02568417f0926dd555b9a Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Olivier=20Cr=C3=AAte?= <olivier.crete@collabora.com>
|
|
||||||
Date: Thu, 3 Jan 2019 14:58:44 -0500
|
|
||||||
Subject: [PATCH] tests/test-different-number-streams: Make it work with only
|
|
||||||
localhost
|
|
||||||
|
|
||||||
---
|
|
||||||
tests/test-different-number-streams.c | 10 ++++++++++
|
|
||||||
1 file changed, 10 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/tests/test-different-number-streams.c b/tests/test-different-number-streams.c
|
|
||||||
index 7fd4763..b53b167 100644
|
|
||||||
--- a/tests/test-different-number-streams.c
|
|
||||||
+++ b/tests/test-different-number-streams.c
|
|
||||||
@@ -73,6 +73,8 @@ int main (void)
|
|
||||||
guint ls_id, rs_id_1, rs_id_2;
|
|
||||||
gchar *lufrag = NULL, *lpassword = NULL;
|
|
||||||
gchar *rufrag1 = NULL, *rpassword1 = NULL, *rufrag2 = NULL, *rpassword2 = NULL;
|
|
||||||
+ NiceAddress *addr;
|
|
||||||
+
|
|
||||||
|
|
||||||
#ifdef G_OS_WIN32
|
|
||||||
WSADATA w;
|
|
||||||
@@ -80,12 +82,18 @@ int main (void)
|
|
||||||
WSAStartup(0x0202, &w);
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+ /* Initialize nice agents */
|
|
||||||
+ addr = nice_address_new ();
|
|
||||||
+ nice_address_set_from_string (addr, "127.0.0.1");
|
|
||||||
+
|
|
||||||
global_mainloop = g_main_loop_new (NULL, FALSE);
|
|
||||||
|
|
||||||
/* step: create the agents L and R */
|
|
||||||
lagent = nice_agent_new (g_main_loop_get_context (global_mainloop),
|
|
||||||
NICE_COMPATIBILITY_GOOGLE);
|
|
||||||
g_debug ("lagent: %p", lagent);
|
|
||||||
+
|
|
||||||
+ nice_agent_add_local_address (lagent, addr);
|
|
||||||
nice_agent_set_software (lagent, "test-different-number-streams, Left Agent");
|
|
||||||
g_object_set (G_OBJECT (lagent), "ice-tcp", FALSE, NULL);
|
|
||||||
g_object_set (G_OBJECT (lagent), "controlling-mode", TRUE, NULL);
|
|
||||||
@@ -98,6 +106,8 @@ int main (void)
|
|
||||||
ragent = nice_agent_new (g_main_loop_get_context (global_mainloop),
|
|
||||||
NICE_COMPATIBILITY_GOOGLE);
|
|
||||||
g_debug ("ragent: %p", ragent);
|
|
||||||
+
|
|
||||||
+ nice_agent_add_local_address (ragent, addr);
|
|
||||||
nice_agent_set_software (ragent, "test-different-number-streams, Right Agent");
|
|
||||||
g_object_set (G_OBJECT (ragent), "ice-tcp", FALSE, NULL);
|
|
||||||
g_object_set (G_OBJECT (ragent), "controlling-mode", FALSE, NULL);
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
10
libnice.spec
10
libnice.spec
@ -2,7 +2,7 @@
|
|||||||
%bcond_with gst010
|
%bcond_with gst010
|
||||||
|
|
||||||
Name: libnice
|
Name: libnice
|
||||||
Version: 0.1.15
|
Version: 0.1.16
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: GLib ICE implementation
|
Summary: GLib ICE implementation
|
||||||
|
|
||||||
@ -13,9 +13,6 @@ Source0: https://nice.freedesktop.org/releases/%{name}-%{version}.tar.gz
|
|||||||
# make tests pass in Koji
|
# make tests pass in Koji
|
||||||
Patch1: libnice-0.1.14-tests-koji.patch
|
Patch1: libnice-0.1.14-tests-koji.patch
|
||||||
|
|
||||||
# upstream fix to make tests/test-different-number-streams pass
|
|
||||||
Patch2: libnice-0.1.15-tests-fix-different-number-streams.patch
|
|
||||||
|
|
||||||
BuildRequires: glib2-devel
|
BuildRequires: glib2-devel
|
||||||
BuildRequires: gnutls-devel >= 2.12.0
|
BuildRequires: gnutls-devel >= 2.12.0
|
||||||
BuildRequires: gobject-introspection-devel
|
BuildRequires: gobject-introspection-devel
|
||||||
@ -69,7 +66,6 @@ developing applications that use %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
|
||||||
chmod 0755 scripts/valgrind-test-driver
|
chmod 0755 scripts/valgrind-test-driver
|
||||||
|
|
||||||
# disable test-new-dribble, which sometimes hangs indefinitely, and
|
# disable test-new-dribble, which sometimes hangs indefinitely, and
|
||||||
@ -137,6 +133,10 @@ make check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 10 2019 Stefan Becker <chemobejk@gmail.com> - 0.1.16-1
|
||||||
|
- Update to 0.1.16
|
||||||
|
- drop all upstream patches
|
||||||
|
|
||||||
* Thu May 09 2019 Stefan Becker <chemobejk@gmail.com> - 0.1.15-1
|
* Thu May 09 2019 Stefan Becker <chemobejk@gmail.com> - 0.1.15-1
|
||||||
- Update to 0.1.15
|
- Update to 0.1.15
|
||||||
- drop all upstream patches
|
- drop all upstream patches
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libnice-0.1.15.tar.gz) = 60a8bcca06c0ab300dfabbf13e45aeac2085d553c420c5cc4d2fdeb46b449b2b9c9aee8015b0662c16bd1cecf5a49824b7e24951a8a0b66a87074cb00a619c0c
|
SHA512 (libnice-0.1.16.tar.gz) = 8fdf0f9fcf43c0fdffbdcb61988a7f9e14bd13bb1bc561d2b9faf493deb18151da14d484740571a302fa203ec7109d45c361ea791e81a2b29932a26220ce902c
|
||||||
|
Loading…
Reference in New Issue
Block a user