Update to 0.1.15

This commit is contained in:
Stefan Becker 2019-05-09 18:44:49 +03:00 committed by Kamil Dudka
parent 6d6e2d0323
commit 279d176c5f
6 changed files with 66 additions and 12063 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1,48 +0,0 @@
From 3f8364b41207d8c26d3d3be518a7d9ebf4243b92 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Fri, 9 Feb 2018 18:01:57 +0100
Subject: [PATCH] tests: make them compile on i686
---
tests/test-pseudotcp-fuzzy.c | 4 ++--
tests/test-pseudotcp.c | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/tests/test-pseudotcp-fuzzy.c b/tests/test-pseudotcp-fuzzy.c
index 4a714e6..030c03f 100644
--- a/tests/test-pseudotcp-fuzzy.c
+++ b/tests/test-pseudotcp-fuzzy.c
@@ -129,7 +129,7 @@ write_to_sock (PseudoTcpSocket *sock)
total += wlen;
total_read += wlen;
if (wlen < (gint) len) {
- g_debug ("seeking %ld from %lu", wlen - len, ftell (in));
+ g_debug ("seeking %ld from %lu", (long) wlen - len, ftell (in));
fseek (in, wlen - len, SEEK_CUR);
g_assert (!feof (in));
g_debug ("Socket queue full after %d bytes written", total);
@@ -355,7 +355,7 @@ static void adjust_clock (PseudoTcpSocket *sock)
if (pseudo_tcp_socket_get_next_clock (sock, &timeout)) {
timeout -= g_get_monotonic_time () / 1000;
- g_debug ("Socket %p: Adjusting clock to %ld ms", sock, timeout);
+ g_debug ("Socket %p: Adjusting clock to %ld ms", sock, (long) timeout);
if (sock == left) {
if (left_clock != 0)
g_source_remove (left_clock);
diff --git a/tests/test-pseudotcp.c b/tests/test-pseudotcp.c
index 1a8391a..584a0d0 100644
--- a/tests/test-pseudotcp.c
+++ b/tests/test-pseudotcp.c
@@ -81,7 +81,7 @@ static void write_to_sock (PseudoTcpSocket *sock)
total += wlen;
total_read += wlen;
if (wlen < (gint) len) {
- g_debug ("seeking %ld from %lu", wlen - len, ftell (in));
+ g_debug ("seeking %ld from %lu", (long) wlen - len, ftell (in));
fseek (in, wlen - len, SEEK_CUR);
g_assert (!feof (in));
g_debug ("Socket queue full after %d bytes written", total);
--
2.13.6

View File

@ -1,32 +0,0 @@
From e4d92bf96d0bb64df35790e5b49c58bfa6e9fbcc Mon Sep 17 00:00:00 2001
From: Jakub Adam <jakub.adam@ktknet.cz>
Date: Thu, 20 Apr 2017 06:47:00 +0200
Subject: [PATCH] component: accept TURN in
nice_component_verify_remote_candidate()
When TURN is in operation, agent_recv_message_unlocked() may receive from
NiceSocket with type = NICE_SOCKET_TYPE_UDP_TURN. Such messages were always
dropped due to failed nice_component_verify_remote_candidate().
Bug: https://phabricator.freedesktop.org/D1727
---
agent/component.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/agent/component.c b/agent/component.c
index 6eee90e..3e8a7a6 100644
--- a/agent/component.c
+++ b/agent/component.c
@@ -1510,7 +1510,8 @@ nice_component_verify_remote_candidate (NiceComponent *component,
(cand->transport == NICE_CANDIDATE_TRANSPORT_TCP_ACTIVE ||
cand->transport == NICE_CANDIDATE_TRANSPORT_TCP_PASSIVE ||
cand->transport == NICE_CANDIDATE_TRANSPORT_TCP_SO)) ||
- cand->transport == NICE_CANDIDATE_TRANSPORT_UDP) &&
+ cand->transport == NICE_CANDIDATE_TRANSPORT_UDP ||
+ nicesock->type == NICE_SOCKET_TYPE_UDP_TURN) &&
nice_address_equal (address, &cand->addr)) {
/* fast return if it's already the first */
if (item == component->valid_candidates)
--
2.14.3

View File

@ -0,0 +1,54 @@
From a38c2adfc4bed2a69dc02568417f0926dd555b9a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Olivier=20Cr=C3=AAte?= <olivier.crete@collabora.com>
Date: Thu, 3 Jan 2019 14:58:44 -0500
Subject: [PATCH] tests/test-different-number-streams: Make it work with only
localhost
---
tests/test-different-number-streams.c | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/tests/test-different-number-streams.c b/tests/test-different-number-streams.c
index 7fd4763..b53b167 100644
--- a/tests/test-different-number-streams.c
+++ b/tests/test-different-number-streams.c
@@ -73,6 +73,8 @@ int main (void)
guint ls_id, rs_id_1, rs_id_2;
gchar *lufrag = NULL, *lpassword = NULL;
gchar *rufrag1 = NULL, *rpassword1 = NULL, *rufrag2 = NULL, *rpassword2 = NULL;
+ NiceAddress *addr;
+
#ifdef G_OS_WIN32
WSADATA w;
@@ -80,12 +82,18 @@ int main (void)
WSAStartup(0x0202, &w);
#endif
+ /* Initialize nice agents */
+ addr = nice_address_new ();
+ nice_address_set_from_string (addr, "127.0.0.1");
+
global_mainloop = g_main_loop_new (NULL, FALSE);
/* step: create the agents L and R */
lagent = nice_agent_new (g_main_loop_get_context (global_mainloop),
NICE_COMPATIBILITY_GOOGLE);
g_debug ("lagent: %p", lagent);
+
+ nice_agent_add_local_address (lagent, addr);
nice_agent_set_software (lagent, "test-different-number-streams, Left Agent");
g_object_set (G_OBJECT (lagent), "ice-tcp", FALSE, NULL);
g_object_set (G_OBJECT (lagent), "controlling-mode", TRUE, NULL);
@@ -98,6 +106,8 @@ int main (void)
ragent = nice_agent_new (g_main_loop_get_context (global_mainloop),
NICE_COMPATIBILITY_GOOGLE);
g_debug ("ragent: %p", ragent);
+
+ nice_agent_add_local_address (ragent, addr);
nice_agent_set_software (ragent, "test-different-number-streams, Right Agent");
g_object_set (G_OBJECT (ragent), "ice-tcp", FALSE, NULL);
g_object_set (G_OBJECT (ragent), "controlling-mode", FALSE, NULL);
--
2.20.1

View File

@ -1,31 +1,21 @@
# disable building of plugin for gstreamer 0.10
%bcond_with gst010
%global upstream_date 20180504
%global upstream_rnum 85
%global upstream_hash 34d6044
Name: libnice
Version: 0.1.14
Release: 9.%{upstream_date}git%{upstream_hash}%{?dist}
Version: 0.1.15
Release: 1%{?dist}
Summary: GLib ICE implementation
License: LGPLv2 and MPLv1.1
URL: https://nice.freedesktop.org/wiki/
Source0: https://nice.freedesktop.org/releases/%{name}-%{version}.tar.gz
Patch1: libnice-0.1.14-%{upstream_rnum}-g%{upstream_hash}.patch
# make tests compile on i686
Patch2: libnice-0.1.14-tests-i686.patch
# make tests pass in Koji
Patch3: libnice-0.1.14-tests-koji.patch
Patch1: libnice-0.1.14-tests-koji.patch
# component: accept TURN in nice_component_verify_remote_candidate() (#1541646)
Patch4: libnice-0.1.14-turn-verify.patch
# upstream fix to make tests/test-different-number-streams pass
Patch2: libnice-0.1.15-tests-fix-different-number-streams.patch
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: glib2-devel
BuildRequires: gnutls-devel >= 2.12.0
BuildRequires: gobject-introspection-devel
@ -80,8 +70,6 @@ developing applications that use %{name}.
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
chmod 0755 scripts/valgrind-test-driver
# disable test-new-dribble, which sometimes hangs indefinitely, and
@ -90,8 +78,6 @@ sed -e 's/test-new-dribble/#&/' \
-e 's/test-send-recv/#&/' \
-i tests/Makefile.am
autoreconf -fiv
%build
%configure --enable-compile-warnings=yes --disable-static \
@ -151,6 +137,12 @@ make check
%changelog
* Thu May 09 2019 Stefan Becker <chemobejk@gmail.com> - 0.1.15-1
- Update to 0.1.15
- drop all upstream patches
- drop autoreconf from build
- add upstream patch to fix a test failure
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.14-9.20180504git34d6044
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (libnice-0.1.14.tar.gz) = 58bd0e0f630f4f14fe4765f2dab24215d71d61a4e7dc260cdb34eb0254b3dcdc9ce3b6fb010800250fb85f91e06b1c48cfcdd6e18867324609ead17a9106d4dd
SHA512 (libnice-0.1.15.tar.gz) = 60a8bcca06c0ab300dfabbf13e45aeac2085d553c420c5cc4d2fdeb46b449b2b9c9aee8015b0662c16bd1cecf5a49824b7e24951a8a0b66a87074cb00a619c0c