Work around autocrap failure to update Makefile

This commit is contained in:
David Woodhouse 2011-08-15 18:22:28 -06:00
parent a23a860d0a
commit 9c4ab3ca49
2 changed files with 36 additions and 2 deletions

View File

@ -36,3 +36,34 @@ index ce7f316..e3438f0 100644
--
1.7.6
--- libnice-0.1.0/nice/Makefile.in 2011-08-15 18:11:15.448626132 -0600
+++ libnice-0.1.0-ppc64/nice/Makefile.in 2011-08-15 18:10:46.301065468 -0600
@@ -271,7 +271,8 @@ ERROR_CFLAGS = \
-Wno-missing-field-initializers
# -Wold-style-definition -Winline -Wunreachable-code
-CLEANFILES = *.gcno *.gcda libnice.symbols
+CLEANFILES = *.gcno *.gcda libnice.symbols libnice-symbols-test.c \
+ libnice-symbols-test.o
lib_LTLIBRARIES = libnice.la
libnice_la_SOURCES =
libnice_la_DEPENDENCIES = \
@@ -730,9 +731,16 @@ check-valgrind:
test-symbols.sh::
chmod +x $(srcdir)/$@
-libnice.symbols: libnice.sym Makefile
+libnice-symbols-test.c: libnice.sym Makefile
rm -f $@
- while read s; do echo "T $$s"; done < $< > $@
+ while read s; do echo "void $$s(void) { }" ; done < $< > $@
+
+libnice-symbols-test.o: libnice-symbols-test.c
+ $(CC) $(CFLAGS) -c -o $@ $<
+
+libnice.symbols: libnice-symbols-test.o Makefile
+ rm -f $@
+ $(top_srcdir)/scripts/make-symbol-list.sh $< >$@
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.

View File

@ -1,6 +1,6 @@
Name: libnice
Version: 0.1.0
Release: 4%{?dist}
Release: 5%{?dist}
Summary: GLib ICE implementation
Group: System Environment/Libraries
@ -83,7 +83,10 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%changelog
* Mon Aug 16 2011 David Woodhouse <dwmw2@infradead.org> - 0.1.0-4
* Tue Aug 16 2011 David Woodhouse <dwmw2@infradead.org> - 0.1.0-5
- Apply portability patch to nice/Makefile.in too. I hate autocrap.
* Tue Aug 16 2011 David Woodhouse <dwmw2@infradead.org> - 0.1.0-4
- Fix non-portable symbol checks in nice/Makefile.am
* Fri Jun 17 2011 Peter Robinson <pbrobinson@gmail.com> - 0.1.0-3