Fix non-portable symbol checks in nice/Makefile.am

This commit is contained in:
David Woodhouse 2011-08-15 17:08:24 -06:00
parent 1be3c15797
commit a23a860d0a
2 changed files with 44 additions and 1 deletions

View File

@ -0,0 +1,38 @@
From c266ec7eac8730031e3297d144ada9654274fe47 Mon Sep 17 00:00:00 2001
From: David Woodhouse <dwmw2@infradead.org>
Date: Mon, 15 Aug 2011 15:30:36 -0400
Subject: [PATCH] Fix check-symbols test for PPC64
---
nice/Makefile.am | 13 ++++++++++---
1 files changed, 10 insertions(+), 3 deletions(-)
diff --git a/nice/Makefile.am b/nice/Makefile.am
index ce7f316..e3438f0 100644
--- a/nice/Makefile.am
+++ b/nice/Makefile.am
@@ -37,11 +37,18 @@ AM_CFLAGS = \
test-symbols.sh::
chmod +x $(srcdir)/$@
-libnice.symbols: libnice.sym Makefile
+libnice-symbols-test.c: libnice.sym Makefile
rm -f $@
- while read s; do echo "T $$s"; done < $< > $@
+ while read s; do echo "void $$s(void) { }" ; done < $< > $@
-CLEANFILES += libnice.symbols
+libnice-symbols-test.o: libnice-symbols-test.c
+ $(CC) $(CFLAGS) -c -o $@ $<
+
+libnice.symbols: libnice-symbols-test.o Makefile
+ rm -f $@
+ $(top_srcdir)/scripts/make-symbol-list.sh $< >$@
+
+CLEANFILES += libnice.symbols libnice-symbols-test.c libnice-symbols-test.o
check_SCRIPTS = test-symbols.sh
check_DATA = libnice.symbols
--
1.7.6

View File

@ -1,12 +1,13 @@
Name: libnice
Version: 0.1.0
Release: 3%{?dist}
Release: 4%{?dist}
Summary: GLib ICE implementation
Group: System Environment/Libraries
License: LGPLv2 and MPLv1.1
URL: http://nice.freedesktop.org/wiki/
Source0: http://nice.freedesktop.org/releases/%{name}-%{version}.tar.gz
Patch1: 0001-Fix-check-symbols-test-for-PPC64.patch
BuildRequires: glib2-devel
BuildRequires: gstreamer-devel
@ -38,6 +39,7 @@ developing applications that use %{name}.
%prep
%setup -q
%patch1 -p1
%check
@ -81,6 +83,9 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%changelog
* Mon Aug 16 2011 David Woodhouse <dwmw2@infradead.org> - 0.1.0-4
- Fix non-portable symbol checks in nice/Makefile.am
* Fri Jun 17 2011 Peter Robinson <pbrobinson@gmail.com> - 0.1.0-3
- rebuild for new gupnp/gssdp