Rebase along stable-1.12 branch
related: rhbz#2059288
This commit is contained in:
parent
d54f60e8f8
commit
239cf5de33
53
0001-ocaml-Add-valgrind-suppression-for-OCaml-4.14-bug.patch
Normal file
53
0001-ocaml-Add-valgrind-suppression-for-OCaml-4.14-bug.patch
Normal file
@ -0,0 +1,53 @@
|
||||
From 7d17629974bcca7caf830c7b0e7c754fa6aad180 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 19 Jun 2022 18:13:34 +0100
|
||||
Subject: [PATCH] ocaml: Add valgrind suppression for OCaml 4.14 bug
|
||||
|
||||
==3869068== Memcheck, a memory error detector
|
||||
==3869068== Copyright (C) 2002-2017, and GNU GPL'd, by Julian Seward et al.
|
||||
==3869068== Using Valgrind-3.18.1 and LibVEX; rerun with -h for copyright info
|
||||
==3869068== Command: ./test_010_import.opt
|
||||
==3869068==
|
||||
==3869068== Syscall param sigaltstack(ss) points to uninitialised byte(s)
|
||||
==3869068== at 0x49DF24B: sigaltstack (syscall-template.S:120)
|
||||
==3869068== by 0x1A1365: caml_terminate_signals (in /home/rjones/d/libnbd/ocaml/tests/test_010_import.opt)
|
||||
==3869068== by 0x1C0C33: caml_startup_common (in /home/rjones/d/libnbd/ocaml/tests/test_010_import.opt)
|
||||
==3869068== by 0x1C0CAE: caml_main (in /home/rjones/d/libnbd/ocaml/tests/test_010_import.opt)
|
||||
==3869068== by 0x15CDC1: main (in /home/rjones/d/libnbd/ocaml/tests/test_010_import.opt)
|
||||
==3869068== Address 0x1ffeffe500 is on thread 1's stack
|
||||
==3869068== in frame #1, created by caml_terminate_signals (???:)
|
||||
==3869068==
|
||||
==3869068== Syscall param sigaltstack(ss) points to uninitialised byte(s)
|
||||
==3869068== at 0x49DF24B: sigaltstack (syscall-template.S:120)
|
||||
==3869068== by 0x1A1365: caml_terminate_signals (in /home/rjones/d/libnbd/ocaml/tests/test_010_import.opt)
|
||||
==3869068== by 0x1B1B6F: caml_do_exit (in /home/rjones/d/libnbd/ocaml/tests/test_010_import.opt)
|
||||
==3869068== by 0x15CDC8: main (in /home/rjones/d/libnbd/ocaml/tests/test_010_import.opt)
|
||||
==3869068== Address 0x1ffeffe4d0 is on thread 1's stack
|
||||
==3869068== in frame #1, created by caml_terminate_signals (???:)
|
||||
|
||||
(cherry picked from commit 73dec295f3bbdf8afbfd548eb5a776dee27b0ac0)
|
||||
---
|
||||
valgrind/ocaml.suppressions | 10 ++++++++++
|
||||
1 file changed, 10 insertions(+)
|
||||
|
||||
diff --git a/valgrind/ocaml.suppressions b/valgrind/ocaml.suppressions
|
||||
index 84f8841..202ddc5 100644
|
||||
--- a/valgrind/ocaml.suppressions
|
||||
+++ b/valgrind/ocaml.suppressions
|
||||
@@ -84,3 +84,13 @@
|
||||
...
|
||||
fun:caml_setup_stack_overflow_detection
|
||||
}
|
||||
+
|
||||
+# Potential bug in OCaml 4.14
|
||||
+# https://github.com/ocaml/ocaml/issues/11335
|
||||
+{
|
||||
+ caml_terminate_signals_uninitialized_sigaltstack
|
||||
+ Memcheck:Param
|
||||
+ sigaltstack(ss)
|
||||
+ fun:sigaltstack
|
||||
+ fun:caml_terminate_signals
|
||||
+}
|
||||
--
|
||||
2.31.1
|
||||
|
55
0002-ocaml-Add-further-valgrind-suppression.patch
Normal file
55
0002-ocaml-Add-further-valgrind-suppression.patch
Normal file
@ -0,0 +1,55 @@
|
||||
From e8c83a655d47f7ca46c6e730364bca09716dca67 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Mon, 20 Jun 2022 20:24:27 +0100
|
||||
Subject: [PATCH] ocaml: Add further valgrind suppression
|
||||
|
||||
After discussion with the OCaml team we think these are both bugs in
|
||||
valgrind, not OCaml, but we still need a suppression.
|
||||
|
||||
==4145632== Syscall param sigaltstack(ss) points to uninitialised byte(s)
|
||||
==4145632== at 0xCC5E24B: sigaltstack (syscall-template.S:120)
|
||||
==4145632== by 0xD7F46CC: caml_stop_stack_overflow_detection (in /home/rjones/d/nbdkit/tests/test-ocaml-plugin.so)
|
||||
==4145632== by 0xD7F277E: caml_startup_common (in /home/rjones/d/nbdkit/tests/test-ocaml-plugin.so)
|
||||
==4145632== by 0xD7F27CC: caml_startup (in /home/rjones/d/nbdkit/tests/test-ocaml-plugin.so)
|
||||
==4145632== by 0xC986891: constructor (plugin.c:64)
|
||||
==4145632== by 0xC133CED: call_init (dl-init.c:70)
|
||||
==4145632== by 0xC133DDB: _dl_init (dl-init.c:117)
|
||||
==4145632== by 0xCD72A73: _dl_catch_exception (dl-error-skeleton.c:182)
|
||||
==4145632== by 0xC13A955: dl_open_worker (dl-open.c:808)
|
||||
==4145632== by 0xCD72A1D: _dl_catch_exception (dl-error-skeleton.c:208)
|
||||
==4145632== by 0xC13ACEB: _dl_open (dl-open.c:883)
|
||||
==4145632== by 0xCCA7EC9: dlopen_doit (dlopen.c:56)
|
||||
==4145632== by 0xCD72A1D: _dl_catch_exception (dl-error-skeleton.c:208)
|
||||
==4145632== by 0xCD72AD2: _dl_catch_error (dl-error-skeleton.c:227)
|
||||
==4145632== by 0xCCA79DE: _dlerror_run (dlerror.c:138)
|
||||
==4145632== by 0xCCA7F67: dlopen@@GLIBC_2.34 (dlopen.c:71)
|
||||
==4145632== by 0x10F775: main (main.c:833)
|
||||
==4145632== Address 0x1ffeffaca0 is on thread 1's stack
|
||||
==4145632== in frame #1, created by caml_stop_stack_overflow_detection (???:)
|
||||
|
||||
(cherry picked from nbdkit commit dba71bf2be6dbcc1585f36a6779395c9fe2cc49d)
|
||||
|
||||
(cherry picked from commit 9057e474b5de78d3a37f063ab197a5989f4294fb)
|
||||
---
|
||||
valgrind/ocaml.suppressions | 8 ++++++++
|
||||
1 file changed, 8 insertions(+)
|
||||
|
||||
diff --git a/valgrind/ocaml.suppressions b/valgrind/ocaml.suppressions
|
||||
index 202ddc5..3a660ee 100644
|
||||
--- a/valgrind/ocaml.suppressions
|
||||
+++ b/valgrind/ocaml.suppressions
|
||||
@@ -94,3 +94,11 @@
|
||||
fun:sigaltstack
|
||||
fun:caml_terminate_signals
|
||||
}
|
||||
+
|
||||
+{
|
||||
+ caml_stop_stack_overflow_detection_uninitialized_sigaltstack
|
||||
+ Memcheck:Param
|
||||
+ sigaltstack(ss)
|
||||
+ fun:sigaltstack
|
||||
+ fun:caml_stop_stack_overflow_detection
|
||||
+}
|
||||
--
|
||||
2.31.1
|
||||
|
@ -0,0 +1,33 @@
|
||||
From 5d5c8350b580333667cc3703be3638396e57c649 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 21 Jun 2022 12:21:55 +0100
|
||||
Subject: [PATCH] valgrind: Update comment about valgrind bug affecting OCaml
|
||||
|
||||
Fixes: 73dec295f3 ("ocaml: Add valgrind suppression for OCaml 4.14 bug")
|
||||
Fixes: 9057e474b5 ("ocaml: Add further valgrind suppression")
|
||||
|
||||
(cherry picked from nbdkit commit 6f1584ca76979f4e5da912c9d36fbd12ab18d8e2)
|
||||
|
||||
(cherry picked from commit 573103697c0fc214800e198f145ae40b02a4fcb5)
|
||||
---
|
||||
valgrind/ocaml.suppressions | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/valgrind/ocaml.suppressions b/valgrind/ocaml.suppressions
|
||||
index 3a660ee..6238ace 100644
|
||||
--- a/valgrind/ocaml.suppressions
|
||||
+++ b/valgrind/ocaml.suppressions
|
||||
@@ -85,8 +85,8 @@
|
||||
fun:caml_setup_stack_overflow_detection
|
||||
}
|
||||
|
||||
-# Potential bug in OCaml 4.14
|
||||
-# https://github.com/ocaml/ocaml/issues/11335
|
||||
+# Valgrind bug affecting OCaml 4.14
|
||||
+# https://bugs.kde.org/show_bug.cgi?id=455711
|
||||
{
|
||||
caml_terminate_signals_uninitialized_sigaltstack
|
||||
Memcheck:Param
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 89aec556d4942e0ecb7f6456c67cbe74f2830b7b Mon Sep 17 00:00:00 2001
|
||||
From eb49c1d99d021ed1d2389eda4c8db4be89cef6c1 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Mon, 27 Jun 2022 16:17:14 +0100
|
||||
Subject: [PATCH] copy: Print program name in some error messages
|
@ -1,4 +1,4 @@
|
||||
From 8f3ab93c07f26dd402516738b93092fe8ab2221b Mon Sep 17 00:00:00 2001
|
||||
From b1faf8da338580679545297236e4bbf824183935 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Mon, 27 Jun 2022 19:17:29 +0100
|
||||
Subject: [PATCH] lib: Display kTLS status
|
@ -1,4 +1,4 @@
|
||||
From b6a1fd0b5ddb1c3d11a539c00c9579027bd5f705 Mon Sep 17 00:00:00 2001
|
||||
From fc6dac90563ce6f456e75bb7aa13487a7aa3855a Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 28 Jun 2022 11:25:20 +0100
|
||||
Subject: [PATCH] copy/nbd-ops.c: Move related extents functions together
|
@ -1,4 +1,4 @@
|
||||
From db434ec3ced3695c594b599d460b0ee742ab1b05 Mon Sep 17 00:00:00 2001
|
||||
From 3431b727c43d77007e7c2975c2ad6763ed5e9611 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 28 Jun 2022 14:07:32 +0100
|
||||
Subject: [PATCH] copy/nbd-ops.c: Fix whitespace for indentation
|
@ -1,4 +1,4 @@
|
||||
From 35c9865521adbdac07c3788bf1bf1da5372a1caa Mon Sep 17 00:00:00 2001
|
||||
From 70337b56e672a484f39be89b79917f883204f149 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 30 Jun 2022 09:07:27 +0100
|
||||
Subject: [PATCH] Add nbddump tool
|
@ -1,4 +1,4 @@
|
||||
From 72eb6d7a6f2e90546fe9ef4823509bb1caf81c75 Mon Sep 17 00:00:00 2001
|
||||
From f157912189927f00fed9c313b2a3207e98d45564 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 30 Jun 2022 21:09:39 +0100
|
||||
Subject: [PATCH] dump: Visually separate columns 0-7 and 8-15
|
@ -1,4 +1,4 @@
|
||||
From f1227c9eb45a3f98809d54c3fb1592f93edacc4c Mon Sep 17 00:00:00 2001
|
||||
From db737715e58b653e72f94a493f87ffa7c10b6976 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 30 Jun 2022 22:27:43 +0100
|
||||
Subject: [PATCH] dump: Fix build on i686
|
@ -1,4 +1,4 @@
|
||||
From 7d44848d2db66a76834661d4a528f1a696ebf303 Mon Sep 17 00:00:00 2001
|
||||
From fba7245a2ad5259d224f035217573a9f82385d42 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 30 Jun 2022 22:31:00 +0100
|
||||
Subject: [PATCH] dump: Fix tests on Debian 10
|
@ -1,4 +1,4 @@
|
||||
From 12a1372363e804f406f9818548fd827a0a649932 Mon Sep 17 00:00:00 2001
|
||||
From d9f0d3fe17e98947052df2c41969326eac2ece41 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 30 Jun 2022 22:35:05 +0100
|
||||
Subject: [PATCH] dump/dump-data.sh: Test requires nbdkit 1.22
|
@ -1,4 +1,4 @@
|
||||
From 059728aa8e92b155efa5e1492c0f57093087a82e Mon Sep 17 00:00:00 2001
|
||||
From f50e1ee777ff34e19e978cc60133ab4fd02b3e3c Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 28 Jun 2022 18:27:58 +0100
|
||||
Subject: [PATCH] copy: Store the preferred block size in the operations struct
|
@ -1,4 +1,4 @@
|
||||
From dd222cb75c5f48e2e93042e07dd3f52b2cc048f8 Mon Sep 17 00:00:00 2001
|
||||
From 764603605a0ab7aaf3547d1669ca6bdffef0a732 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Tue, 28 Jun 2022 21:58:55 +0100
|
||||
Subject: [PATCH] copy: Use preferred block size for copying
|
@ -1,4 +1,4 @@
|
||||
From 4559b377a9931c4d82fa4dbefd1a0064595f5057 Mon Sep 17 00:00:00 2001
|
||||
From 046e18bdb4cdbaa2786f04450894bf0996dfc8d9 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sat, 2 Jul 2022 17:12:46 +0100
|
||||
Subject: [PATCH] dump: Add another example to the manual
|
31
libnbd.spec
31
libnbd.spec
@ -12,7 +12,7 @@
|
||||
|
||||
Name: libnbd
|
||||
Version: 1.12.4
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: NBD client library in userspace
|
||||
|
||||
License: LGPLv2+
|
||||
@ -32,18 +32,21 @@ Source3: copy-patches.sh
|
||||
# https://gitlab.com/nbdkit/libnbd/-/commits/rhel-9.1/
|
||||
|
||||
# Patches.
|
||||
Patch0001: 0001-copy-Print-program-name-in-some-error-messages.patch
|
||||
Patch0002: 0002-lib-Display-kTLS-status.patch
|
||||
Patch0003: 0003-copy-nbd-ops.c-Move-related-extents-functions-togeth.patch
|
||||
Patch0004: 0004-copy-nbd-ops.c-Fix-whitespace-for-indentation.patch
|
||||
Patch0005: 0005-Add-nbddump-tool.patch
|
||||
Patch0006: 0006-dump-Visually-separate-columns-0-7-and-8-15.patch
|
||||
Patch0007: 0007-dump-Fix-build-on-i686.patch
|
||||
Patch0008: 0008-dump-Fix-tests-on-Debian-10.patch
|
||||
Patch0009: 0009-dump-dump-data.sh-Test-requires-nbdkit-1.22.patch
|
||||
Patch0010: 0010-copy-Store-the-preferred-block-size-in-the-operation.patch
|
||||
Patch0011: 0011-copy-Use-preferred-block-size-for-copying.patch
|
||||
Patch0012: 0012-dump-Add-another-example-to-the-manual.patch
|
||||
Patch0001: 0001-ocaml-Add-valgrind-suppression-for-OCaml-4.14-bug.patch
|
||||
Patch0002: 0002-ocaml-Add-further-valgrind-suppression.patch
|
||||
Patch0003: 0003-valgrind-Update-comment-about-valgrind-bug-affecting.patch
|
||||
Patch0004: 0004-copy-Print-program-name-in-some-error-messages.patch
|
||||
Patch0005: 0005-lib-Display-kTLS-status.patch
|
||||
Patch0006: 0006-copy-nbd-ops.c-Move-related-extents-functions-togeth.patch
|
||||
Patch0007: 0007-copy-nbd-ops.c-Fix-whitespace-for-indentation.patch
|
||||
Patch0008: 0008-Add-nbddump-tool.patch
|
||||
Patch0009: 0009-dump-Visually-separate-columns-0-7-and-8-15.patch
|
||||
Patch0010: 0010-dump-Fix-build-on-i686.patch
|
||||
Patch0011: 0011-dump-Fix-tests-on-Debian-10.patch
|
||||
Patch0012: 0012-dump-dump-data.sh-Test-requires-nbdkit-1.22.patch
|
||||
Patch0013: 0013-copy-Store-the-preferred-block-size-in-the-operation.patch
|
||||
Patch0014: 0014-copy-Use-preferred-block-size-for-copying.patch
|
||||
Patch0015: 0015-dump-Add-another-example-to-the-manual.patch
|
||||
|
||||
%if 0%{patches_touch_autotools}
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
@ -340,7 +343,7 @@ make %{?_smp_mflags} check || {
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jul 05 2022 Richard W.M. Jones <rjones@redhat.com> - 1.12.4-2
|
||||
* Mon Jul 06 2022 Richard W.M. Jones <rjones@redhat.com> - 1.12.4-3
|
||||
- Rebase to new stable branch version 1.12.4
|
||||
resolves: rhbz#2059288
|
||||
- New tool: nbddump
|
||||
|
Loading…
Reference in New Issue
Block a user