Add nbdcopy --blkhash option
resolves: RHEL-85513
This commit is contained in:
parent
3064c5a572
commit
0d12e607e8
33
0002-copy-progress-Add-a-comment-about-size-and-pipes.patch
Normal file
33
0002-copy-progress-Add-a-comment-about-size-and-pipes.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From 6e95cddb80399429569a02c29479cb96175f0291 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sat, 29 Mar 2025 13:56:36 +0000
|
||||
Subject: [PATCH] copy: progress: Add a comment about size and pipes
|
||||
|
||||
I think this is a bug of sorts, although the progress_bar subfunctions
|
||||
happen to handle it fine. Add a comment so I remember to do something
|
||||
about this later.
|
||||
|
||||
(cherry picked from commit 363437af152d037b909de6b1ef7f91da921e073c)
|
||||
---
|
||||
copy/progress.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/copy/progress.c b/copy/progress.c
|
||||
index cc0910d6..3c010320 100644
|
||||
--- a/copy/progress.c
|
||||
+++ b/copy/progress.c
|
||||
@@ -100,6 +100,11 @@ progress_bar (off_t pos, int64_t size)
|
||||
if (size == 0)
|
||||
return;
|
||||
|
||||
+ /* XXX Synchronous mode, when the source is a pipe, passes size ==
|
||||
+ * -1 here. We should deal with this by displaying some sort of
|
||||
+ * spinner.
|
||||
+ */
|
||||
+
|
||||
pthread_mutex_lock (&lock);
|
||||
if (progress_fd == -1)
|
||||
do_progress_bar (pos, size);
|
||||
--
|
||||
2.47.1
|
||||
|
49
0003-copy-Set-the-total-size-in-bytes-copied.patch
Normal file
49
0003-copy-Set-the-total-size-in-bytes-copied.patch
Normal file
@ -0,0 +1,49 @@
|
||||
From f2f54e2dc61c7d7fbfc7ee53d70629937967e84a Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sat, 29 Mar 2025 14:00:39 +0000
|
||||
Subject: [PATCH] copy: Set the total size in bytes copied
|
||||
|
||||
Ensure that src->size contains the total size in bytes copied. There
|
||||
is (only) one place where this is not known in advance, which is when
|
||||
we are reading from a pipe.
|
||||
|
||||
(cherry picked from commit afe4f390a65a0d1b9f3625bf90c73726866e0a64)
|
||||
---
|
||||
copy/main.c | 3 +++
|
||||
copy/synch-copying.c | 6 ++++++
|
||||
2 files changed, 9 insertions(+)
|
||||
|
||||
diff --git a/copy/main.c b/copy/main.c
|
||||
index 200b7756..447dc948 100644
|
||||
--- a/copy/main.c
|
||||
+++ b/copy/main.c
|
||||
@@ -479,6 +479,9 @@ main (int argc, char *argv[])
|
||||
/* Always set the progress bar to 100% at the end of the copy. */
|
||||
progress_bar (1, 1);
|
||||
|
||||
+ /* We should always know the total size copied here. */
|
||||
+ assert (src->size >= 0);
|
||||
+
|
||||
/* Shut down the source side. */
|
||||
src->ops->close (src);
|
||||
|
||||
diff --git a/copy/synch-copying.c b/copy/synch-copying.c
|
||||
index 2f6627bf..200c97f6 100644
|
||||
--- a/copy/synch-copying.c
|
||||
+++ b/copy/synch-copying.c
|
||||
@@ -53,6 +53,12 @@ synch_copying (void)
|
||||
offset += r;
|
||||
progress_bar (offset, src->size);
|
||||
}
|
||||
+
|
||||
+ /* Record the total amount of data that was copied. In all other
|
||||
+ * cases, src->size will already be set to the true size, so here
|
||||
+ * is the only place we have to set this.
|
||||
+ */
|
||||
+ src->size = offset;
|
||||
}
|
||||
|
||||
/* Otherwise we know how much we're copying, so we can copy in whole
|
||||
--
|
||||
2.47.1
|
||||
|
@ -0,0 +1,29 @@
|
||||
From 3a4305f0f26e9a0257256fa2326ff8976cb005d0 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sat, 29 Mar 2025 21:30:26 +0000
|
||||
Subject: [PATCH] info/info-uri-nbds.sh: Fix test if compiled without GnuTLS
|
||||
|
||||
Fixes: commit 37ee81ea12eec0dafd677c439710d63579652586
|
||||
(cherry picked from commit 35683f8236adead4c76f268a67528df634394dce)
|
||||
---
|
||||
info/info-uri-nbds.sh | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/info/info-uri-nbds.sh b/info/info-uri-nbds.sh
|
||||
index 4fbfc64c..9b618fb8 100755
|
||||
--- a/info/info-uri-nbds.sh
|
||||
+++ b/info/info-uri-nbds.sh
|
||||
@@ -28,6 +28,10 @@ requires $NBDKIT null --version
|
||||
requires $NBDKIT --tls-verify-peer -U - null --run 'exit 0'
|
||||
requires jq --version
|
||||
|
||||
+# Requires that this build has TLS.
|
||||
+requires nbdsh --version
|
||||
+requires nbdsh -c 'exit(not h.supports_tls())'
|
||||
+
|
||||
# Requires that the test certificates were created.
|
||||
pki=../tests/pki
|
||||
requires test -f $pki/stamp-pki
|
||||
--
|
||||
2.47.1
|
||||
|
1111
0005-copy-Add-blkhash-option.patch
Normal file
1111
0005-copy-Add-blkhash-option.patch
Normal file
File diff suppressed because it is too large
Load Diff
12
libnbd.spec
12
libnbd.spec
@ -21,7 +21,7 @@
|
||||
|
||||
Name: libnbd
|
||||
Version: 1.22.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: NBD client library in userspace
|
||||
|
||||
License: LGPL-2.0-or-later AND BSD-3-Clause
|
||||
@ -42,6 +42,10 @@ Source3: copy-patches.sh
|
||||
|
||||
# Patches.
|
||||
Patch0001: 0001-info-Use-magenta-for-export-headings-instead-of-blac.patch
|
||||
Patch0002: 0002-copy-progress-Add-a-comment-about-size-and-pipes.patch
|
||||
Patch0003: 0003-copy-Set-the-total-size-in-bytes-copied.patch
|
||||
Patch0004: 0004-info-info-uri-nbds.sh-Fix-test-if-compiled-without-G.patch
|
||||
Patch0005: 0005-copy-Add-blkhash-option.patch
|
||||
|
||||
%if 0%{verify_tarball_signature}
|
||||
BuildRequires: gnupg2
|
||||
@ -382,12 +386,14 @@ make %{?_smp_mflags} check || {
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Mar 10 2025 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-1
|
||||
* Mon Mar 31 2025 Richard W.M. Jones <rjones@redhat.com> - 1.22.1-2
|
||||
- Rebase to libnbd 1.22.1
|
||||
- Synch spec file with Fedora Rawhide.
|
||||
- resolves: RHEL-78831
|
||||
resolves: RHEL-78831
|
||||
- Fix nbdinfo with dark theme
|
||||
resolves: RHEL-7119
|
||||
- Add nbdcopy --blkhash option
|
||||
resolves: RHEL-85513
|
||||
|
||||
* Wed Oct 30 2024 Troy Dawson <tdawson@redhat.com> - 1.20.3-2
|
||||
- Bump release for October 2024 mass rebuild:
|
||||
|
Loading…
Reference in New Issue
Block a user