new upstream version 1.4.1, nasm available on all arches, run tests with SMP
This commit is contained in:
parent
131b56142c
commit
9c2250df69
14
.gitignore
vendored
14
.gitignore
vendored
@ -1,13 +1 @@
|
||||
libjpeg-turbo-1.0.0.tar.gz
|
||||
/libjpeg-turbo-1.0.1.tar.gz
|
||||
/libjpeg-turbo-1.0.90.tar.gz
|
||||
/libjpeg-turbo-1.1.0.tar.gz
|
||||
/libjpeg-turbo-1.1.1.tar.gz
|
||||
/libjpeg-turbo-1.2.0.tar.gz
|
||||
/libjpeg-turbo-1.2.1.tar.gz
|
||||
/libjpeg-turbo-1.2.90-20130204svn922.tar.gz
|
||||
/libjpeg-turbo-1.2.90.tar.gz
|
||||
/libjpeg-turbo-1.3.0.tar.gz
|
||||
/libjpeg-turbo-1.3.1.tar.gz
|
||||
/libjpeg-turbo-1.3.90.tar.gz
|
||||
/libjpeg-turbo-1.4.0.tar.gz
|
||||
/libjpeg-turbo-*.tar.gz
|
||||
|
@ -1,15 +0,0 @@
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 2792067..bfdd7d8 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -362,10 +362,6 @@ endif
|
||||
# CC: RGB->YCC SAMP: fullsize/int FDCT: float ENT: prog huff
|
||||
./cjpeg -sample 3x2 -dct float -prog -outfile testout_3x2_float_prog.jpg $(srcdir)/testimages/testorig.ppm
|
||||
md5/md5cmp $(MD5_JPEG_3x2_FLOAT_PROG) testout_3x2_float_prog.jpg
|
||||
-# CC: YCC->RGB SAMP: fullsize/int IDCT: float ENT: prog huff
|
||||
- ./djpeg -dct float -outfile testout_3x2_float.ppm testout_3x2_float_prog.jpg
|
||||
- md5/md5cmp $(MD5_PPM_3x2_FLOAT) testout_3x2_float.ppm
|
||||
- rm testout_3x2_float.ppm testout_3x2_float_prog.jpg
|
||||
|
||||
if WITH_ARITH_ENC
|
||||
# CC: YCC->RGB SAMP: fullsize/h2v2 FDCT: islow ENT: arith
|
@ -1,22 +1,18 @@
|
||||
Name: libjpeg-turbo
|
||||
Version: 1.4.0
|
||||
Version: 1.4.1
|
||||
Release: 1%{?dist}
|
||||
Summary: A MMX/SSE2 accelerated library for manipulating JPEG image files
|
||||
License: IJG
|
||||
URL: http://sourceforge.net/projects/libjpeg-turbo
|
||||
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Patch0: libjpeg-turbo12-noinst.patch
|
||||
Patch1: libjpeg-turbo-header-files.patch
|
||||
Patch2: libjpeg-turbo-remove-test.patch
|
||||
Patch0: libjpeg-turbo14-noinst.patch
|
||||
Patch1: libjpeg-turbo-header-files.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: libtool
|
||||
|
||||
%ifarch %{ix86} x86_64
|
||||
BuildRequires: nasm
|
||||
%endif
|
||||
|
||||
Obsoletes: libjpeg < 6b-47
|
||||
# add provides (even if it not needed) to workaround bad packages, like
|
||||
@ -75,10 +71,9 @@ manipulate JPEG files using the TurboJPEG library.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .noinst
|
||||
%patch1 -p1 -b .header-files
|
||||
%patch2 -p1 -b .remove-test
|
||||
|
||||
%build
|
||||
autoreconf -fiv
|
||||
autoreconf -vif
|
||||
%configure --disable-static
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -90,7 +85,7 @@ find %{buildroot} -name "*.la" -delete
|
||||
chmod -x README-turbo.txt
|
||||
|
||||
%check
|
||||
make test
|
||||
make test %{?_smp_mflags}
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
@ -99,7 +94,7 @@ make test
|
||||
%postun -n turbojpeg -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%doc README README-turbo.txt change.log ChangeLog.txt
|
||||
%doc README README-turbo.txt ChangeLog.txt
|
||||
%{_libdir}/libjpeg.so.62*
|
||||
|
||||
%files devel
|
||||
@ -132,6 +127,11 @@ make test
|
||||
%{_libdir}/libturbojpeg.so
|
||||
|
||||
%changelog
|
||||
* Tue Jun 16 2015 Peter Robinson <pbrobinson@fedoraproject.org> 1.4.1-1
|
||||
- new upstream version 1.4.1
|
||||
- nasm available on all arches
|
||||
- run tests with SMP
|
||||
|
||||
* Tue Jan 20 2015 Petr Hracek <phracek@redhat.com> - 1.4.0-1
|
||||
- new upstream version 1.4.0 (#1180442)
|
||||
|
||||
|
@ -1,27 +1,24 @@
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index b32a41b..1758e5f 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -90,9 +90,7 @@ noinst_PROGRAMS = jcstest
|
||||
--- libjpeg-turbo-1.4.1/Makefile.am.orig 2015-06-16 19:23:23.866620985 +0100
|
||||
+++ libjpeg-turbo-1.4.1/Makefile.am 2015-06-16 19:26:38.070227353 +0100
|
||||
@@ -90,9 +90,7 @@
|
||||
|
||||
if WITH_TURBOJPEG
|
||||
|
||||
-bin_PROGRAMS += tjbench
|
||||
-
|
||||
-noinst_PROGRAMS += tjunittest
|
||||
+noinst_PROGRAMS += tjbench tjunittest
|
||||
+noinst_PROGRAMS += tjbench tjunittest
|
||||
|
||||
tjbench_SOURCES = tjbench.c bmp.h bmp.c tjutil.h tjutil.c rdbmp.c rdppm.c \
|
||||
wrbmp.c wrppm.c
|
||||
@@ -158,14 +156,6 @@ dist_man1_MANS = cjpeg.1 djpeg.1 jpegtran.1 rdjpgcom.1 wrjpgcom.1
|
||||
@@ -158,13 +156,6 @@
|
||||
DOCS= coderules.txt jconfig.txt change.log rdrle.c wrrle.c BUILDING.txt \
|
||||
ChangeLog.txt
|
||||
|
||||
-docdir = $(datadir)/doc
|
||||
-dist_doc_DATA = README README-turbo.txt libjpeg.txt structure.txt usage.txt \
|
||||
- wizard.txt
|
||||
-
|
||||
-exampledir = $(datadir)/doc
|
||||
-exampledir = $(docdir)
|
||||
-dist_example_DATA = example.c
|
||||
-
|
||||
-
|
Loading…
Reference in New Issue
Block a user