libguestfs/SOURCES/0007-RHEL-Remove-libguestfs...

56 lines
1.4 KiB
Diff

From dabee87775ee919a8ae930ca5f03c7bb4b7616e6 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 21 Dec 2012 15:50:11 +0000
Subject: [PATCH] RHEL: Remove libguestfs live (RHBZ#798980).
This isn't supported in RHEL.
Disable daemon tests that require the 'unix' backend.
---
lib/launch-unix.c | 7 +++++++
tests/Makefile.am | 3 ---
2 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/lib/launch-unix.c b/lib/launch-unix.c
index 0d344f9df..74dd1bb4a 100644
--- a/lib/launch-unix.c
+++ b/lib/launch-unix.c
@@ -37,6 +37,12 @@
static int
launch_unix (guestfs_h *g, void *datav, const char *sockpath)
{
+ error (g,
+ "launch: In RHEL, only the 'libvirt' or 'direct' method is supported.\n"
+ "In particular, \"libguestfs live\" is not supported.");
+ return -1;
+
+#if 0
int r, daemon_sock = -1;
struct sockaddr_un addr;
uint32_t size;
@@ -106,6 +112,7 @@ launch_unix (guestfs_h *g, void *datav, const char *sockpath)
g->conn = NULL;
}
return -1;
+#endif
}
static int
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 690e09b5e..919e2f248 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -328,9 +328,6 @@ EXTRA_DIST += create/test-disk-create.sh
check_DATA = daemon/captive-daemon.pm
-TESTS += \
- daemon/test-daemon-start.pl \
- daemon/test-btrfs.pl
EXTRA_DIST += \
daemon/test-daemon-start.pl \
daemon/test-btrfs.pl
--
2.31.1