libguestfs/0004-RHEL-Remove-libguestfs-live-RHBZ-798980.patch
Richard W.M. Jones 117cba40b0 Fix: syslinux: failed to create ldlinux.sys
resolves: rhbz#1990720, rhbz#1950627

Fix license files.

(cherry picked from commit 4c961db464)

Move appliance to separate subpackage
resolves: rhbz#1989514

https://bugzilla.redhat.com/show_bug.cgi?id=1989514

Move the appliance to a subpackage (libguestfs-appliance).  The main
package depends on this new subpackage so in effect nothing changes
for most users.

However this allows the appliance to be replaced if there exists a
package called "libguestfs-noappliance".  This package is not provided
anywhere, you have to provide the dependency or make the package
yourself.  But if you do this then libguestfs won't install the
appliance and you are free to replace it with (eg) a fixed appliance.

(cherry picked from commit 941da64078)
2021-08-06 09:53:04 +01:00

56 lines
1.4 KiB
Diff

From 69751394dccdf5ade209b42aa97b498b59f42010 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 21 Dec 2012 15:50:11 +0000
Subject: [PATCH] RHEL: Remove libguestfs live (RHBZ#798980).
This isn't supported in RHEL.
Disable daemon tests that require the 'unix' backend.
---
lib/launch-unix.c | 7 +++++++
tests/Makefile.am | 3 ---
2 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/lib/launch-unix.c b/lib/launch-unix.c
index 0d344f9df..74dd1bb4a 100644
--- a/lib/launch-unix.c
+++ b/lib/launch-unix.c
@@ -37,6 +37,12 @@
static int
launch_unix (guestfs_h *g, void *datav, const char *sockpath)
{
+ error (g,
+ "launch: In RHEL, only the 'libvirt' or 'direct' method is supported.\n"
+ "In particular, \"libguestfs live\" is not supported.");
+ return -1;
+
+#if 0
int r, daemon_sock = -1;
struct sockaddr_un addr;
uint32_t size;
@@ -106,6 +112,7 @@ launch_unix (guestfs_h *g, void *datav, const char *sockpath)
g->conn = NULL;
}
return -1;
+#endif
}
static int
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 690e09b5e..919e2f248 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -328,9 +328,6 @@ EXTRA_DIST += create/test-disk-create.sh
check_DATA = daemon/captive-daemon.pm
-TESTS += \
- daemon/test-daemon-start.pl \
- daemon/test-btrfs.pl
EXTRA_DIST += \
daemon/test-daemon-start.pl \
daemon/test-btrfs.pl
--
2.31.1