Add patch to diagnose Perl configure problems.
This commit is contained in:
parent
461424032b
commit
f0844aa4ac
@ -0,0 +1,25 @@
|
||||
From 610642491a4846f45c7b233060ffde46f6ca09f0 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 21 Jul 2011 17:00:48 +0100
|
||||
Subject: [PATCH] build: Send failed Perl test configure output to config.log.
|
||||
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 24de092..ed88a2e 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -781,7 +781,7 @@ AS_IF([test "x$PERL" != "xno"],
|
||||
missing_perl_modules=no
|
||||
for pm in Pod::Usage Getopt::Long Sys::Virt Data::Dumper Locale::TextDomain Win::Hivex Win::Hivex::Regedit String::ShellQuote; do
|
||||
AC_MSG_CHECKING([for $pm])
|
||||
- if ! $PERL -M$pm -e1 >/dev/null 2>&1; then
|
||||
+ if ! $PERL -M$pm -e1 >&AS_MESSAGE_LOG_FD 2>&1; then
|
||||
AC_MSG_RESULT([no])
|
||||
missing_perl_modules=yes
|
||||
else
|
||||
--
|
||||
1.7.5.2
|
||||
|
11
libguestfs-1.12.0-configure-for-patch5.patch
Normal file
11
libguestfs-1.12.0-configure-for-patch5.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- configure.orig 2011-07-21 16:53:04.508348683 +0100
|
||||
+++ configure 2011-07-21 17:00:19.706803882 +0100
|
||||
@@ -41164,7 +41164,7 @@
|
||||
for pm in Pod::Usage Getopt::Long Sys::Virt Data::Dumper Locale::TextDomain Win::Hivex Win::Hivex::Regedit String::ShellQuote; do
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $pm" >&5
|
||||
$as_echo_n "checking for $pm... " >&6; }
|
||||
- if ! $PERL -M$pm -e1 >/dev/null 2>&1; then
|
||||
+ if ! $PERL -M$pm -e1 >&5 2>&1; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
$as_echo "no" >&6; }
|
||||
missing_perl_modules=yes
|
@ -30,7 +30,7 @@ Summary: Access and modify virtual machine disk images
|
||||
Name: libguestfs
|
||||
Epoch: 1
|
||||
Version: 1.12.0
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
URL: http://libguestfs.org/
|
||||
@ -51,6 +51,10 @@ Patch2: libguestfs-1.12.0-configure-force-machine-accel-tcg.patch
|
||||
Patch3: 0001-build-Allow-make-quickcheck-test-tool-args-to-be-ove.patch
|
||||
Patch4: libguestfs-1.12.0-Makefile.in-for-patch3.patch
|
||||
|
||||
# Upstream patch to diagnose Perl configure problems.
|
||||
Patch5: 0001-build-Send-failed-Perl-test-configure-output-to-conf.patch
|
||||
Patch6: libguestfs-1.12.0-configure-for-patch5.patch
|
||||
|
||||
# Basic build requirements:
|
||||
BuildRequires: /usr/bin/pod2man
|
||||
BuildRequires: /usr/bin/pod2text
|
||||
@ -506,6 +510,8 @@ for %{name}.
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p0
|
||||
|
||||
mkdir -p daemon/m4
|
||||
|
||||
@ -871,7 +877,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jul 21 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.12.0-6
|
||||
* Thu Jul 21 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.12.0-7
|
||||
- Attempt rebuild in dist-f16-perl.
|
||||
|
||||
* Thu Jul 21 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.12.0-4
|
||||
|
Loading…
Reference in New Issue
Block a user