New /etc/virt-builder -> /etc/xdg/virt-builder configuration directories.
Remove upstream patches.
This commit is contained in:
parent
0ea8e121af
commit
d853471e38
@ -1,40 +0,0 @@
|
||||
From f108f373eacdc9436f8345d928b69c8f3035dc23 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 2 Mar 2014 12:42:34 +0000
|
||||
Subject: [PATCH] builder: Move repos configuration to
|
||||
/etc/virt-builder/repos.d/
|
||||
|
||||
---
|
||||
builder/Makefile.am | 2 +-
|
||||
builder/paths.ml | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/builder/Makefile.am b/builder/Makefile.am
|
||||
index a539e91..e3da2ca 100644
|
||||
--- a/builder/Makefile.am
|
||||
+++ b/builder/Makefile.am
|
||||
@@ -243,7 +243,7 @@ DISTCLEANFILES = .depend
|
||||
|
||||
# virt-builder's default repository
|
||||
|
||||
-repoconfdir = $(sysconfdir)/xdg/virt-builder/repos.d
|
||||
+repoconfdir = $(sysconfdir)/virt-builder/repos.d
|
||||
repoconf_DATA = libguestfs.conf libguestfs.gpg
|
||||
|
||||
# Build a small C index validator program.
|
||||
diff --git a/builder/paths.ml b/builder/paths.ml
|
||||
index e4f0c7b..2eeebeb 100644
|
||||
--- a/builder/paths.ml
|
||||
+++ b/builder/paths.ml
|
||||
@@ -35,7 +35,7 @@ let xdg_config_home ~prog =
|
||||
let xdg_config_dirs ~prog =
|
||||
let dirs =
|
||||
try Sys.getenv "XDG_CONFIG_DIRS"
|
||||
- with Not_found -> "/etc/xdg" in
|
||||
+ with Not_found -> "/etc" in
|
||||
let dirs = string_nsplit ":" dirs in
|
||||
let dirs = List.filter (fun x -> x <> "") dirs in
|
||||
List.map (fun x -> x // prog) dirs
|
||||
--
|
||||
1.8.5.3
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- builder/Makefile.in.old 2014-03-02 13:28:33.348057819 +0000
|
||||
+++ builder/Makefile.in 2014-03-02 13:28:18.482107909 +0000
|
||||
@@ -1634,7 +1634,7 @@
|
||||
DISTCLEANFILES = .depend
|
||||
|
||||
# virt-builder's default repository
|
||||
-repoconfdir = $(sysconfdir)/xdg/virt-builder/repos.d
|
||||
+repoconfdir = $(sysconfdir)/virt-builder/repos.d
|
||||
repoconf_DATA = libguestfs.conf libguestfs.gpg
|
||||
virt_index_validate_SOURCES = \
|
||||
index-parse.y \
|
@ -27,12 +27,6 @@ License: LGPLv2+
|
||||
URL: http://libguestfs.org/
|
||||
Source0: http://libguestfs.org/download/1.25-development/%{name}-%{version}.tar.gz
|
||||
|
||||
# Non-upstream patch to move virt-builder configuration files to
|
||||
# /etc/virt-builder.
|
||||
Patch1: 0001-builder-Move-repos-configuration-to-etc-virt-builder.patch
|
||||
# Automake changes in above patch.
|
||||
Patch2: automake.patch
|
||||
|
||||
# Basic build requirements:
|
||||
BuildRequires: perl(Pod::Simple)
|
||||
BuildRequires: perl(Pod::Man)
|
||||
@ -676,9 +670,6 @@ for %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p0
|
||||
|
||||
if [ "$(getenforce | tr '[A-Z]' '[a-z]')" != "disabled" ]; then
|
||||
# For sVirt to work, the local temporary directory we use in the
|
||||
# tests must be labelled the same way as /tmp.
|
||||
@ -937,10 +928,11 @@ mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/run/libguestfs
|
||||
%files tools-c
|
||||
%doc README
|
||||
%config(noreplace) %{_sysconfdir}/libguestfs-tools.conf
|
||||
%dir %{_sysconfdir}/virt-builder
|
||||
%dir %{_sysconfdir}/virt-builder/repos.d
|
||||
%config %{_sysconfdir}/virt-builder/repos.d/libguestfs.conf
|
||||
%config %{_sysconfdir}/virt-builder/repos.d/libguestfs.gpg
|
||||
%{_sysconfdir}/virt-builder
|
||||
%dir %{_sysconfdir}/xdg/virt-builder
|
||||
%dir %{_sysconfdir}/xdg/virt-builder/repos.d
|
||||
%config %{_sysconfdir}/xdg/virt-builder/repos.d/libguestfs.conf
|
||||
%config %{_sysconfdir}/xdg/virt-builder/repos.d/libguestfs.gpg
|
||||
%{_mandir}/man5/libguestfs-tools.conf.5*
|
||||
%{_bindir}/guestfish
|
||||
%{_mandir}/man1/guestfish.1*
|
||||
|
Loading…
Reference in New Issue
Block a user