Allow 'make quickcheck' args to be overridden.

This commit is contained in:
Richard W.M. Jones 2011-07-21 10:52:59 +01:00
parent 5ae60548bd
commit d7fde3e5bb
3 changed files with 50 additions and 3 deletions

View File

@ -0,0 +1,30 @@
From 806b6e01506dea4eae68ac3e468d9398d63cafcb Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 21 Jul 2011 10:50:40 +0100
Subject: [PATCH] build: Allow 'make quickcheck' test-tool args to be
overridden.
A typical use for this is for packagers who want to increase
the default timeout:
make quickcheck QUICKCHECK_TEST_TOOL_ARGS="-t 300"
---
Makefile.am | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index e1ddf0d..ca31727 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -219,7 +219,7 @@ CLEANFILES = \
# is NOT a substitute for proper testing!
quickcheck:
- ./run test-tool/libguestfs-test-tool
+ ./run test-tool/libguestfs-test-tool $(QUICKCHECK_TEST_TOOL_ARGS)
# Make binary distribution.
--
1.7.5.2

View File

@ -0,0 +1,11 @@
--- libguestfs-1.12.0/Makefile.in.orig 2011-07-21 10:53:28.852989803 +0100
+++ libguestfs-1.12.0/Makefile.in 2011-07-21 10:53:38.227163685 +0100
@@ -1873,7 +1873,7 @@
# is NOT a substitute for proper testing!
quickcheck:
- ./run test-tool/libguestfs-test-tool
+ ./run test-tool/libguestfs-test-tool $(QUICKCHECK_TEST_TOOL_ARGS)
bindist:
rm -rf $(BINTMPDIR)
mkdir $(BINTMPDIR)

View File

@ -30,7 +30,7 @@ Summary: Access and modify virtual machine disk images
Name: libguestfs
Epoch: 1
Version: 1.12.0
Release: 3%{?dist}
Release: 4%{?dist}
License: LGPLv2+
Group: Development/Libraries
URL: http://libguestfs.org/
@ -47,6 +47,10 @@ Patch1: 0001-perl-Don-t-set-CCFLAGS.patch
# Force qemu-kvm test to run with -machine accel=tcg flag.
Patch2: libguestfs-1.12.0-configure-force-machine-accel-tcg.patch
# Upstream patch to allow 'make quickcheck' args to be overridden.
Patch3: 0001-build-Allow-make-quickcheck-test-tool-args-to-be-ove.patch
Patch4: libguestfs-1.12.0-Makefile.in-for-patch3.patch
# Basic build requirements:
BuildRequires: /usr/bin/pod2man
BuildRequires: /usr/bin/pod2text
@ -500,6 +504,8 @@ for %{name}.
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
mkdir -p daemon/m4
@ -630,7 +636,7 @@ popd
%if %{runtests}
# Because of RHBZ#723555, RHBZ#723822
make quickcheck
make quickcheck QUICKCHECK_TEST_TOOL_ARGS="-t 300"
%endif
@ -863,7 +869,7 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Thu Jul 21 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.12.0-3
* Thu Jul 21 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.12.0-4
- Disable tests, use quickcheck, because of RHBZ#723555, RHBZ#723822.
* Wed Jul 20 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.12.0-2