New upstream version 1.17.4.

- Remove patch now upstream.
This commit is contained in:
Richard W.M. Jones 2012-02-01 18:16:56 +00:00
parent 33c8a61346
commit ca412b9e61
4 changed files with 8 additions and 112 deletions

1
.gitignore vendored
View File

@ -137,3 +137,4 @@ libguestfs-1.5.3.tar.gz
/libguestfs-1.17.1.tar.gz /libguestfs-1.17.1.tar.gz
/libguestfs-1.17.2.tar.gz /libguestfs-1.17.2.tar.gz
/libguestfs-1.17.3.tar.gz /libguestfs-1.17.3.tar.gz
/libguestfs-1.17.4.tar.gz

View File

@ -1,104 +0,0 @@
From 03684e7a616eab56a81665c8c8859426e50ae429 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 28 Jan 2012 17:35:34 +0000
Subject: [PATCH] ocaml: Various fixes for bytecode compilation.
Set LD_LIBRARY_PATH so we link against the just-built library, not
the installed library.
Use OCAMLCFLAGS instead of OCAMLOPTFLAGS where appropriate.
Remove unnecessary -cclib option for bytecode linking (gcc is not used
in this case).
This fixes commit eb68a314133c88260cdf4547d7d338446488e698.
---
ocaml/Makefile.am | 23 +++++++++++++++--------
1 files changed, 15 insertions(+), 8 deletions(-)
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
index 50f2649..c512d0b 100644
--- a/ocaml/Makefile.am
+++ b/ocaml/Makefile.am
@@ -102,7 +102,8 @@ noinst_DATA += \
bindtests.bc: bindtests.cmo mlguestfs.cma
mkdir -p t
- $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -cclib -L$(top_builddir)/src/.libs -I . -package unix -linkpkg mlguestfs.cma $< -o $@
+ LD_LIBRARY_PATH=../src/.libs \
+ $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -I . -package unix -linkpkg mlguestfs.cma $< -o $@
bindtests.opt: bindtests.cmx mlguestfs.cmxa
mkdir -p t
@@ -110,7 +111,8 @@ bindtests.opt: bindtests.cmx mlguestfs.cmxa
t/guestfs_005_load.bc: t/guestfs_005_load.cmo mlguestfs.cma
mkdir -p t
- $(OCAMLFIND) ocamlc $(OCAMLOPTFLAGS) -cclib -L$(top_builddir)/src/.libs -I . -package unix -linkpkg mlguestfs.cma $< -o $@
+ LD_LIBRARY_PATH=../src/.libs \
+ $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -I . -package unix -linkpkg mlguestfs.cma $< -o $@
t/guestfs_005_load.opt: t/guestfs_005_load.cmx mlguestfs.cmxa
mkdir -p t
@@ -118,7 +120,8 @@ t/guestfs_005_load.opt: t/guestfs_005_load.cmx mlguestfs.cmxa
t/guestfs_010_basic.bc: t/guestfs_010_basic.cmo mlguestfs.cma
mkdir -p t
- $(OCAMLFIND) ocamlc $(OCAMLOPTFLAGS) -cclib -L$(top_builddir)/src/.libs -I . -package unix -linkpkg mlguestfs.cma $< -o $@
+ LD_LIBRARY_PATH=../src/.libs \
+ $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -I . -package unix -linkpkg mlguestfs.cma $< -o $@
t/guestfs_010_basic.opt: t/guestfs_010_basic.cmx mlguestfs.cmxa
mkdir -p t
@@ -126,7 +129,8 @@ t/guestfs_010_basic.opt: t/guestfs_010_basic.cmx mlguestfs.cmxa
t/guestfs_070_threads.bc: t/guestfs_070_threads.cmo mlguestfs.cma
mkdir -p t
- $(OCAMLFIND) ocamlc $(OCAMLOPTFLAGS) -cclib -L$(top_builddir)/src/.libs -I . -package unix,threads -thread -linkpkg mlguestfs.cma $< -o $@
+ LD_LIBRARY_PATH=../src/.libs \
+ $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -I . -package unix,threads -thread -linkpkg mlguestfs.cma $< -o $@
t/guestfs_070_threads.opt: t/guestfs_070_threads.cmx mlguestfs.cmxa
mkdir -p t
@@ -134,7 +138,8 @@ t/guestfs_070_threads.opt: t/guestfs_070_threads.cmx mlguestfs.cmxa
t/guestfs_080_optargs.bc: t/guestfs_080_optargs.cmo mlguestfs.cma
mkdir -p t
- $(OCAMLFIND) ocamlc $(OCAMLOPTFLAGS) -cclib -L$(top_builddir)/src/.libs -I . -package unix -linkpkg mlguestfs.cma $< -o $@
+ LD_LIBRARY_PATH=../src/.libs \
+ $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -I . -package unix -linkpkg mlguestfs.cma $< -o $@
t/guestfs_080_optargs.opt: t/guestfs_080_optargs.cmx mlguestfs.cmxa
mkdir -p t
@@ -142,7 +147,8 @@ t/guestfs_080_optargs.opt: t/guestfs_080_optargs.cmx mlguestfs.cmxa
t/guestfs_400_events.bc: t/guestfs_400_events.cmo mlguestfs.cma
mkdir -p t
- $(OCAMLFIND) ocamlc $(OCAMLOPTFLAGS) -cclib -L$(top_builddir)/src/.libs -I . -package unix -linkpkg mlguestfs.cma $< -o $@
+ LD_LIBRARY_PATH=../src/.libs \
+ $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -I . -package unix -linkpkg mlguestfs.cma $< -o $@
t/guestfs_400_events.opt: t/guestfs_400_events.cmx mlguestfs.cmxa
mkdir -p t
@@ -150,7 +156,8 @@ t/guestfs_400_events.opt: t/guestfs_400_events.cmx mlguestfs.cmxa
t/guestfs_400_progress.bc: t/guestfs_400_progress.cmo mlguestfs.cma
mkdir -p t
- $(OCAMLFIND) ocamlc $(OCAMLOPTFLAGS) -cclib -L$(top_builddir)/src/.libs -I . -package unix -linkpkg mlguestfs.cma $< -o $@
+ LD_LIBRARY_PATH=../src/.libs \
+ $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -I . -package unix -linkpkg mlguestfs.cma $< -o $@
t/guestfs_400_progress.opt: t/guestfs_400_progress.cmx mlguestfs.cmxa
mkdir -p t
@@ -159,7 +166,7 @@ t/guestfs_400_progress.opt: t/guestfs_400_progress.cmx mlguestfs.cmxa
# Need to rebuild the tests from source if the main library has
# changed at all, otherwise we get inconsistent assumptions.
t/guestfs_070_threads.cmo: t/guestfs_070_threads.ml mlguestfs.cma
- $(OCAMLFIND) ocamlc $(OCAMLOPTFLAGS) -package unix,threads -thread -linkpkg -c $< -o $@
+ $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -package unix,threads -thread -linkpkg -c $< -o $@
t/guestfs_070_threads.cmx: t/guestfs_070_threads.ml mlguestfs.cmxa
$(OCAMLFIND) ocamlopt $(OCAMLOPTFLAGS) -package unix,threads -thread -linkpkg -c $< -o $@
--
1.7.6

View File

@ -29,8 +29,8 @@
Summary: Access and modify virtual machine disk images Summary: Access and modify virtual machine disk images
Name: libguestfs Name: libguestfs
Epoch: 1 Epoch: 1
Version: 1.17.3 Version: 1.17.4
Release: 2%{?dist} Release: 1%{?dist}
License: LGPLv2+ License: LGPLv2+
Group: Development/Libraries Group: Development/Libraries
URL: http://libguestfs.org/ URL: http://libguestfs.org/
@ -41,9 +41,6 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
ExclusiveArch: x86_64 ExclusiveArch: x86_64
%endif %endif
# Upstream patch to fix OCaml bytecode compilation.
Patch0001: 0001-ocaml-Various-fixes-for-bytecode-compilation.patch
# Basic build requirements: # Basic build requirements:
BuildRequires: /usr/bin/pod2man BuildRequires: /usr/bin/pod2man
BuildRequires: /usr/bin/pod2text BuildRequires: /usr/bin/pod2text
@ -626,8 +623,6 @@ for %{name}.
%prep %prep
%setup -q %setup -q
%patch0001 -p1
mkdir -p daemon/m4 mkdir -p daemon/m4
# Replace developer-specific README that ships with libguestfs, with # Replace developer-specific README that ships with libguestfs, with
@ -1026,6 +1021,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog %changelog
* Wed Feb 1 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.17.4-1
- New upstream version 1.17.4.
- Remove patch now upstream.
* Sat Jan 28 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.17.3-2 * Sat Jan 28 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.17.3-2
- New upstream version 1.17.3. - New upstream version 1.17.3.
- Remove patch now upstream. - Remove patch now upstream.

View File

@ -1 +1 @@
3b0aedbae81229ba005f85633d3935c2 libguestfs-1.17.3.tar.gz f6d1ee09fe1508956ff8117b743f7b92 libguestfs-1.17.4.tar.gz