Version 1.15.14.
This commit is contained in:
parent
a57c52f877
commit
c9bfe9cfe4
1
.gitignore
vendored
1
.gitignore
vendored
@ -127,3 +127,4 @@ libguestfs-1.5.3.tar.gz
|
||||
/libguestfs-1.15.11.tar.gz
|
||||
/libguestfs-1.15.12.tar.gz
|
||||
/libguestfs-1.15.13.tar.gz
|
||||
/libguestfs-1.15.14.tar.gz
|
||||
|
@ -1,41 +0,0 @@
|
||||
From b5f90793026832889cae3d4997810cb34777cf9a Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Fri, 23 Dec 2011 08:28:26 +0000
|
||||
Subject: [PATCH] fish: Fix test-guestfish-events.sh so it works when
|
||||
LIBGUESTFS_DEBUG=1 is set.
|
||||
|
||||
Various messages were added and changed when this variable was set
|
||||
while tests were running.
|
||||
---
|
||||
fish/test-guestfish-events.sh | 8 +-------
|
||||
1 files changed, 1 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/fish/test-guestfish-events.sh b/fish/test-guestfish-events.sh
|
||||
index ad6fefe..4d301b0 100755
|
||||
--- a/fish/test-guestfish-events.sh
|
||||
+++ b/fish/test-guestfish-events.sh
|
||||
@@ -22,7 +22,7 @@ set -e
|
||||
|
||||
rm -f test.out
|
||||
|
||||
-../fish/guestfish -a /dev/null <<'EOF' > test.out
|
||||
+../fish/guestfish -a /dev/null <<'EOF' | grep -v get_verbose | grep -v get_trace | grep -v 'library .*0x' > test.out
|
||||
trace true
|
||||
|
||||
event ev1 * "echo $EVENT $@"
|
||||
@@ -53,12 +53,6 @@ if [ "$(cat test.out)" != '"ev1" (0): *: echo $EVENT $@
|
||||
"ev1" (1): *: echo $EVENT $@
|
||||
"ev2" (2): *: echo $EVENT $@
|
||||
"ev2" (2): *: echo $EVENT $@
|
||||
-enter get_verbose
|
||||
-trace get_verbose
|
||||
-trace get_verbose = 0
|
||||
-enter get_trace
|
||||
-trace get_trace
|
||||
-trace get_trace = 1
|
||||
enter get_autosync
|
||||
trace get_autosync
|
||||
trace get_autosync = 1
|
||||
--
|
||||
1.7.6
|
||||
|
@ -1,27 +0,0 @@
|
||||
From 6067e1540fab8e8ca85e8c052bbee057882548be Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 22 Dec 2011 22:17:17 +0000
|
||||
Subject: [PATCH] tests/lvm: Contains a Perl test so we must set PERL5LIB.
|
||||
|
||||
This fixes commit 498758faee6be7e989869bf7feba5e1026a1bb65.
|
||||
---
|
||||
tests/lvm/Makefile.am | 3 ++-
|
||||
1 files changed, 2 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/tests/lvm/Makefile.am b/tests/lvm/Makefile.am
|
||||
index 290f6b3..9c4c137 100644
|
||||
--- a/tests/lvm/Makefile.am
|
||||
+++ b/tests/lvm/Makefile.am
|
||||
@@ -27,7 +27,8 @@ TESTS_ENVIRONMENT = \
|
||||
MALLOC_PERTURB_=$(random_val) \
|
||||
LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
|
||||
LIBGUESTFS_PATH=$(top_builddir)/appliance \
|
||||
- TMPDIR=$(top_builddir)
|
||||
+ TMPDIR=$(top_builddir) \
|
||||
+ PERL5LIB=$(top_builddir)/perl/blib/lib:$(top_builddir)/perl/blib/arch
|
||||
|
||||
EXTRA_DIST = \
|
||||
$(TESTS)
|
||||
--
|
||||
1.7.6
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 37aba887d7494a8d970a860e190bd77765d6b440 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 22 Dec 2011 19:12:14 +0000
|
||||
Subject: [PATCH] tests/protocol: Contains a Perl test so we must set
|
||||
PERL5LIB.
|
||||
|
||||
This fixes commit 498758faee6be7e989869bf7feba5e1026a1bb65.
|
||||
---
|
||||
tests/protocol/Makefile.am | 3 ++-
|
||||
1 files changed, 2 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/tests/protocol/Makefile.am b/tests/protocol/Makefile.am
|
||||
index 0d899dd..ce9282e 100644
|
||||
--- a/tests/protocol/Makefile.am
|
||||
+++ b/tests/protocol/Makefile.am
|
||||
@@ -32,7 +32,8 @@ TESTS_ENVIRONMENT = \
|
||||
MALLOC_PERTURB_=$(random_val) \
|
||||
LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
|
||||
LIBGUESTFS_PATH=$(top_builddir)/appliance \
|
||||
- TMPDIR=$(top_builddir)
|
||||
+ TMPDIR=$(top_builddir) \
|
||||
+ PERL5LIB=$(top_builddir)/perl/blib/lib:$(top_builddir)/perl/blib/arch
|
||||
|
||||
EXTRA_DIST = \
|
||||
$(TESTS)
|
||||
--
|
||||
1.7.6
|
||||
|
@ -29,20 +29,14 @@
|
||||
Summary: Access and modify virtual machine disk images
|
||||
Name: libguestfs
|
||||
Epoch: 1
|
||||
Version: 1.15.13
|
||||
Release: 4%{?dist}
|
||||
Version: 1.15.14
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
URL: http://libguestfs.org/
|
||||
Source0: http://libguestfs.org/download/1.15-development/%{name}-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
|
||||
# Upstream patches:
|
||||
Patch0: 0001-tests-protocol-Contains-a-Perl-test-so-we-must-set-P.patch
|
||||
Patch1: 0001-tests-lvm-Contains-a-Perl-test-so-we-must-set-PERL5L.patch
|
||||
Patch2: 0001-fish-Fix-test-guestfish-events.sh-so-it-works-when-L.patch
|
||||
BuildRequires: automake
|
||||
|
||||
%if 0%{?rhel} >= 7
|
||||
ExclusiveArch: x86_64
|
||||
%endif
|
||||
@ -594,11 +588,6 @@ for %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
automake
|
||||
|
||||
mkdir -p daemon/m4
|
||||
|
||||
# Replace developer-specific README that ships with libguestfs, with
|
||||
@ -974,6 +963,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Dec 23 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.15.14-1
|
||||
- New upstream version 1.15.14.
|
||||
- Remove three patches, now upstream.
|
||||
|
||||
* Thu Dec 22 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.15.13-4
|
||||
- New upstream version 1.15.13.
|
||||
- Fixes Security: Mitigate possible privilege escalation via SG_IO ioctl
|
||||
|
Loading…
Reference in New Issue
Block a user