- Backport supermin build fix from upstream.
- Further changes required for new layout of supermin appliance.
This commit is contained in:
parent
3a15815b2a
commit
c863b45761
38
libguestfs-1.3.12-ensure-ordinary-appliance-is-updated.patch
Normal file
38
libguestfs-1.3.12-ensure-ordinary-appliance-is-updated.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
diff -ur libguestfs-1.3.12/appliance/Makefile.am libguestfs-1.3.12.new/appliance/Makefile.am
|
||||||
|
--- libguestfs-1.3.12/appliance/Makefile.am 2010-05-13 18:30:37.000000000 +0100
|
||||||
|
+++ libguestfs-1.3.12.new/appliance/Makefile.am 2010-05-14 15:44:54.941717073 +0100
|
||||||
|
@@ -87,13 +87,13 @@
|
||||||
|
if SUPERMIN
|
||||||
|
|
||||||
|
supermin.d/base.img supermin.d/hostfiles: stamp-supermin
|
||||||
|
-stamp-supermin: $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/initramfs/init
|
||||||
|
+stamp-supermin: $(INITRAMFSIMG)
|
||||||
|
mkdir -p supermin.d
|
||||||
|
rm -f $@ supermin.d/base.img supermin.d/hostfiles
|
||||||
|
febootstrap-to-supermin $(top_builddir)/initramfs supermin.d/base.img supermin.d/hostfiles
|
||||||
|
touch $@
|
||||||
|
|
||||||
|
-supermin.d/daemon.img: $(top_builddir)/initramfs/sbin/guestfsd
|
||||||
|
+supermin.d/daemon.img: $(INITRAMFSIMG)
|
||||||
|
mkdir -p supermin.d
|
||||||
|
rm -f $@ $@-t
|
||||||
|
(cd $(top_builddir)/initramfs && \
|
||||||
|
diff -ur libguestfs-1.3.12/appliance/Makefile.in libguestfs-1.3.12.new/appliance/Makefile.in
|
||||||
|
--- libguestfs-1.3.12/appliance/Makefile.in 2010-05-14 12:19:39.000000000 +0100
|
||||||
|
+++ libguestfs-1.3.12.new/appliance/Makefile.in 2010-05-14 15:44:59.237342261 +0100
|
||||||
|
@@ -1275,13 +1275,13 @@
|
||||||
|
# to read the README file.
|
||||||
|
|
||||||
|
@SUPERMIN_TRUE@supermin.d/base.img supermin.d/hostfiles: stamp-supermin
|
||||||
|
-@SUPERMIN_TRUE@stamp-supermin: $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/initramfs/init
|
||||||
|
+@SUPERMIN_TRUE@stamp-supermin: $(INITRAMFSIMG)
|
||||||
|
@SUPERMIN_TRUE@ mkdir -p supermin.d
|
||||||
|
@SUPERMIN_TRUE@ rm -f $@ supermin.d/base.img supermin.d/hostfiles
|
||||||
|
@SUPERMIN_TRUE@ febootstrap-to-supermin $(top_builddir)/initramfs supermin.d/base.img supermin.d/hostfiles
|
||||||
|
@SUPERMIN_TRUE@ touch $@
|
||||||
|
|
||||||
|
-@SUPERMIN_TRUE@supermin.d/daemon.img: $(top_builddir)/initramfs/sbin/guestfsd
|
||||||
|
+@SUPERMIN_TRUE@supermin.d/daemon.img: $(INITRAMFSIMG)
|
||||||
|
@SUPERMIN_TRUE@ mkdir -p supermin.d
|
||||||
|
@SUPERMIN_TRUE@ rm -f $@ $@-t
|
||||||
|
@SUPERMIN_TRUE@ (cd $(top_builddir)/initramfs && \
|
@ -42,7 +42,7 @@ Summary: Access and modify virtual machine disk images
|
|||||||
Name: libguestfs
|
Name: libguestfs
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 1.3.12
|
Version: 1.3.12
|
||||||
Release: 1%{?dist}
|
Release: 3%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
URL: http://libguestfs.org/
|
URL: http://libguestfs.org/
|
||||||
@ -52,6 +52,9 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
|||||||
# Disable FUSE tests, not supported in Koji at the moment.
|
# Disable FUSE tests, not supported in Koji at the moment.
|
||||||
Patch0: libguestfs-1.0.79-no-fuse-test.patch
|
Patch0: libguestfs-1.0.79-no-fuse-test.patch
|
||||||
|
|
||||||
|
# Small build fix for supermin backported from upstream.
|
||||||
|
Patch1: libguestfs-1.3.12-ensure-ordinary-appliance-is-updated.patch
|
||||||
|
|
||||||
# Basic build requirements:
|
# Basic build requirements:
|
||||||
BuildRequires: /usr/bin/pod2man
|
BuildRequires: /usr/bin/pod2man
|
||||||
BuildRequires: /usr/bin/pod2text
|
BuildRequires: /usr/bin/pod2text
|
||||||
@ -389,6 +392,7 @@ Requires: jpackage-utils
|
|||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
mkdir -p daemon/m4
|
mkdir -p daemon/m4
|
||||||
|
|
||||||
@ -430,8 +434,8 @@ make INSTALLDIRS=vendor %{?_smp_mflags}
|
|||||||
echo "==== files in initramfs ===="
|
echo "==== files in initramfs ===="
|
||||||
find initramfs -type f
|
find initramfs -type f
|
||||||
echo "==== hostfiles ===="
|
echo "==== hostfiles ===="
|
||||||
ls -l appliance/*.supermin.hostfiles
|
ls -l appliance/supermin.d/hostfiles
|
||||||
cat appliance/*.supermin.hostfiles
|
cat appliance/supermin.d/hostfiles
|
||||||
echo "============"
|
echo "============"
|
||||||
|
|
||||||
|
|
||||||
@ -497,11 +501,7 @@ make DESTDIR=$RPM_BUILD_ROOT install
|
|||||||
|
|
||||||
# Delete the ordinary appliance, leaving just the supermin appliance.
|
# Delete the ordinary appliance, leaving just the supermin appliance.
|
||||||
rm $RPM_BUILD_ROOT%{_libdir}/guestfs/vmlinuz.*
|
rm $RPM_BUILD_ROOT%{_libdir}/guestfs/vmlinuz.*
|
||||||
mkdir keep
|
rm $RPM_BUILD_ROOT%{_libdir}/guestfs/initramfs.*
|
||||||
mv $RPM_BUILD_ROOT%{_libdir}/guestfs/initramfs.*.supermin.img keep
|
|
||||||
rm $RPM_BUILD_ROOT%{_libdir}/guestfs/initramfs.*.img
|
|
||||||
mv keep/* $RPM_BUILD_ROOT%{_libdir}/guestfs/
|
|
||||||
rmdir keep
|
|
||||||
|
|
||||||
# Delete static libraries, libtool files.
|
# Delete static libraries, libtool files.
|
||||||
rm $RPM_BUILD_ROOT%{_libdir}/libguestfs.a
|
rm $RPM_BUILD_ROOT%{_libdir}/libguestfs.a
|
||||||
@ -568,7 +568,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc COPYING
|
%doc COPYING
|
||||||
%{_bindir}/libguestfs-supermin-helper
|
|
||||||
%{_bindir}/libguestfs-test-tool
|
%{_bindir}/libguestfs-test-tool
|
||||||
%{_libdir}/guestfs/
|
%{_libdir}/guestfs/
|
||||||
%{_libdir}/libguestfs.so.*
|
%{_libdir}/libguestfs.so.*
|
||||||
@ -696,6 +695,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 14 2010 Richard W.M. Jones <rjones@redhat.com> - 1:1.3.12-3
|
||||||
|
- Backport supermin build fix from upstream.
|
||||||
|
- Further changes required for new layout of supermin appliance.
|
||||||
|
|
||||||
* Fri May 14 2010 Richard W.M. Jones <rjones@redhat.com> - 1:1.3.12-1
|
* Fri May 14 2010 Richard W.M. Jones <rjones@redhat.com> - 1:1.3.12-1
|
||||||
- New upstream version 1.3.12.
|
- New upstream version 1.3.12.
|
||||||
- febootstrap >= 2.7 is required at compile time and at runtime (at runtime
|
- febootstrap >= 2.7 is required at compile time and at runtime (at runtime
|
||||||
|
Loading…
Reference in New Issue
Block a user