New upstream version 1.15.19.
- +BR psmisc for the appliance. - Includes GObject bindings in libguestfs-gobject and libguestfs-gobject-devel subpackages.
This commit is contained in:
parent
8bfd0ff3f2
commit
c6613f1d9d
1
.gitignore
vendored
1
.gitignore
vendored
@ -132,3 +132,4 @@ libguestfs-1.5.3.tar.gz
|
||||
/libguestfs-1.15.16.tar.gz
|
||||
/libguestfs-1.15.17.tar.gz
|
||||
/libguestfs-1.15.18.tar.gz
|
||||
/libguestfs-1.15.19.tar.gz
|
||||
|
31
0001-php-Enable-make-clean-in-extension-subdirectory.patch
Normal file
31
0001-php-Enable-make-clean-in-extension-subdirectory.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 4f868b84d6e7c387e27f50aae54476bc97a70bc2 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 22 Jan 2012 14:38:07 +0000
|
||||
Subject: [PATCH 1/2] php: Enable 'make clean' in extension subdirectory.
|
||||
|
||||
---
|
||||
php/Makefile.am | 8 ++++----
|
||||
1 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/php/Makefile.am b/php/Makefile.am
|
||||
index 828960c..7652b66 100644
|
||||
--- a/php/Makefile.am
|
||||
+++ b/php/Makefile.am
|
||||
@@ -49,10 +49,10 @@ extension/config.h: extension/config.m4 ../config.status
|
||||
|
||||
TESTS = run-php-tests.sh
|
||||
|
||||
-# Amazingly the PHP-installed extension Makefile doesn't have a
|
||||
-# 'make clean' rule.
|
||||
-#clean-local:
|
||||
-# $(MAKE) -C extension clean
|
||||
+# Before PHP 5.4.0, the extension directory didn't have a 'make clean'
|
||||
+# rule. Therefore, don't die if this fails.
|
||||
+clean-local:
|
||||
+ -$(MAKE) -C extension clean
|
||||
|
||||
install-data-hook:
|
||||
$(MAKE) -C extension INSTALL_ROOT=$(DESTDIR) install
|
||||
--
|
||||
1.7.6
|
||||
|
28
0002-php-function_entry-zend_function_entry.patch
Normal file
28
0002-php-function_entry-zend_function_entry.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From 5cfd3e7b3e1a7a4031f676d5b65392c7de113164 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sun, 22 Jan 2012 14:47:43 +0000
|
||||
Subject: [PATCH 2/2] php: function_entry -> zend_function_entry.
|
||||
|
||||
function_entry was left over from PHP 3.
|
||||
|
||||
See: http://news.php.net/php.pecl.dev/7123
|
||||
---
|
||||
generator/generator_php.ml | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/generator/generator_php.ml b/generator/generator_php.ml
|
||||
index 5e7294c..6038fb7 100644
|
||||
--- a/generator/generator_php.ml
|
||||
+++ b/generator/generator_php.ml
|
||||
@@ -106,7 +106,7 @@ PHP_MINIT_FUNCTION (guestfs_php)
|
||||
NULL, PHP_GUESTFS_HANDLE_RES_NAME, module_number);
|
||||
}
|
||||
|
||||
-static function_entry guestfs_php_functions[] = {
|
||||
+static zend_function_entry guestfs_php_functions[] = {
|
||||
PHP_FE (guestfs_create, NULL)
|
||||
PHP_FE (guestfs_last_error, NULL)
|
||||
";
|
||||
--
|
||||
1.7.6
|
||||
|
@ -29,7 +29,7 @@
|
||||
Summary: Access and modify virtual machine disk images
|
||||
Name: libguestfs
|
||||
Epoch: 1
|
||||
Version: 1.15.18
|
||||
Version: 1.15.19
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
@ -41,6 +41,10 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
ExclusiveArch: x86_64
|
||||
%endif
|
||||
|
||||
# Two upstream patches for PHP 5.4.
|
||||
Patch1: 0001-php-Enable-make-clean-in-extension-subdirectory.patch
|
||||
Patch2: 0002-php-function_entry-zend_function_entry.patch
|
||||
|
||||
# Basic build requirements:
|
||||
BuildRequires: /usr/bin/pod2man
|
||||
BuildRequires: /usr/bin/pod2text
|
||||
@ -115,6 +119,7 @@ BuildRequires: ntfsprogs
|
||||
%endif
|
||||
BuildRequires: parted
|
||||
BuildRequires: procps
|
||||
BuildRequires: psmisc
|
||||
BuildRequires: reiserfs-utils
|
||||
BuildRequires: scrub
|
||||
BuildRequires: strace
|
||||
@ -170,6 +175,7 @@ Requires: ntfsprogs
|
||||
%endif
|
||||
Requires: parted
|
||||
Requires: procps
|
||||
Requires: psmisc
|
||||
Requires: reiserfs-utils
|
||||
Requires: scrub
|
||||
Requires: strace
|
||||
@ -202,6 +208,9 @@ BuildRequires: java-devel
|
||||
BuildRequires: php-devel
|
||||
BuildRequires: erlang-erts
|
||||
BuildRequires: erlang-erl_interface
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: gobject-introspection-devel
|
||||
BuildRequires: gjs
|
||||
|
||||
# For libguestfs-tools:
|
||||
BuildRequires: perl-Sys-Virt
|
||||
@ -272,6 +281,9 @@ To mount guest filesystems on the host using FUSE, install
|
||||
|
||||
For Erlang bindings, install 'erlang-libguestfs'.
|
||||
|
||||
For GObject bindings and GObject Introspection, install
|
||||
'libguestfs-gobject-devel'.
|
||||
|
||||
For Java bindings, install 'libguestfs-java-devel'.
|
||||
|
||||
For OCaml bindings, install 'ocaml-libguestfs-devel'.
|
||||
@ -578,6 +590,30 @@ Requires: erlang-erts
|
||||
erlang-%{name} contains Erlang bindings for %{name}.
|
||||
|
||||
|
||||
%package gobject
|
||||
Summary: GObject bindings for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
|
||||
%description gobject
|
||||
%{name}-gobject contains GObject bindings for %{name}.
|
||||
|
||||
To develop software against these bindings, you need to install
|
||||
%{name}-gobject-devel.
|
||||
|
||||
|
||||
%package gobject-devel
|
||||
Summary: GObject bindings for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-gobject = %{epoch}:%{version}-%{release}
|
||||
|
||||
%description gobject-devel
|
||||
%{name}-gobject contains GObject bindings for %{name}.
|
||||
|
||||
This package is needed if you want to write software using the
|
||||
GObject bindings. It also contains GObject Introspection information.
|
||||
|
||||
|
||||
%package man-pages-uk
|
||||
Summary: Ukrainian (uk) man pages for %{name}
|
||||
Group: Development/Libraries
|
||||
@ -593,6 +629,9 @@ for %{name}.
|
||||
|
||||
mkdir -p daemon/m4
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
# Replace developer-specific README that ships with libguestfs, with
|
||||
# our replacement file.
|
||||
mv README README.orig
|
||||
@ -740,6 +779,8 @@ make DESTDIR=$RPM_BUILD_ROOT install
|
||||
# Delete static libraries, libtool files.
|
||||
rm $RPM_BUILD_ROOT%{_libdir}/libguestfs.a
|
||||
rm $RPM_BUILD_ROOT%{_libdir}/libguestfs.la
|
||||
rm $RPM_BUILD_ROOT%{_libdir}/libguestfs-gobject-1.0.a
|
||||
rm $RPM_BUILD_ROOT%{_libdir}/libguestfs-gobject-1.0.la
|
||||
|
||||
find $RPM_BUILD_ROOT -name perllocal.pod -delete
|
||||
find $RPM_BUILD_ROOT -name .packlist -delete
|
||||
@ -961,6 +1002,19 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man3/guestfs-erlang.3*
|
||||
|
||||
|
||||
%files gobject
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/libguestfs-gobject-1.0.so.0*
|
||||
|
||||
|
||||
%files gobject-devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/libguestfs-gobject-1.0.so
|
||||
%{_includedir}/guestfs-gobject.h
|
||||
%{_libdir}/girepository-1.0/Guestfs-1.0.typelib
|
||||
%{_datadir}/gir-1.0/Guestfs-1.0.gir
|
||||
|
||||
|
||||
%files man-pages-uk
|
||||
%defattr(-,root,root,-)
|
||||
%lang(uk) %{_mandir}/uk/man1/*.1*
|
||||
@ -968,6 +1022,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Jan 22 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.15.19-1
|
||||
- New upstream version 1.15.19.
|
||||
- +BR psmisc for the appliance.
|
||||
- Includes GObject bindings in libguestfs-gobject and
|
||||
libguestfs-gobject-devel subpackages.
|
||||
- Include upstream patches for PHP 5.4.
|
||||
|
||||
* Thu Jan 19 2012 Richard W.M. Jones <rjones@redhat.com> - 1:1.15.18-1
|
||||
- New upstream version 1.15.18.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user