New upstream version 1.13.24.
- This version includes upstream workarounds for broken qemu, so both non-upstream patches have now been removed from Fedora.
This commit is contained in:
parent
1caa929094
commit
c23b4fcc1b
1
.gitignore
vendored
1
.gitignore
vendored
@ -110,3 +110,4 @@ libguestfs-1.5.3.tar.gz
|
||||
/libguestfs-1.13.21.tar.gz
|
||||
/libguestfs-1.13.22.tar.gz
|
||||
/libguestfs-1.13.23.tar.gz
|
||||
/libguestfs-1.13.24.tar.gz
|
||||
|
@ -1,74 +0,0 @@
|
||||
diff -ur libguestfs-1.13.22.old/src/launch.c libguestfs-1.13.22/src/launch.c
|
||||
--- libguestfs-1.13.22.old/src/launch.c 2011-10-19 16:27:38.000000000 +0100
|
||||
+++ libguestfs-1.13.22/src/launch.c 2011-10-19 18:19:32.160093691 +0100
|
||||
@@ -76,10 +76,10 @@
|
||||
static void print_qemu_command_line (guestfs_h *g, char **argv);
|
||||
static int connect_unix_socket (guestfs_h *g, const char *sock);
|
||||
static int qemu_supports (guestfs_h *g, const char *option);
|
||||
-
|
||||
-#if 0
|
||||
static int qemu_supports_re (guestfs_h *g, const pcre *option_regex);
|
||||
|
||||
+static pcre *re_machine_name;
|
||||
+
|
||||
static void compile_regexps (void) __attribute__((constructor));
|
||||
static void free_regexps (void) __attribute__((destructor));
|
||||
|
||||
@@ -97,13 +97,15 @@
|
||||
abort (); \
|
||||
} \
|
||||
} while (0)
|
||||
+
|
||||
+ COMPILE (re_machine_name, "-machine .*\\bname\\b", 0);
|
||||
}
|
||||
|
||||
static void
|
||||
free_regexps (void)
|
||||
{
|
||||
+ pcre_free (re_machine_name);
|
||||
}
|
||||
-#endif
|
||||
|
||||
/* Functions to add a string to the current command line. */
|
||||
static void
|
||||
@@ -596,14 +598,19 @@
|
||||
if (qemu_supports (g, "-nodefconfig"))
|
||||
add_cmdline (g, "-nodefconfig");
|
||||
|
||||
- /* The qemu -machine option (added 2010-12) is a bit more sane
|
||||
- * since it falls back through various different acceleration
|
||||
- * modes, so try that first (thanks Markus Armbruster).
|
||||
+ /* The qemu -machine option (added 2010-12) falls back through
|
||||
+ * various different acceleration modes, so try that first (thanks
|
||||
+ * Markus Armbruster). However in qemu commit 9052ea6bf4962b13
|
||||
+ * the syntax was changed, so we have to detect that.
|
||||
*/
|
||||
- if (qemu_supports (g, "-machine")) {
|
||||
+ if (qemu_supports_re (g, re_machine_name)) { /* after 2011-07-23 */
|
||||
+ add_cmdline (g, "-machine");
|
||||
+ add_cmdline (g, "pc,accel=kvm:tcg");
|
||||
+ }
|
||||
+ else if (qemu_supports (g, "-machine")) { /* after 2010-12 */
|
||||
add_cmdline (g, "-machine");
|
||||
add_cmdline (g, "accel=kvm:tcg");
|
||||
- } else {
|
||||
+ } else { /* no -machine option */
|
||||
/* qemu sometimes needs this option to enable hardware
|
||||
* virtualization, but some versions of 'qemu-kvm' will use KVM
|
||||
* regardless (even where this option appears in the help text).
|
||||
@@ -1254,7 +1261,6 @@
|
||||
return strstr (g->qemu_help, option) != NULL;
|
||||
}
|
||||
|
||||
-#if 0
|
||||
/* As above but using a regex instead of a fixed string. */
|
||||
static int
|
||||
qemu_supports_re (guestfs_h *g, const pcre *option_regex)
|
||||
@@ -1266,7 +1272,6 @@
|
||||
|
||||
return match (g, g->qemu_help, option_regex);
|
||||
}
|
||||
-#endif
|
||||
|
||||
/* Check if a file can be opened. */
|
||||
static int
|
@ -1,25 +0,0 @@
|
||||
Only in libguestfs-1.12.0: autom4te.cache
|
||||
diff -ur libguestfs-1.12.0.old/configure libguestfs-1.12.0/configure
|
||||
--- libguestfs-1.12.0.old/configure 2011-07-20 16:40:27.000000000 +0100
|
||||
+++ libguestfs-1.12.0/configure 2011-07-20 18:48:50.261315374 +0100
|
||||
@@ -36849,7 +36849,7 @@
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for virtio-serial support in $QEMU" >&5
|
||||
$as_echo_n "checking for virtio-serial support in $QEMU... " >&6; }
|
||||
- if $QEMU -nographic -device \? 2>&1 | grep -sq virtio-serial; then
|
||||
+ if $QEMU -machine pc,accel=tcg -nographic -device \? 2>&1 | grep -sq virtio-serial; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
$as_echo "yes" >&6; }
|
||||
else
|
||||
diff -ur libguestfs-1.12.0.old/configure.ac libguestfs-1.12.0/configure.ac
|
||||
--- libguestfs-1.12.0.old/configure.ac 2011-07-20 16:35:50.000000000 +0100
|
||||
+++ libguestfs-1.12.0/configure.ac 2011-07-20 18:48:41.251139811 +0100
|
||||
@@ -326,7 +326,7 @@
|
||||
fi
|
||||
|
||||
AC_MSG_CHECKING([for virtio-serial support in $QEMU])
|
||||
- if $QEMU -nographic -device \? 2>&1 | grep -sq virtio-serial; then
|
||||
+ if $QEMU -machine pc,accel=tcg -nographic -device \? 2>&1 | grep -sq virtio-serial; then
|
||||
AC_MSG_RESULT([yes])
|
||||
else
|
||||
AC_MSG_RESULT([no])
|
@ -29,23 +29,14 @@
|
||||
Summary: Access and modify virtual machine disk images
|
||||
Name: libguestfs
|
||||
Epoch: 1
|
||||
Version: 1.13.23
|
||||
Release: 1%{?dist}.1
|
||||
Version: 1.13.24
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
URL: http://libguestfs.org/
|
||||
Source0: http://libguestfs.org/download/1.13-development/%{name}-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
|
||||
# Force qemu-kvm test to run with -machine accel=tcg flag.
|
||||
Patch0: libguestfs-1.12.0-configure-force-machine-accel-tcg.patch
|
||||
|
||||
# Non-upstream patch to fix -machine option. This is not upstream
|
||||
# because qemu have reverted the behaviour. However the reverted
|
||||
# version is not yet in Rawhide so we have to keep this patch for a
|
||||
# while.
|
||||
Patch1: 0001-Fix-qemu-machine-option-for-latest-qemu-thanks-Marku.patch
|
||||
|
||||
# Basic build requirements:
|
||||
BuildRequires: /usr/bin/pod2man
|
||||
BuildRequires: /usr/bin/pod2text
|
||||
@ -519,9 +510,6 @@ for %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
mkdir -p daemon/m4
|
||||
|
||||
# Replace developer-specific README that ships with libguestfs, with
|
||||
@ -897,6 +885,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Oct 24 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.13.24-1
|
||||
- New upstream version 1.13.24.
|
||||
- This version includes upstream workarounds for broken qemu, so both
|
||||
non-upstream patches have now been removed from Fedora.
|
||||
|
||||
* Fri Oct 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.13.23-1.1
|
||||
- rebuild with new gmp without compat lib
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user