Add patch to fix quoting bug.
This commit is contained in:
parent
3d0ccd131d
commit
c1e38f89b5
@ -1,7 +1,7 @@
|
||||
From 7eaecf8303c229268f1f55dcb5e37ff9f0bf420d Mon Sep 17 00:00:00 2001
|
||||
From: Richard W.M. Jones <rjones@redhat.com>
|
||||
Date: Mon, 6 Dec 2010 16:46:00 +0000
|
||||
Subject: [PATCH 1/2] regressions: Disable test for 576879.
|
||||
Subject: [PATCH 1/3] regressions: Disable test for 576879.
|
||||
|
||||
This test has worked only intermittently for a while. Disable
|
||||
it. The upstream bug has been reopened.
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 461dc7038433c5183a428f88495c792a0aa4906c Mon Sep 17 00:00:00 2001
|
||||
From 968a17e0b92ed1d80ea7a694bde0fc196e7403f4 Mon Sep 17 00:00:00 2001
|
||||
From: Richard W.M. Jones <rjones@redhat.com>
|
||||
Date: Mon, 6 Dec 2010 17:44:06 +0000
|
||||
Subject: [PATCH 2/2] Add --with-febootstrap-yum-config.
|
||||
Subject: [PATCH 2/3] Add --with-febootstrap-yum-config.
|
||||
|
||||
This allows the febootstrap --yum-config option to be passed through,
|
||||
allowing a separate yum configuration to be used.
|
||||
@ -35,7 +35,7 @@ index bab0529..9e54b4a 100755
|
||||
# copied from the old febootstrap-minimize. However minimization is
|
||||
# not so important now that we are caching the appliance.
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 682fa11..a20de9b 100644
|
||||
index 682fa11..f48afa7 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -200,19 +200,15 @@ if test "x$enable_appliance" = "xyes"; then
|
||||
@ -56,7 +56,7 @@ index 682fa11..a20de9b 100644
|
||||
- PACKAGE_DIRECTORY="$local_package_directory"
|
||||
- AC_SUBST([PACKAGE_DIRECTORY])
|
||||
+ dnl Pass a febootstrap --yum-config option.
|
||||
+ AC_MSG_CHECKING([febootstrap --yum-config option])
|
||||
+ AC_MSG_CHECKING([if user requested febootstrap --yum-config option])
|
||||
+ AC_ARG_WITH([febootstrap-yum-config],
|
||||
+ [AS_HELP_STRING([--with-febootstrap-yum-config=FILE],
|
||||
+ [pass febootstrap --yum-config option @<:@default=no@:>@])],
|
||||
|
30
0003-appliance-Don-t-quote-the-exclude-parameters.patch
Normal file
30
0003-appliance-Don-t-quote-the-exclude-parameters.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 17957d047df8d690145b69d1508c8f957113f6b1 Mon Sep 17 00:00:00 2001
|
||||
From: Richard W.M. Jones <rjones@redhat.com>
|
||||
Date: Mon, 6 Dec 2010 21:24:59 +0000
|
||||
Subject: [PATCH 3/3] appliance: Don't quote the --exclude parameters.
|
||||
|
||||
The quotes appear literally on the command line:
|
||||
|
||||
$ s="--foo 'bar'"
|
||||
$ echo $s
|
||||
--foo 'bar'
|
||||
---
|
||||
appliance/make.sh.in | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/appliance/make.sh.in b/appliance/make.sh.in
|
||||
index 9e54b4a..3b51fcf 100755
|
||||
--- a/appliance/make.sh.in
|
||||
+++ b/appliance/make.sh.in
|
||||
@@ -21,7 +21,7 @@ unset CDPATH
|
||||
set -e
|
||||
|
||||
# XXX Distro-dependent in future.
|
||||
-excludes="--exclude '^perl' --exclude '^python' --exclude '^fedora-logos' --exclude '^redhat-logos' --exclude '^dracut' --exclude '^upstart' --exclude '^plymouth' --exclude '^systemd' --exclude '^linux-firmware' --exclude '^kbd-misc'"
|
||||
+excludes="--exclude ^perl --exclude ^python --exclude ^fedora-logos --exclude ^redhat-logos --exclude ^dracut --exclude ^upstart --exclude ^plymouth --exclude ^systemd --exclude ^linux-firmware --exclude ^kbd-misc"
|
||||
|
||||
# Run febootstrap on the package list.
|
||||
if [ "x@FEBOOTSTRAP_YUM_CONFIG@" != "xno" ]; then
|
||||
--
|
||||
1.7.3.2
|
||||
|
@ -30,7 +30,7 @@ Summary: Access and modify virtual machine disk images
|
||||
Name: libguestfs
|
||||
Epoch: 1
|
||||
Version: 1.7.19
|
||||
Release: 12%{?dist}
|
||||
Release: 13%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
URL: http://libguestfs.org/
|
||||
@ -44,6 +44,8 @@ Patch0: libguestfs-1.7.13-no-fuse-test.patch
|
||||
Patch1: 0001-regressions-Disable-test-for-576879.patch
|
||||
# Add --with-febootstrap-yum-config option.
|
||||
Patch2: 0002-Add-with-febootstrap-yum-config.patch
|
||||
# Fix a bug in quoting.
|
||||
Patch3: 0003-appliance-Don-t-quote-the-exclude-parameters.patch
|
||||
BuildRequires: autoconf, automake, libtool, gettext-devel
|
||||
|
||||
# Basic build requirements:
|
||||
@ -432,6 +434,7 @@ php-%{name} contains PHP bindings for %{name}.
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
aclocal -I m4
|
||||
autoreconf -i -f
|
||||
rm -f appliance/make.sh
|
||||
@ -754,7 +757,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Dec 6 2010 Richard Jones <rjones@redhat.com> - 1:1.7.19-12
|
||||
* Mon Dec 6 2010 Richard Jones <rjones@redhat.com> - 1:1.7.19-13
|
||||
- Rebuild appliance properly using febootstrap 3.1 and alternate yum repo.
|
||||
|
||||
* Sun Dec 5 2010 Richard Jones <rjones@redhat.com> - 1:1.7.19-1
|
||||
|
Loading…
Reference in New Issue
Block a user