- New upstream version 1.7.20.
- Remove patches which are upstream.
This commit is contained in:
parent
34cee5ae7c
commit
bbc5f5f8f1
1
.gitignore
vendored
1
.gitignore
vendored
@ -42,3 +42,4 @@ libguestfs-1.5.3.tar.gz
|
||||
/libguestfs-1.7.17.tar.gz
|
||||
/libguestfs-1.7.18.tar.gz
|
||||
/libguestfs-1.7.19.tar.gz
|
||||
/libguestfs-1.7.20.tar.gz
|
||||
|
@ -1,66 +0,0 @@
|
||||
From 7eaecf8303c229268f1f55dcb5e37ff9f0bf420d Mon Sep 17 00:00:00 2001
|
||||
From: Richard W.M. Jones <rjones@redhat.com>
|
||||
Date: Mon, 6 Dec 2010 16:46:00 +0000
|
||||
Subject: [PATCH 1/3] regressions: Disable test for 576879.
|
||||
|
||||
This test has worked only intermittently for a while. Disable
|
||||
it. The upstream bug has been reopened.
|
||||
---
|
||||
regressions/Makefile.am | 2 +-
|
||||
regressions/rhbz576879.sh | 14 +++++++++-----
|
||||
2 files changed, 10 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/regressions/Makefile.am b/regressions/Makefile.am
|
||||
index 10c5c48..15f6d7b 100644
|
||||
--- a/regressions/Makefile.am
|
||||
+++ b/regressions/Makefile.am
|
||||
@@ -29,7 +29,6 @@ TESTS = \
|
||||
rhbz503169c10.sh \
|
||||
rhbz503169c13.sh \
|
||||
rhbz557655.sh \
|
||||
- rhbz576879.sh \
|
||||
rhbz578407.sh \
|
||||
rhbz580246.sh \
|
||||
test-add-domain.sh \
|
||||
@@ -56,6 +55,7 @@ SKIPPED_TESTS = \
|
||||
test-bootbootboot.sh
|
||||
|
||||
FAILING_TESTS = \
|
||||
+ rhbz576879.sh \
|
||||
test-qemudie-launchfail.sh
|
||||
|
||||
random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
|
||||
diff --git a/regressions/rhbz576879.sh b/regressions/rhbz576879.sh
|
||||
index 0f44cbb..c9d7445 100755
|
||||
--- a/regressions/rhbz576879.sh
|
||||
+++ b/regressions/rhbz576879.sh
|
||||
@@ -24,17 +24,21 @@ set -e
|
||||
|
||||
rm -f test1.img
|
||||
|
||||
+# Somewhere after 1.7, the first test started to hang.
|
||||
+#
|
||||
+# Somewhere between ~ 1.5.23 and ~ 1.5.24 the second test started
|
||||
+# to hang.
|
||||
+#
|
||||
+# We don't understand why. I have disabled this test and reopened
|
||||
+# the upstream bug.
|
||||
+# -- RWMJ 2010-12-06
|
||||
+
|
||||
../fish/guestfish -N disk <<EOF
|
||||
-upload $srcdir/rhbz576879.sh /test.sh
|
||||
# Shouldn't lose synchronization, so next command should work:
|
||||
ping-daemon
|
||||
EOF
|
||||
|
||||
-# Somewhere between ~ 1.5.23 and ~ 1.5.24 the test below started to
|
||||
-# hang although we don't understand why. I have disabled this test.
|
||||
-# -- RWMJ 2010-10-27
|
||||
-exit 0
|
||||
-
|
||||
# Second patch tests the problem found in comment 5 where both ends
|
||||
# send cancel messages simultaneously.
|
||||
|
||||
--
|
||||
1.7.3.2
|
||||
|
@ -1,72 +0,0 @@
|
||||
From 968a17e0b92ed1d80ea7a694bde0fc196e7403f4 Mon Sep 17 00:00:00 2001
|
||||
From: Richard W.M. Jones <rjones@redhat.com>
|
||||
Date: Mon, 6 Dec 2010 17:44:06 +0000
|
||||
Subject: [PATCH 2/3] Add --with-febootstrap-yum-config.
|
||||
|
||||
This allows the febootstrap --yum-config option to be passed through,
|
||||
allowing a separate yum configuration to be used.
|
||||
|
||||
The hope is that this will enable building in Koji.
|
||||
---
|
||||
appliance/make.sh.in | 9 +++++----
|
||||
configure.ac | 22 +++++++++-------------
|
||||
2 files changed, 14 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/appliance/make.sh.in b/appliance/make.sh.in
|
||||
index bab0529..9e54b4a 100755
|
||||
--- a/appliance/make.sh.in
|
||||
+++ b/appliance/make.sh.in
|
||||
@@ -24,12 +24,13 @@ set -e
|
||||
excludes="--exclude '^perl' --exclude '^python' --exclude '^fedora-logos' --exclude '^redhat-logos' --exclude '^dracut' --exclude '^upstart' --exclude '^plymouth' --exclude '^systemd' --exclude '^linux-firmware' --exclude '^kbd-misc'"
|
||||
|
||||
# Run febootstrap on the package list.
|
||||
-if [ -z "@PACKAGE_DIRECTORY@" ]; then
|
||||
- @FEBOOTSTRAP@ -v -o supermin.d $excludes --names $(< packagelist )
|
||||
-else
|
||||
- @FEBOOTSTRAP@ -v -o supermin.d $excludes @PACKAGE_DIRECTORY@/*
|
||||
+if [ "x@FEBOOTSTRAP_YUM_CONFIG@" != "xno" ]; then
|
||||
+ extra="--yum-config @FEBOOTSTRAP_YUM_CONFIG@"
|
||||
fi
|
||||
|
||||
+echo @FEBOOTSTRAP@ -v -o supermin.d --names $(< packagelist ) $excludes $extra
|
||||
+@FEBOOTSTRAP@ -v -o supermin.d --names $(< packagelist ) $excludes $extra
|
||||
+
|
||||
# Remove some things that we don't want in the appliance. This is
|
||||
# copied from the old febootstrap-minimize. However minimization is
|
||||
# not so important now that we are caching the appliance.
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 682fa11..f48afa7 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -200,19 +200,15 @@ if test "x$enable_appliance" = "xyes"; then
|
||||
$FEBOOTSTRAP --version >/dev/null 2>&1 ||
|
||||
AC_MSG_ERROR([febootstrap >= 3.0 must be installed, your version is too old])
|
||||
|
||||
- dnl Build from local package files, used when building with no network
|
||||
- dnl access, ie. under Koji.
|
||||
- AC_MSG_CHECKING([if we should build the appliance from local packages])
|
||||
- AC_ARG_WITH([local-package-directory],
|
||||
- [AS_HELP_STRING([--with-local-package-directory],
|
||||
- [build from local packages in dir @<:@default=no@:>@])],
|
||||
- [local_package_directory=$withval],
|
||||
- [local_package_directory=no])
|
||||
- AC_MSG_RESULT([$local_package_directory])
|
||||
- PACKAGE_DIRECTORY=
|
||||
- test "x$local_package_directory" != "xno" &&
|
||||
- PACKAGE_DIRECTORY="$local_package_directory"
|
||||
- AC_SUBST([PACKAGE_DIRECTORY])
|
||||
+ dnl Pass a febootstrap --yum-config option.
|
||||
+ AC_MSG_CHECKING([if user requested febootstrap --yum-config option])
|
||||
+ AC_ARG_WITH([febootstrap-yum-config],
|
||||
+ [AS_HELP_STRING([--with-febootstrap-yum-config=FILE],
|
||||
+ [pass febootstrap --yum-config option @<:@default=no@:>@])],
|
||||
+ [FEBOOTSTRAP_YUM_CONFIG="$withval"],
|
||||
+ [FEBOOTSTRAP_YUM_CONFIG=no])
|
||||
+ AC_MSG_RESULT([$FEBOOTSTRAP_YUM_CONFIG])
|
||||
+ AC_SUBST([FEBOOTSTRAP_YUM_CONFIG])
|
||||
|
||||
dnl Which distro?
|
||||
dnl
|
||||
--
|
||||
1.7.3.2
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 17957d047df8d690145b69d1508c8f957113f6b1 Mon Sep 17 00:00:00 2001
|
||||
From: Richard W.M. Jones <rjones@redhat.com>
|
||||
Date: Mon, 6 Dec 2010 21:24:59 +0000
|
||||
Subject: [PATCH 3/3] appliance: Don't quote the --exclude parameters.
|
||||
|
||||
The quotes appear literally on the command line:
|
||||
|
||||
$ s="--foo 'bar'"
|
||||
$ echo $s
|
||||
--foo 'bar'
|
||||
---
|
||||
appliance/make.sh.in | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/appliance/make.sh.in b/appliance/make.sh.in
|
||||
index 9e54b4a..3b51fcf 100755
|
||||
--- a/appliance/make.sh.in
|
||||
+++ b/appliance/make.sh.in
|
||||
@@ -21,7 +21,7 @@ unset CDPATH
|
||||
set -e
|
||||
|
||||
# XXX Distro-dependent in future.
|
||||
-excludes="--exclude '^perl' --exclude '^python' --exclude '^fedora-logos' --exclude '^redhat-logos' --exclude '^dracut' --exclude '^upstart' --exclude '^plymouth' --exclude '^systemd' --exclude '^linux-firmware' --exclude '^kbd-misc'"
|
||||
+excludes="--exclude ^perl --exclude ^python --exclude ^fedora-logos --exclude ^redhat-logos --exclude ^dracut --exclude ^upstart --exclude ^plymouth --exclude ^systemd --exclude ^linux-firmware --exclude ^kbd-misc"
|
||||
|
||||
# Run febootstrap on the package list.
|
||||
if [ "x@FEBOOTSTRAP_YUM_CONFIG@" != "xno" ]; then
|
||||
--
|
||||
1.7.3.2
|
||||
|
@ -29,8 +29,8 @@
|
||||
Summary: Access and modify virtual machine disk images
|
||||
Name: libguestfs
|
||||
Epoch: 1
|
||||
Version: 1.7.19
|
||||
Release: 15%{?dist}
|
||||
Version: 1.7.20
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
URL: http://libguestfs.org/
|
||||
@ -40,14 +40,6 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
# Disable FUSE tests, not supported in Koji at the moment.
|
||||
Patch0: libguestfs-1.7.13-no-fuse-test.patch
|
||||
|
||||
# Disable test for RHBZ#576879 which wasn't working (or bug reappeared).
|
||||
Patch1: 0001-regressions-Disable-test-for-576879.patch
|
||||
# Add --with-febootstrap-yum-config option.
|
||||
Patch2: 0002-Add-with-febootstrap-yum-config.patch
|
||||
# Fix a bug in quoting.
|
||||
Patch3: 0003-appliance-Don-t-quote-the-exclude-parameters.patch
|
||||
BuildRequires: autoconf, automake, libtool, gettext-devel
|
||||
|
||||
# Basic build requirements:
|
||||
BuildRequires: /usr/bin/pod2man
|
||||
BuildRequires: /usr/bin/pod2text
|
||||
@ -430,12 +422,6 @@ php-%{name} contains PHP bindings for %{name}.
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
aclocal -I m4
|
||||
autoreconf -i -f
|
||||
rm -f appliance/make.sh
|
||||
|
||||
mkdir -p daemon/m4
|
||||
|
||||
@ -755,6 +741,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Dec 7 2010 Richard Jones <rjones@redhat.com> - 1:1.7.20-1
|
||||
- New upstream version 1.7.20.
|
||||
- Remove patches which are upstream.
|
||||
|
||||
* Tue Dec 7 2010 Richard Jones <rjones@redhat.com> - 1:1.7.19-15
|
||||
- Rebuild appliance with febootstrap 3.1-5 because we accidentally
|
||||
reopened RHBZ#654638.
|
||||
|
Loading…
Reference in New Issue
Block a user