- New upstream stable branch version 1.12.1.
- Remove 4 x upstream patches.
This commit is contained in:
parent
3b8a74a3c2
commit
a67a388e7f
1
.gitignore
vendored
1
.gitignore
vendored
@ -87,3 +87,4 @@ libguestfs-1.5.3.tar.gz
|
||||
/libguestfs-1.11.19.tar.gz
|
||||
/libguestfs-1.11.20.tar.gz
|
||||
/libguestfs-1.12.0.tar.gz
|
||||
/libguestfs-1.12.1.tar.gz
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 806b6e01506dea4eae68ac3e468d9398d63cafcb Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 21 Jul 2011 10:50:40 +0100
|
||||
Subject: [PATCH] build: Allow 'make quickcheck' test-tool args to be
|
||||
overridden.
|
||||
|
||||
A typical use for this is for packagers who want to increase
|
||||
the default timeout:
|
||||
|
||||
make quickcheck QUICKCHECK_TEST_TOOL_ARGS="-t 300"
|
||||
---
|
||||
Makefile.am | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index e1ddf0d..ca31727 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -219,7 +219,7 @@ CLEANFILES = \
|
||||
# is NOT a substitute for proper testing!
|
||||
|
||||
quickcheck:
|
||||
- ./run test-tool/libguestfs-test-tool
|
||||
+ ./run test-tool/libguestfs-test-tool $(QUICKCHECK_TEST_TOOL_ARGS)
|
||||
|
||||
# Make binary distribution.
|
||||
|
||||
--
|
||||
1.7.5.2
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 610642491a4846f45c7b233060ffde46f6ca09f0 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Thu, 21 Jul 2011 17:00:48 +0100
|
||||
Subject: [PATCH] build: Send failed Perl test configure output to config.log.
|
||||
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 24de092..ed88a2e 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -781,7 +781,7 @@ AS_IF([test "x$PERL" != "xno"],
|
||||
missing_perl_modules=no
|
||||
for pm in Pod::Usage Getopt::Long Sys::Virt Data::Dumper Locale::TextDomain Win::Hivex Win::Hivex::Regedit String::ShellQuote; do
|
||||
AC_MSG_CHECKING([for $pm])
|
||||
- if ! $PERL -M$pm -e1 >/dev/null 2>&1; then
|
||||
+ if ! $PERL -M$pm -e1 >&AS_MESSAGE_LOG_FD 2>&1; then
|
||||
AC_MSG_RESULT([no])
|
||||
missing_perl_modules=yes
|
||||
else
|
||||
--
|
||||
1.7.5.2
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- libguestfs-1.12.0/Makefile.in.orig 2011-07-21 10:53:28.852989803 +0100
|
||||
+++ libguestfs-1.12.0/Makefile.in 2011-07-21 10:53:38.227163685 +0100
|
||||
@@ -1873,7 +1873,7 @@
|
||||
# is NOT a substitute for proper testing!
|
||||
|
||||
quickcheck:
|
||||
- ./run test-tool/libguestfs-test-tool
|
||||
+ ./run test-tool/libguestfs-test-tool $(QUICKCHECK_TEST_TOOL_ARGS)
|
||||
bindist:
|
||||
rm -rf $(BINTMPDIR)
|
||||
mkdir $(BINTMPDIR)
|
@ -1,11 +0,0 @@
|
||||
--- configure.orig 2011-07-21 16:53:04.508348683 +0100
|
||||
+++ configure 2011-07-21 17:00:19.706803882 +0100
|
||||
@@ -41164,7 +41164,7 @@
|
||||
for pm in Pod::Usage Getopt::Long Sys::Virt Data::Dumper Locale::TextDomain Win::Hivex Win::Hivex::Regedit String::ShellQuote; do
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $pm" >&5
|
||||
$as_echo_n "checking for $pm... " >&6; }
|
||||
- if ! $PERL -M$pm -e1 >/dev/null 2>&1; then
|
||||
+ if ! $PERL -M$pm -e1 >&5 2>&1; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
$as_echo "no" >&6; }
|
||||
missing_perl_modules=yes
|
@ -29,8 +29,8 @@
|
||||
Summary: Access and modify virtual machine disk images
|
||||
Name: libguestfs
|
||||
Epoch: 1
|
||||
Version: 1.12.0
|
||||
Release: 11%{?dist}
|
||||
Version: 1.12.1
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
URL: http://libguestfs.org/
|
||||
@ -47,14 +47,6 @@ Patch1: 0001-perl-Don-t-set-CCFLAGS.patch
|
||||
# Force qemu-kvm test to run with -machine accel=tcg flag.
|
||||
Patch2: libguestfs-1.12.0-configure-force-machine-accel-tcg.patch
|
||||
|
||||
# Upstream patch to allow 'make quickcheck' args to be overridden.
|
||||
Patch3: 0001-build-Allow-make-quickcheck-test-tool-args-to-be-ove.patch
|
||||
Patch4: libguestfs-1.12.0-Makefile.in-for-patch3.patch
|
||||
|
||||
# Upstream patch to diagnose Perl configure problems.
|
||||
Patch5: 0001-build-Send-failed-Perl-test-configure-output-to-conf.patch
|
||||
Patch6: libguestfs-1.12.0-configure-for-patch5.patch
|
||||
|
||||
# Basic build requirements:
|
||||
BuildRequires: /usr/bin/pod2man
|
||||
BuildRequires: /usr/bin/pod2text
|
||||
@ -508,10 +500,6 @@ for %{name}.
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p0
|
||||
|
||||
mkdir -p daemon/m4
|
||||
|
||||
@ -877,6 +865,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jul 26 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.12.1-1
|
||||
- New upstream stable branch version 1.12.1.
|
||||
- Remove 4 x upstream patches.
|
||||
|
||||
* Tue Jul 26 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.12.0-11
|
||||
- Bump and rebuild.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user