configure: Use Python platform-dependent site-packages.

This commit is contained in:
Richard W.M. Jones 2011-05-09 16:32:52 +01:00
parent 64eda6549a
commit a1ae78b8d3
2 changed files with 36 additions and 1 deletions

View File

@ -0,0 +1,26 @@
From 03a8e3fc8eba11abb47a9f6f627b8d49076b1049 Mon Sep 17 00:00:00 2001
From: Richard W.M. Jones <rjones@redhat.com>
Date: Mon, 9 May 2011 16:30:30 +0100
Subject: [PATCH] configure: Use Python platform-dependent site-packages.
This updates commit c446e6e26e317e105870b0ab25fb082887e23bf6.
---
configure.ac | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/configure.ac b/configure.ac
index a746256..c8e5642 100644
--- a/configure.ac
+++ b/configure.ac
@@ -558,7 +558,7 @@ AS_IF([test "x$enable_python" != "xno"],
AC_MSG_CHECKING([for Python site-packages path])
if test -z "$PYTHON_INSTALLDIR"; then
PYTHON_INSTALLDIR=`$PYTHON -c "import distutils.sysconfig; \
- print (distutils.sysconfig.get_python_lib(0,0));"`
+ print (distutils.sysconfig.get_python_lib(1,0));"`
fi
AC_MSG_RESULT([$PYTHON_INSTALLDIR])
fi
--
1.7.5

View File

@ -30,7 +30,7 @@ Summary: Access and modify virtual machine disk images
Name: libguestfs
Epoch: 1
Version: 1.11.5
Release: 1%{?dist}
Release: 2%{?dist}
License: LGPLv2+
Group: Development/Libraries
URL: http://libguestfs.org/
@ -40,6 +40,10 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
# Disable FUSE tests, not supported in Koji at the moment.
Patch0: libguestfs-1.7.13-no-fuse-test.patch
# configure: Use Python platform-dependent site-packages.
Patch1: 0001-configure-Use-Python-platform-dependent-site-package.patch
BuildRequires: autoconf, automake, libtool, gettext
# Basic build requirements:
BuildRequires: /usr/bin/pod2man
BuildRequires: /usr/bin/pod2text
@ -434,6 +438,8 @@ php-%{name} contains PHP bindings for %{name}.
%setup -q
%patch0 -p1
%patch1 -p1
autoconf
mkdir -p daemon/m4
@ -772,6 +778,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Mon May 9 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.11.5-2
- configure: Use Python platform-dependent site-packages.
* Mon May 9 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.11.5-1
- New upstream version 1.11.5.
- virt-edit has been rewritten in C, therefore this tool has been moved